Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 85754 - wvdial/gnome-ppp unable to set serial speed of ltmodem
Summary: wvdial/gnome-ppp unable to set serial speed of ltmodem
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Dialup Developers
Depends on:
Reported: 2005-03-18 04:12 UTC by Steven Picken
Modified: 2005-03-29 04:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Steven Picken 2005-03-18 04:12:36 UTC
When I try to use this modem, both gnome-ppp and wvdial tell me:

--> WvDial: Internet dialer version 1.54.0
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.

I have checked all the bugs I can find on, but even after re-emerging wvstreams-4.0.1, wvstreams-4.0.1-rc1, wvstreams-4.0.1-rc2, the issue continues.

the system was built with kernel26-headers, but I double checked by doing emerge -C kernel-headers (which failed because it wasn't installed)

Reproducible: Always
Steps to Reproduce:
1. emerge ltmodem
2. echo "ltmodem" >> /etc/modules.autoload.d/kernel-2.6
3. echo "ltserial" >> /etc/modules.autoload.d/kernel-2.6
4. modprobe ltmodem
5. modprobe ltserial
6. emerge wvdial
7. emerge gnome-ppp
8. ln -sf /dev/ttyLT0 /dev/modem
9. gnome-ppp
10. (configure gnome ppp using all defaults, changed username, password and phone number)
11. connect
Actual Results:  
Connection failed, the log output this:
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.
--> Cannot open /dev/ttyLT0: Cannot set information for serial port.

Expected Results:  
connected to the internet

Portage (default-linux/x86/2004.3, gcc-3.3.5, glibc-,
2.6.10-gentoo-r6-Initial i686)
System uname: 2.6.10-gentoo-r6-Initial i686 AMD Duron(tm) processor
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 14 2005, 03:15:14)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/libtool:   1.5.10-r4
CFLAGS="-O2 -march=athlon -fomit-frame-pointer -pipe -mmmx -m3dnow"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon -fomit-frame-pointer -pipe -mmmx -m3dnow"
FEATURES="autoaddcvs autoconfig buildpkg ccache distcc distlocks sandbox sfperms"
USE="x86 3dnow X Xaw3d aac acpi aim alsa apache2 apm arts audiofile avi bcmath
berkdb bitmap-fonts bonobo bzlib calendar cdr cpdflib crypt ctype cups curl
curlwrappers dga directfb dv encode esd exif expat fam fbcon fdftk ffmpeg fftw
flash font-server foomaticdb ftp gd gdbm gif glut gnome gphoto2 gpm gtk gtk2
gtkhtml guile iconv icq imagemagick imlib java javascript jikes jpeg junit lcms
libedit libg++ libwww mad mcal mhash mime ming mmap mmx mng motif mp3 mpeg mpi
msn mysql mysqli ncurses nls nocd nptl oggvorbis openal opengl oss pam pcre
pdflib perl php pic pie png posix ppds python readline samba sdl sharedmem
simplexml slang sndfile spell ssl svg svga symlink sysvipc szip tcltk tcpd
threads tidy tiff truetype truetype-fonts type1-fonts unicode usb v4l wmf xml2
xmlrpc xmms xpm xv yahoo zlib"
Comment 1 Alin Năstac (RETIRED) gentoo-dev 2005-03-18 04:57:10 UTC
first, make sure you have net-libs/wvstreams-4.0.1-r2.
next, try to run as normal user. of course, your user should have full access to /dev/ttyLT0 and /var/lock. does it work?

Comment 2 Alin Năstac (RETIRED) gentoo-dev 2005-03-24 22:47:44 UTC
well? did it worked?
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2005-03-28 15:54:06 UTC
the reporter has vanished
Comment 4 Steven Picken 2005-03-29 00:34:54 UTC
My appologies, I had to leave this issue when I left town for a few days.

Your suggestions above worked fine, but I hit another unrelated issue. My friend ended up buying an external modem instead.

Thanks for your help.
Comment 5 Alin Năstac (RETIRED) gentoo-dev 2005-03-29 04:13:34 UTC
this bug has been fixed in wvstreams-4.0.2. 
if anyone need to run wvdial/gnome-ppp as root for starting its ltmodem, he/she should use >=net-libs/wvstreams-4.0.2