Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 853946 - app-text/zathura-0.4.9 - meson.build: ERROR: declare_dependency keyword argument link_with was of type array[Executable] but shoul
Summary: app-text/zathura-0.4.9 - meson.build: ERROR: declare_dependency keyword argum...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Piotr Karbowski
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-23 20:50 UTC by Toralf Förster
Modified: 2022-12-30 18:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.88 KB, text/plain)
2022-06-23 20:50 UTC, Toralf Förster
Details
app-text:zathura-0.4.9:20220623-202922.log (app-text:zathura-0.4.9:20220623-202922.log,4.69 KB, text/plain)
2022-06-23 20:50 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,29.99 KB, text/plain)
2022-06-23 20:50 UTC, Toralf Förster
Details
environment (environment,102.00 KB, text/plain)
2022-06-23 20:50 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,8.33 KB, application/x-bzip)
2022-06-23 20:51 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,6.30 KB, application/x-bzip)
2022-06-23 20:51 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,24.48 KB, application/x-bzip)
2022-06-23 20:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-06-23 20:50:55 UTC
Program msginit found: YES (/usr/bin/msginit)
Program msgmerge found: YES (/usr/bin/msgmerge)
Program xgettext found: YES (/usr/bin/xgettext)

meson.build:204:0: ERROR: declare_dependency keyword argument 'link_with' was of type array[Executable] but should have been array[BothLibraries | SharedLibrary | StaticLibrary | CustomTarget | CustomTargetIndex | Jar | Dependency]

A full log can be found at /var/tmp/portage/app-text/zathura-0.4.9/work/zathura-0.4.9-build/meson-logs/meson-log.txt

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no_multilib_systemd-j4-20220623-150004

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.1.1 *
clang/llvm (if any):
/usr/lib/llvm/14
14.0.5
Python 3.9.13
Available Ruby profiles:
  [1]   ruby31 *
Available Rust versions:
  [1]   rust-1.61.0 *
The following VMs are available for generation-2:
*)	Eclipse Temurin JDK 17.0.3_p7 [openjdk-bin-17]
Available Java Virtual Machines:
  [1]   openjdk-bin-17  system-vm

php cli:

  HEAD of ::gentoo
commit 34dabb8db14a520b43cf7f88bdec15de715b33ba
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Thu Jun 23 20:17:50 2022 +0000

    2022-06-23 20:17:49 UTC

emerge -qpvO app-text/zathura
[ebuild  N    ] app-text/zathura-0.4.9  USE="magic seccomp -doc -sqlite -synctex -test"
Comment 1 Toralf Förster gentoo-dev 2022-06-23 20:50:56 UTC
Created attachment 787232 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-06-23 20:50:57 UTC
Created attachment 787235 [details]
app-text:zathura-0.4.9:20220623-202922.log
Comment 3 Toralf Förster gentoo-dev 2022-06-23 20:50:58 UTC
Created attachment 787238 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2022-06-23 20:50:59 UTC
Created attachment 787241 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2022-06-23 20:51:01 UTC
Created attachment 787244 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-06-23 20:51:01 UTC
Created attachment 787247 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2022-06-23 20:51:02 UTC
Created attachment 787250 [details]
temp.tar.bz2
Comment 8 Eli Schwartz 2022-06-23 22:26:24 UTC
Excellent, the release candidate testing works. :)

This is a known regression in rc1, fixed in https://github.com/mesonbuild/meson/commit/b05d7db44359c4e5bf7816d68e8bb556fd1e4724
Comment 9 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2022-12-30 18:25:53 UTC
That looks like its a meson issue and not zathura itself. I cannot reproduce it whatsoever so I will close as INVALID. If however I got it wrong, let me know and reopen it. Thanks.
Comment 10 Eli Schwartz 2022-12-30 18:31:01 UTC
No, that's correct. It was a bug that got introduced in Meson 0.63 release candidates, and thereafter fixed in time for final release.

I appreciate Gentoo's willingness to do tinderbox tests with testing prereleases of Meson, it's really helpful. ;)