Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 84586 - gtk apps die with `PANGO_IS_FONT (font)' failed or similar
Summary: gtk apps die with `PANGO_IS_FONT (font)' failed or similar
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 93690 (view as bug list)
Depends on:
Reported: 2005-03-08 19:45 UTC by Jonathan Nicol
Modified: 2005-07-29 17:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Nicol 2005-03-08 19:45:52 UTC
After running emerge -u world, bluefish now crashes. The splash window appears, and then it crashes.

The relevant packages updated were:

dev-libs/glib-2.4.8  -> dev-libs/glib-2.6.2-r1
x11-libs/pango-1.6.0 -> x11-libs/pango-1.8.0
x11-libs/gtk+-2.4.14 -> x11-libs/gtk+-2.6.2 

I have tried re-emerging all of these individually, as well as bluefish itself. I also rebuilt libpcre-5.0 and atk-1.8.0, but the problem persists.

Reproducible: Always
Steps to Reproduce:
1.emerge -u world bluefish

Actual Results:  
Here is the error output from bluefish:

(bluefish:27389): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed
(bluefish:27389): Pango-CRITICAL **: _pango_engine_shape_covers: assertion
`PANGO_IS_FONT (font)' failed
(bluefish:27389): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed
(bluefish:27389): Pango-CRITICAL **: _pango_engine_shape_shape: assertion
`PANGO_IS_FONT (font)' failed
Pango-ERROR **: file shape.c: line 75 (pango_shape): assertion failed:
(glyphs->num_glyphs > 0)

Portage (default-linux/x86/2004.0, gcc-3.3.5, glibc-,
2.6.10-gentoo-r6 i686)
System uname: 2.6.10-gentoo-r6 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1,dev-lang/python-2.2.3-r5 [2.3.4
(#1, Feb 15 2005, 04:15:51)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1, 2.2.3-r5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.9.4, 1.5, 1.8.5-r3, 1.6.3, 1.7.9-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.19-r1, 2.6.4, 2.4.21-r1
CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb
/usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms"
USE="x86 X aalib acpi aim alsa apm auctex avi berkdb bitmap-fonts bonobo cddb
cdparanoia cdr crypt cscope cups curl dga directfb distcc divx4linux dvd dvdr
emboss encode esd f77 fam flac font-server foomaticdb gb gd gdbm ggi gif
gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile imagemagick imap
imlib java jpeg kerberos krb4 libg++ libwww mad matroska mbox mikmod mmx motif
mozilla moznocompose moznoirc moznomail moznoxft mp3 mpeg nagios-dns nagios-ntp
nagios-ping nagios-ssh ncurses nls nvidia oggvorbis opengl oss pam pdflib perl
png ppds prelude python quicktime readline samba sasl scanner sdl slang snmp
speex spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts
type1-fonts usb wmf xml xml2 xmms xv xvid zlib"
Comment 1 Jonathan Nicol 2005-03-08 21:10:44 UTC
I changed my Gnome Application font from "ClearlyU PUA" to "Bitstream Vera Sans" and now it works! Why does ClearlyU break bluefish in this way??
Comment 2 foser (RETIRED) gentoo-dev 2005-03-09 02:08:53 UTC
where does the font come from ?
What if you use pango 1.8.1 instead ?
Comment 3 Jonathan Nicol 2005-03-09 04:13:24 UTC
The font seems to be included in

# equery belongs cu-pua12.pcf.gz
[ Searching for file(s) cu-pua12.pcf.gz in *... ]
x11-base/xorg-x11-6.8.0-r4 (/usr/share/fonts/misc/cu-pua12.pcf.gz)

The problem still exists with pango-1.8.1.

However, when I switched back to this font to test 1.8.1, I *didn't recognize it*. Despite this font being set, and it causing this bluefish crash, it apparently wasn't ever being rendered. This is a can of worms I don't really want to open, so I'm going to continue using Bitstream Vera Sans and leave it at that. Bluefish is working now, and that was the important part. However, if you consider this a bug worth investigating, let me know if there's anything you'd like me to do. Thanks either way.
Comment 4 John N. Laliberte (RETIRED) gentoo-dev 2005-06-24 20:17:11 UTC
*** Bug 93690 has been marked as a duplicate of this bug. ***
Comment 5 John N. Laliberte (RETIRED) gentoo-dev 2005-06-24 20:19:58 UTC
this bug seems to be somewhat widespread, i keep seeing it in different places (
and more people reported in the gentoo forums thread ):

heres some links so i don't lose them / can check them later on:

it actually looks like they have fixed the problem in the newest version of
pango with a one line fix ( on the 14th of this month ):

I will look into backporting this patch tommorrow.
Comment 6 John N. Laliberte (RETIRED) gentoo-dev 2005-06-25 08:14:41 UTC
i just commited 1.8.1-r1 with a patch that supposedly fixes this issue.  

could you guys please try emerging this version and see if the problem goes away?  

Comment 7 MT 2005-06-26 10:46:42 UTC
i have just recompiled pango to the 1.8.1-r1 and the problem seem fixed, is
about 1 hour that i'm playing with gtk scrooling windows and they don't break.
Comment 8 John N. Laliberte (RETIRED) gentoo-dev 2005-06-27 11:13:31 UTC
can the reporter( jnicol) confirm that the patch works for him?
Comment 9 John N. Laliberte (RETIRED) gentoo-dev 2005-07-29 17:07:43 UTC
-r1 is now stable.