Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 84428 - ntop segfault after a while
Summary: ntop segfault after a while
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 155761 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-07 13:02 UTC by hall
Modified: 2006-01-12 02:31 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hall 2005-03-07 13:02:09 UTC
hi.
I've recently installed ntop and it ends with segfault after a little while (1min approx). Unfortunattely running in debug mode don't produce any verbose info. note I'm running smp system.

ntop:
v.3.0 SourceForge .tgz MT (SSL) (configured on Mar  7 2005  8:18:41, built on Mar  7 2005 08:19:20)

emerge:
Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11 i686)
=================================================================
System uname: 2.6.11 i686 Intel(R) Xeon(TM) CPU 2.80GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  8 2005, 17:00:10)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -fomit-frame-pointer -funroll-loops -ftracer -mmmx -msse -msse2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -fomit-frame-pointer -funroll-loops -ftracer -mmmx -msse -msse2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X Xaw3d aalib acpi alsa audiofile avi bash-completion bzlib cairo calendar cdparanoia cross crypt cups dga dio directfb divx4linux dvb dvd dvdr encode ethereal exif extensions fbcon font-server fpx ftp gif gimpprint glut gnome gpm gtk gtk2 i8x0 icq ieee1394 imagemagick imap java jpeg lcms libcaca live lzo mad mhash mime mmx mmx2 mozilla mp3 mpeg mpi ncurses network nfs nls nptl nvidia oggvorbis openal opengl pam perl png ppds python qt quicktime readline real recode rtc sdl shared sharedmem smp sse sse2 ssl svg szip tga theora threads tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 videos wmf xanim xinerama xml xml2 xmms xosd xpm xv xvid xvmc zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY




Reproducible: Always
Steps to Reproduce:
1.ntop
2.
3.




If I can provide any more info on that just let me know.
Comment 1 Eldad Zack (RETIRED) gentoo-dev 2005-03-14 02:03:31 UTC
Can you please emerge using CFLAGS="-march=pentium4" only?
Comment 2 hall 2005-03-14 17:57:13 UTC
ok.
I've tried that as well as CFLAGS="" and cvs version. neither one worked.

here is tail of strace, note this is a SMP system.

nanosleep({10, 0}, Mon Mar 14 20:49:50 2005  CHKVER: Version file is from 'version.ntop.org'
Mon Mar 14 20:49:50 2005  CHKVER: as of date is '2004-12-01T17:00:00'
Mon Mar 14 20:49:50 2005  CHKVER: This version of ntop is a minimally supported but OLDER version - please upgrade
{10, 0})             = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
time(NULL)                              = 1110851399
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_IGN}, 8) = 0
nanosleep({10, 0}, {10, 0})             = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
time(NULL)                              = 1110851409
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_IGN}, 8) = 0
nanosleep({10, 0}, 0xbfffeb04)          = ? ERESTART_RESTARTBLOCK (To be restarted)
+++ killed by SIGSEGV +++
Comment 3 Aaron Walker (RETIRED) gentoo-dev 2005-03-15 02:22:24 UTC
strace output is usually (although not necessarily in this case) fairly useless when it comes to these kinds of bugs.

Can you use strace -o and then either a) attach the file here or b) put the file elsewhere and post a link to it?  It's hard looking at just the last 10 lines, as you really have no context.

Also, even better than strace output (in addition to, not in leu of the strace), can you get a gdb backtrace?  If you don't know how and would like me to explain to you how to go about getting one, don't hesitate to ask.
Comment 4 rob holland (RETIRED) gentoo-dev 2005-03-15 14:22:09 UTC
details on gdb backtraces can be found at:

http://dev.gentoo.org/~tigger/blog/guidexml/auditing-system.html
Comment 5 Chan Min Wai 2005-06-12 09:08:20 UTC
Some Serious bug of crash have been solved on the cvs version...
These bug happen when you have multiple Nic with multiple VLAN...

can we have a ebuild on the CVS version?
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2005-06-17 23:31:52 UTC
hall: can you confirm that ntop segfaults due to memory overflow? You may start 
ntop and look at output of `ps aux`. I can see that ntop is eating more and 
more memory... But may be memory overflow is another problem, may be not. 
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-09-15 05:53:52 UTC
ntop-3.1 segfaults here right when starting it w/ anything above -O0

CFLAGS="-march=athlon-xp -O0 -pipe -fomit-frame-pointer" works, -O1 and above
kills the thing. Hmmm. :/ Does not seem to leak memory though.
Comment 8 SpanKY gentoo-dev 2005-12-29 19:56:35 UTC
try ntop-3.2 and if it still freaks out, please drop a line upstream dev list:
http://www.ntop.org/support.html
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-01-12 02:31:40 UTC
*** Bug 118739 has been marked as a duplicate of this bug. ***