Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 844103 - dev-util/gnome-builder-42.1: src/plugins/meson/meson.build:30:0: ERROR: Unknown variable "test_sources".
Summary: dev-util/gnome-builder-42.1: src/plugins/meson/meson.build:30:0: ERROR: Unkno...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://gitlab.gnome.org/GNOME/gnome-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-13 20:51 UTC by Dmitry Baranov
Modified: 2022-10-13 00:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,18.19 KB, text/plain)
2022-05-13 20:52 UTC, Dmitry Baranov
Details
emerge --info (einfo.txt,6.37 KB, text/plain)
2022-05-13 20:52 UTC, Dmitry Baranov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Baranov 2022-05-13 20:51:07 UTC
* ERROR: dev-util/gnome-builder-42.1::gentoo failed (configure phase):
src/plugins/meson/meson.build:30:0: ERROR: Unknown variable "test_sources".

Reproducible: Always
Comment 1 Dmitry Baranov 2022-05-13 20:52:11 UTC
Created attachment 778604 [details]
build.log
Comment 2 Dmitry Baranov 2022-05-13 20:52:53 UTC
Created attachment 778607 [details]
emerge --info
Comment 3 Dmitry Baranov 2022-05-13 20:54:22 UTC
# emerge -pv gnome-builder
[ebuild     U  ] dev-util/gnome-builder-42.1::gentoo [3.40.2::staging] USE="glade sysprof* -clang -devhelp -doc -flatpak% -git -gtk-doc -spell -test -webkit%" PYTHON_SINGLE_TARGET="python3_9 -python3_8 -python3_10"
Comment 4 Dmitry Baranov 2022-05-13 21:16:03 UTC
Turning on git USE fixes build:
USE="git" emerge -1q gnome-builder

Looks like meson scripts problem.

First init test_sources var:
src/plugins/git/daemon/meson.build:92:test_sources = [

Causes an error if the git USE is disabled:
src/plugins/meson/meson.build:30:test_sources += files([
Comment 5 Larry the Git Cow gentoo-dev 2022-10-13 00:27:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ef3ed93925d4b23c9dc3a3ff6c4581fd2d37fc24

commit ef3ed93925d4b23c9dc3a3ff6c4581fd2d37fc24
Author:     Guillermo Joandet <gjoandet@gmail.com>
AuthorDate: 2022-10-05 17:16:40 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2022-10-13 00:26:55 +0000

    dev-util/gnome-builder: version bump to 43.2
    
    Closes: https://bugs.gentoo.org/844103
    Signed-off-by: Guillermo Joandet <gjoandet@gmail.com>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 dev-util/gnome-builder/Manifest                  |   1 +
 dev-util/gnome-builder/gnome-builder-43.2.ebuild | 260 +++++++++++++++++++++++
 dev-util/gnome-builder/metadata.xml              |   1 +
 profiles/package.mask                            |   1 +
 4 files changed, 263 insertions(+)