Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 843794 (gnome-42-stable) - GNOME 42 stabilization
Summary: GNOME 42 stabilization
Status: RESOLVED FIXED
Alias: gnome-42-stable
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: CC-ARCHES
: 847550 (view as bug list)
Depends on: 839939 843167 843800 843806 843809 847901
Blocks: gnome-42
  Show dependency tree
 
Reported: 2022-05-11 15:14 UTC by Matt Turner
Modified: 2022-06-01 10:34 UTC (History)
10 users (show)

See Also:
Package list:
app-accessibility/at-spi2-core-2.44.1 app-accessibility/orca-42.1 amd64 arm64 x86 app-arch/file-roller-3.42.0 amd64 arm64 x86 app-crypt/libsecret-0.20.5-r3 amd64 arm arm64 ppc ppc64 sparc x86 app-editors/gedit-42.0 amd64 arm64 x86 app-editors/gedit-plugins-42.0 amd64 x86 app-editors/ghex-42.2 amd64 ppc ppc64 x86 app-editors/gnome-text-editor-42.1 amd64 app-misc/gnote-42.0 amd64 x86 app-misc/tracker-3.3.0 amd64 arm64 x86 app-misc/tracker-miners-3.3.0 amd64 arm64 x86 app-office/gnumeric-1.12.52 amd64 app-text/enchant-2.3.3-r1 amd64 arm arm64 ppc ppc64 sparc x86 app-text/evince-42.2 amd64 arm64 x86 app-text/gspell-1.10.0 amd64 arm64 ppc ppc64 x86 app-text/yelp-tools-42.0 amd64 arm arm64 ppc ppc64 sparc x86 dev-cpp/glibmm-2.66.4 amd64 arm arm64 ppc ppc64 sparc x86 dev-cpp/glibmm-2.72.1 amd64 arm arm64 ppc ppc64 sparc x86 dev-cpp/gtkmm-3.24.6 amd64 arm arm64 ppc ppc64 sparc x86 dev-lang/vala-0.54.7 amd64 arm arm64 ppc ppc64 sparc x86 dev-lang/vala-0.56.1 amd64 arm arm64 ppc ppc64 sparc x86 dev-libs/atk-2.38.0 dev-libs/folks-0.15.5 amd64 arm64 x86 dev-libs/fribidi-1.0.12 dev-libs/gjs-1.72.0 amd64 arm arm64 ppc64 x86 dev-libs/glib-2.72.1 dev-libs/gmime-3.2.11 amd64 arm arm64 ppc ppc64 sparc x86 dev-libs/gobject-introspection-1.72.0 dev-libs/gobject-introspection-common-1.72.0 dev-libs/jsonrpc-glib-3.42.0 amd64 x86 dev-libs/libdazzle-3.44.0 amd64 arm64 x86 dev-libs/libgit2-1.4.3 amd64 arm arm64 ppc ppc64 x86 dev-libs/libgnome-games-support-2.0.0 amd64 arm64 x86 dev-libs/libgweather-4.0.0 amd64 arm64 x86 dev-libs/libpeas-1.32.0 amd64 arm64 x86 dev-libs/template-glib-3.34.1 amd64 x86 dev-libs/vala-common-0.56.1 dev-python/pygobject-3.42.1 dev-util/gdbus-codegen-2.72.1 dev-util/glib-utils-2.72.1 dev-util/sysprof-3.44.0 amd64 x86 dev-util/sysprof-capture-3.44.0 amd64 x86 dev-util/sysprof-common-3.44.0 amd64 x86 dev-util/umockdev-0.17.9 amd64 arm arm64 ppc ppc64 sparc x86 games-board/gnome-chess-42.0 amd64 arm64 x86 games-board/tali-40.7 amd64 arm64 x86 games-puzzle/five-or-more-3.32.3 amd64 arm64 x86 games-puzzle/gnome-sudoku-42.0 amd64 arm64 x86 games-puzzle/swell-foop-41.1 amd64 arm64 x86 gnome-base/gdm-42.0 amd64 arm64 x86 gnome-base/gnome-control-center-42.1 amd64 arm64 x86 gnome-base/gnome-desktop-42.1-r300 amd64 arm64 x86 gnome-base/gnome-desktop-42.1-r400 amd64 arm64 x86 gnome-base/gnome-session-42.0 amd64 arm64 x86 gnome-base/gnome-settings-daemon-42.1 amd64 arm64 x86 gnome-base/gnome-shell-42.1 amd64 arm64 x86 gnome-base/gsettings-desktop-schemas-42.0 gnome-base/gvfs-1.50.1-r1 amd64 arm arm64 ppc ppc64 sparc x86 gnome-base/librsvg-2.54.3 amd64 arm arm64 ppc64 x86 gnome-base/nautilus-42.1.1 amd64 arm64 x86 dev-libs/libportal-0.6 amd64 arm64 x86 gnome-extra/evolution-data-server-3.44.1 amd64 arm64 x86 gnome-extra/evolution-ews-3.44.1 amd64 x86 gnome-extra/gnome-boxes-42.0.1 amd64 gnome-extra/gnome-calculator-42.0 amd64 arm64 gnome-extra/gnome-calendar-42.1 amd64 arm64 x86 gnome-extra/gnome-characters-42.0 amd64 arm64 x86 gnome-extra/gnome-clocks-42.0 amd64 x86 gnome-extra/gnome-contacts-42.0 amd64 arm64 gnome-extra/gnome-logs-42.0 amd64 x86 gnome-extra/gnome-shell-extensions-42.1 amd64 arm64 x86 gnome-extra/gnome-shell-frippery-42.0 amd64 x86 gnome-extra/gnome-system-monitor-42.0 amd64 arm64 x86 gnome-extra/gnome-tweaks-40.10 amd64 arm64 x86 gnome-extra/gnome-user-docs-42.0 amd64 arm64 x86 gnome-extra/gnome-weather-42.0 amd64 arm64 x86 gnome-extra/gucharmap-14.0.3 amd64 arm arm64 ppc ppc64 sparc x86 gnome-extra/libgsf-1.14.49 amd64 arm arm64 ppc ppc64 sparc x86 gnome-extra/nm-applet-1.26.0 amd64 arm64 ppc ppc64 x86 gnome-extra/sushi-41.2 amd64 arm64 x86 gnome-extra/yelp-42.1 amd64 arm64 x86 gnome-extra/yelp-xsl-42.0 amd64 arm arm64 ppc ppc64 sparc x86 gnome-extra/zenity-3.42.1 amd64 arm64 x86 gui-libs/gdk-pixbuf-loader-webp-0.0.4 amd64 arm arm64 ppc ppc64 x86 gui-libs/gtk-4.6.4-r1 amd64 arm arm64 ppc ppc64 x86 gui-libs/gtksourceview-5.4.1 amd64 arm64 x86 gui-libs/libhandy-1.6.2 amd64 arm64 ppc ppc64 x86 mail-client/evolution-3.44.1 amd64 arm64 x86 media-fonts/cantarell-0.303.1 amd64 arm arm64 ppc ppc64 sparc x86 media-gfx/eog-42.1 amd64 arm64 x86 media-gfx/eog-plugins-42.1 amd64 x86 media-gfx/gnome-font-viewer-42.0 amd64 arm64 x86 media-gfx/gnome-photos-42.0 amd64 arm64 x86 media-gfx/gthumb-3.12.2-r2 amd64 x86 media-gfx/shotwell-0.30.15 amd64 arm64 x86 media-gfx/simple-scan-42.1 amd64 ppc ppc64 x86 media-libs/gexiv2-0.14.0 amd64 arm arm64 ppc ppc64 sparc x86 media-libs/graphene-1.10.8 amd64 arm arm64 ppc ppc64 x86 media-libs/libgphoto2-2.5.29 amd64 arm arm64 ppc ppc64 sparc x86 media-libs/libmediaart-1.9.5 amd64 arm64 x86 media-plugins/gst-plugins-libnice-0.1.18 amd64 arm arm64 ppc ppc64 x86 media-sound/gnome-music-42.1 amd64 arm64 x86 media-sound/gnome-sound-recorder-42.0 amd64 x86 media-video/totem-42.0-r1 amd64 arm64 x86 net-libs/glib-networking-2.72.0-r1 amd64 arm arm64 ppc ppc64 sparc x86 net-libs/gnome-online-accounts-3.44.0 amd64 arm64 x86 net-libs/libmbim-1.26.4 amd64 arm arm64 ppc ppc64 x86 net-libs/libnice-0.1.18 amd64 arm arm64 ppc ppc64 sparc x86 net-libs/libnma-1.8.38 amd64 arm arm64 ppc ppc64 x86 net-libs/libqmi-1.30.6 amd64 arm arm64 ppc ppc64 x86 net-misc/mobile-broadband-provider-info-20220315 amd64 arm arm64 ppc ppc64 sparc x86 net-misc/modemmanager-1.18.8 amd64 arm arm64 ppc ppc64 x86 net-misc/networkmanager-1.36.4 amd64 arm arm64 ppc ppc64 x86 net-vpn/networkmanager-openconnect-1.2.8 amd64 arm arm64 x86 net-vpn/networkmanager-openvpn-1.8.18 amd64 x86 net-vpn/networkmanager-pptp-1.2.10 amd64 x86 net-vpn/networkmanager-vpnc-1.2.8 amd64 x86 net-wireless/gnome-bluetooth-42.0-r2 amd64 arm64 x86 gui-libs/libadwaita-1.1.1 amd64 arm64 x86 sci-geosciences/gnome-maps-42.1 amd64 x86 sys-apps/accountsservice-22.08.8 amd64 arm arm64 ppc ppc64 x86 sys-apps/baobab-42.0 amd64 arm64 x86 sys-apps/bubblewrap-0.6.1 amd64 arm arm64 ppc ppc64 x86 sys-apps/gnome-disk-utility-42.0 amd64 arm64 x86 sys-block/gparted-1.4.0 amd64 ppc ppc64 x86 www-client/epiphany-42.2 amd64 arm64 x86 x11-libs/gdk-pixbuf-2.42.8 x11-libs/goffice-0.10.52 amd64 x11-libs/gtk+-3.24.34 x11-libs/pango-1.50.7 x11-libs/vte-0.68.0 amd64 arm arm64 ppc ppc64 sparc x86 x11-misc/alacarte-3.44.1 amd64 x86 x11-terms/gnome-terminal-3.44.0 amd64 arm64 x86 x11-themes/adwaita-icon-theme-42.0 amd64 arm arm64 ppc64 x86 x11-themes/gnome-backgrounds-42.0 amd64 arm64 x86 x11-wm/mutter-42.1 amd64 arm64 x86 app-i18n/ibus-1.5.26-r1 amd64 arm arm64 ppc64 x86 dev-libs/weston-10.0.0 ppc gnome-extra/gnome-shell-extension-dash-to-panel-46 amd64 x86 gnome-extra/gnome-shell-extension-gsconnect-50 amd64 x86
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Turner gentoo-dev 2022-05-11 15:14:47 UTC
Please stabilize.
Comment 1 NATTkA bot gentoo-dev 2022-05-11 15:19:46 UTC Comment hidden (obsolete)
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-11 17:54:55 UTC
Can depend on bug 839939 if needed.
Comment 3 NATTkA bot gentoo-dev 2022-05-11 17:55:28 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2022-05-11 18:11:26 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2022-05-11 18:39:20 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2022-05-11 18:56:21 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2022-05-11 21:03:26 UTC Comment hidden (obsolete)
Comment 8 NATTkA bot gentoo-dev 2022-05-11 21:11:34 UTC Comment hidden (obsolete)
Comment 9 NATTkA bot gentoo-dev 2022-05-11 21:19:34 UTC Comment hidden (obsolete)
Comment 10 NATTkA bot gentoo-dev 2022-05-11 21:27:33 UTC Comment hidden (obsolete)
Comment 11 NATTkA bot gentoo-dev 2022-05-12 17:52:17 UTC Comment hidden (obsolete)
Comment 12 NATTkA bot gentoo-dev 2022-05-12 22:48:15 UTC Comment hidden (obsolete)
Comment 13 NATTkA bot gentoo-dev 2022-05-15 03:15:15 UTC Comment hidden (obsolete)
Comment 14 NATTkA bot gentoo-dev 2022-05-15 03:51:12 UTC Comment hidden (obsolete)
Comment 15 NATTkA bot gentoo-dev 2022-05-16 22:24:16 UTC Comment hidden (obsolete)
Comment 16 NATTkA bot gentoo-dev 2022-05-16 22:31:10 UTC Comment hidden (obsolete)
Comment 17 CFuga 2022-05-17 17:47:10 UTC
Please, add the following packages to the stabilization list:

gnome-extra/gnome-shell-extension-dash-to-panel-46 *
gnome-extra/gnome-shell-extension-gsconnect-50 *

They directly depend on the new stable version for gnome-base/gnome-shell
Comment 18 James Le Cuirot gentoo-dev 2022-05-21 09:03:16 UTC
I have mixed feelings about stabilising dev-libs/weston on ppc. A few tests fail, but then they also do on ppc64, which has already been stabilised. I haven't been given any indication of whether it actually works in practise. See bug #833010.
Comment 19 Pacho Ramos gentoo-dev 2022-05-26 09:45:37 UTC
gui-libs/gtk-4.6.4-r1 includes an important fix for X11 users (otherwise users in stable will get the windows sizes messed up and will later need to manually "downsize" every affected window)
Comment 20 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 01:19:57 UTC
amd64 done
Comment 21 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 01:26:49 UTC
x86 done
Comment 22 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 05:04:53 UTC
hppa done
Comment 23 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 05:04:55 UTC
ppc done
Comment 24 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 05:04:57 UTC
ppc64 done
Comment 25 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 05:37:16 UTC
sparc done
Comment 26 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-28 05:40:57 UTC
arm64 done
Comment 27 Jakov Smolić archtester gentoo-dev 2022-05-31 09:24:30 UTC
arm done

all arches done
Comment 28 Yixun Lan archtester gentoo-dev 2022-06-01 10:34:07 UTC
*** Bug 847550 has been marked as a duplicate of this bug. ***