Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 843275 - media-gfx/inkscape-1.1.2 with poppler-22.05.0: extension/internal/pdfinput/svg-builder.cpp:1028:35: error: cannot convert ‘const std::shared_ptr<GfxFont>’ to ‘GfxFont*’ in initialization
Summary: media-gfx/inkscape-1.1.2 with poppler-22.05.0: extension/internal/pdfinput/sv...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: poppler-22.04, poppler-22.05
  Show dependency tree
 
Reported: 2022-05-08 09:21 UTC by Kobboi
Modified: 2022-05-08 19:36 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,30.75 KB, application/gzip)
2022-05-08 09:22 UTC, Kobboi
Details
emerge-info.txt (emerge-info.txt,7.79 KB, text/plain)
2022-05-08 09:22 UTC, Kobboi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2022-05-08 09:21:43 UTC
[456/1061] /usr/bin/x86_64-pc-linux-gnu-g++ -DBOOST_ATOMIC_DYN_LINK -DBOOST_ATOMIC_NO_LIB -DBOOST_FILESYSTEM_DYN_LINK -DBOOST_FILESYSTEM_NO_LIB -DHAVE_CONFIG_H -Dinkscape_base_EXPORTS -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/src -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2 -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/include -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/adaptagrams -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/2geom/include -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/2geom/include/2geom -isystem /usr/include/harfbuzz -isystem /usr/include/freetype2 -isystem /usr/include/glib-2.0 -isystem /usr/lib64/glib-2.0/include -isystem /usr/include/sysprof-4 -isystem /usr/include/pango-1.0 -isystem /usr/lib64/libffi/include -isystem /usr/include/libmount -isystem /usr/include/blkid -isystem /usr/include/fribidi -isystem /usr/include/cairo -isystem /usr/include/pixman-1 -isystem /usr/include/libpng16 -isystem /usr/include/libsoup-2.4 -isystem /usr/include/libxml2 -isystem /usr/include/poppler -isystem /usr/include/libcdr-0.1 -isystem /usr/include/librevenge-0.0 -isystem /usr/include/dbus-1.0 -isystem /usr/lib64/dbus-1.0/include -isystem /var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/src/extension/dbus -isystem /usr/include/gtkmm-3.0 -isystem /usr/lib64/gtkmm-3.0/include -isystem /usr/include/giomm-2.4 -isystem /usr/lib64/giomm-2.4/include -isystem /usr/include/glibmm-2.4 -isystem /usr/lib64/glibmm-2.4/include -isystem /usr/include/sigc++-2.0 -isystem /usr/lib64/sigc++-2.0/include -isystem /usr/include/gtk-3.0 -isystem /usr/include/gdk-pixbuf-2.0 -isystem /usr/include/gio-unix-2.0 -isystem /usr/include/sysprof-3 -isystem /usr/include/atk-1.0 -isystem /usr/include/at-spi2-atk/2.0 -isystem /usr/include/at-spi-2.0 -isystem /usr/include/cairomm-1.0 -isystem /usr/lib64/cairomm-1.0/include -isystem /usr/include/pangomm-1.4 -isystem /usr/lib64/pangomm-1.4/include -isystem /usr/include/atkmm-1.6 -isystem /usr/lib64/atkmm-1.6/include -isystem /usr/include/gtk-3.0/unix-print -isystem /usr/include/gdkmm-3.0 -isystem /usr/lib64/gdkmm-3.0/include -isystem /usr/include/gspell-1 -isystem /usr/include/enchant-2  -O2 -march=znver3 -pipe -g -ggdb3 -fno-strict-aliasing -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Werror=format -Werror=format-security -Wno-switch -Wstrict-null-sentinel -pthread -fopenmp -fPIC   -pthread -pthread -UWITH_MESH -UWITH_CSSBLEND -UWITH_CSSCOMPOSITE -UWITH_SVG2 -fPIC -fdiagnostics-color -std=gnu++17 -MD -MT src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o -MF src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o.d -o src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o -c /var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/extension/internal/pdfinput/svg-builder.cpp
FAILED: src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o 
/usr/bin/x86_64-pc-linux-gnu-g++ -DBOOST_ATOMIC_DYN_LINK -DBOOST_ATOMIC_NO_LIB -DBOOST_FILESYSTEM_DYN_LINK -DBOOST_FILESYSTEM_NO_LIB -DHAVE_CONFIG_H -Dinkscape_base_EXPORTS -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/src -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2 -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/include -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/adaptagrams -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/2geom/include -I/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/3rdparty/2geom/include/2geom -isystem /usr/include/harfbuzz -isystem /usr/include/freetype2 -isystem /usr/include/glib-2.0 -isystem /usr/lib64/glib-2.0/include -isystem /usr/include/sysprof-4 -isystem /usr/include/pango-1.0 -isystem /usr/lib64/libffi/include -isystem /usr/include/libmount -isystem /usr/include/blkid -isystem /usr/include/fribidi -isystem /usr/include/cairo -isystem /usr/include/pixman-1 -isystem /usr/include/libpng16 -isystem /usr/include/libsoup-2.4 -isystem /usr/include/libxml2 -isystem /usr/include/poppler -isystem /usr/include/libcdr-0.1 -isystem /usr/include/librevenge-0.0 -isystem /usr/include/dbus-1.0 -isystem /usr/lib64/dbus-1.0/include -isystem /var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2_build/src/extension/dbus -isystem /usr/include/gtkmm-3.0 -isystem /usr/lib64/gtkmm-3.0/include -isystem /usr/include/giomm-2.4 -isystem /usr/lib64/giomm-2.4/include -isystem /usr/include/glibmm-2.4 -isystem /usr/lib64/glibmm-2.4/include -isystem /usr/include/sigc++-2.0 -isystem /usr/lib64/sigc++-2.0/include -isystem /usr/include/gtk-3.0 -isystem /usr/include/gdk-pixbuf-2.0 -isystem /usr/include/gio-unix-2.0 -isystem /usr/include/sysprof-3 -isystem /usr/include/atk-1.0 -isystem /usr/include/at-spi2-atk/2.0 -isystem /usr/include/at-spi-2.0 -isystem /usr/include/cairomm-1.0 -isystem /usr/lib64/cairomm-1.0/include -isystem /usr/include/pangomm-1.4 -isystem /usr/lib64/pangomm-1.4/include -isystem /usr/include/atkmm-1.6 -isystem /usr/lib64/atkmm-1.6/include -isystem /usr/include/gtk-3.0/unix-print -isystem /usr/include/gdkmm-3.0 -isystem /usr/lib64/gdkmm-3.0/include -isystem /usr/include/gspell-1 -isystem /usr/include/enchant-2  -O2 -march=znver3 -pipe -g -ggdb3 -fno-strict-aliasing -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -Werror=format -Werror=format-security -Wno-switch -Wstrict-null-sentinel -pthread -fopenmp -fPIC   -pthread -pthread -UWITH_MESH -UWITH_CSSBLEND -UWITH_CSSCOMPOSITE -UWITH_SVG2 -fPIC -fdiagnostics-color -std=gnu++17 -MD -MT src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o -MF src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o.d -o src/CMakeFiles/inkscape_base.dir/extension/internal/pdfinput/svg-builder.cpp.o -c /var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/extension/internal/pdfinput/svg-builder.cpp
/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/extension/internal/pdfinput/svg-builder.cpp: In member function ‘void Inkscape::Extension::Internal::SvgBuilder::updateFont(GfxState*)’:
/var/tmp/portage/media-gfx/inkscape-1.1.2/work/inkscape-1.1.2/src/extension/internal/pdfinput/svg-builder.cpp:1028:35: error: cannot convert ‘const std::shared_ptr<GfxFont>’ to ‘GfxFont*’ in initialization
 1028 |     GfxFont *font = state->getFont();
      |                     ~~~~~~~~~~~~~~^~
      |                                   |
      |                                   const std::shared_ptr<GfxFont>


Reproducible: Always
Comment 1 Kobboi 2022-05-08 09:22:01 UTC
Created attachment 777485 [details]
build.log.gz
Comment 2 Kobboi 2022-05-08 09:22:13 UTC
Created attachment 777488 [details]
emerge-info.txt
Comment 3 ncaq 2022-05-08 10:55:19 UTC
I found workaround.

```
emerge -1 '=app-text/poppler-22.03.0'
```

I think we should limit the version of poppler in ebuild for now.
Comment 4 Kobboi 2022-05-08 12:23:28 UTC
Indeed works fine with the previous poppler, adapted the description accordingly.
Comment 5 Jan Psota 2022-05-08 13:40:09 UTC
Same here. Git version of Inkscape compiles and works.
Comment 6 Larry the Git Cow gentoo-dev 2022-05-08 17:42:27 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ea7abbfe5d1f6fbe2f25979b00e3d36651e0a041

commit ea7abbfe5d1f6fbe2f25979b00e3d36651e0a041
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-05-08 17:41:15 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-05-08 17:42:19 +0000

    media-gfx/inkscape: fix build with Poppler 22.04.0
    
    Also, switch out the 22.03.0 patch with the variant in upstream's
    1.1.x branch so that 22.04.x patch applies (from same place).
    
    Closes: https://bugs.gentoo.org/843275
    Closes: https://bugs.gentoo.org/835661
    Bug: https://bugs.gentoo.org/835424
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/inkscape-1.1.2-r1-poppler-22.03.0.patch  |  43 +++++
 .../files/inkscape-1.1.2-r1-poppler-22.04.0.patch  | 130 +++++++++++++++
 media-gfx/inkscape/inkscape-1.1.2-r1.ebuild        | 184 +++++++++++++++++++++
 3 files changed, 357 insertions(+)