Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 843272 - media-libs/mesa-22.0.3 X crashes with crocus driver
Summary: media-libs/mesa-22.0.3 X crashes with crocus driver
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-08 08:31 UTC by David Duchesne
Modified: 2022-06-09 13:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Duchesne 2022-05-08 08:31:13 UTC
media-libs/mesa-22.0.3 X crashes with crocus driver

X crashes with 22.0.3 when I open palemoon, it seems to be the only application that triggers the crash.
It looks like related to crocus driver because if I revert to 21.3.8 and use i965 driver instead of crocus then, no more crash.

[  2179.672] Failed to compile FS: 0:1(10): error: GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

[  2179.672] Program source:
#version 130
#ifdef GL_ES
precision mediump float;
#endif
#define RepeatNone                        0
#define RepeatNormal                     1
#define RepeatPad                        2
#define RepeatReflect                    3
#define RepeatFix                     10
uniform int          source_repeat_mode;
uniform int          mask_repeat_mode;
vec2 rel_tex_coord(vec2 texture, vec4 wh, int repeat)
{
   vec2 rel_tex;
   rel_tex = texture * wh.xy;
   if (repeat == RepeatFix + RepeatNone)
      return rel_tex;
   else if (repeat == RepeatFix + RepeatNormal)
      rel_tex = floor(rel_tex) + (fract(rel_tex) / wh.xy);
   else if (repeat == RepeatFix + RepeatPad) {
      if (rel_tex.x >= 1.0)
         rel_tex.x = 1.0 - wh.z * wh.x / 2.;
      else if (rel_tex.x < 0.0)
         rel_tex.x = 0.0;
      if (rel_tex.y >= 1.0)
         rel_tex.y = 1.0 - wh.w * wh.y / 2.;
      else if (rel_tex.y < 0.0)
         rel_tex.y = 0.0;
      rel_tex = rel_tex / wh.xy;
   } else if (repeat == RepeatFix + RepeatReflect) {
      if ((1.0 - mod(abs(floor(rel_tex.x)), 2.0)) < 0.001)
[  2179.672] (EE)
Fatal server error:
[  2179.672] (EE) GLSL compile failure
[  2179.672] (EE)
[  2179.672] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  2179.672] (EE) Please also check the log file at "/home/sdauth/.local/share/xorg/Xorg.0.log" for additional information.
[  2179.672] (EE)
[  2179.672] (II) AIGLX: Suspending AIGLX clients for VT switch
[  2179.711] (EE) Server terminated with error (1). Closing log file.

Reproducible: Always
Comment 1 David Duchesne 2022-05-08 08:34:22 UTC
Portage 3.0.30 (python 3.9.12-final-0, default/linux/amd64/17.1/no-multilib/hardened, gcc-11.2.1, glibc-2.34-r10, 5.10.109-gentoo-hardened x86_64)
=================================================================
System uname: Linux-5.10.109-gentoo-hardened-x86_64-AMD_A10-6800K_APU_with_Radeon-tm-_HD_Graphics-with-glibc2.34
KiB Mem:    32421848 total,  28758352 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Sat, 07 May 2022 20:30:01 +0000
Head commit of repository gentoo: 21a016521d76712d660ed9dc36279b76e3cf616f
Timestamp of repository menelkir: Mon, 02 May 2022 19:19:51 +0000
Head commit of repository menelkir: 578cbb0aad3a4656e1d6378ef129195a165dc49c

Timestamp of repository mv: Mon, 02 May 2022 18:48:02 +0000
Head commit of repository mv: a11fb399b7f905843a136d8f4c1c5e1238c1e194

Head commit of repository xfceclassic: d0fb6a84e27039e76420d6416d1d802a55b80911

sh bash 5.1_p16
ld GNU ld (Gentoo 2.37_p1 p2) 2.37
app-misc/pax-utils:        1.3.3::gentoo
app-shells/bash:           5.1_p16::gentoo
dev-lang/perl:             5.34.0-r9::gentoo
dev-lang/python:           2.7.18_p15::gentoo, 3.9.12::gentoo, 3.10.4::gentoo
dev-lang/rust:             1.59.0::gentoo
dev-util/cmake:            3.22.2::gentoo
dev-util/meson:            0.61.4-r2::gentoo
sys-apps/baselayout:       2.7-r3::gentoo
sys-apps/openrc:           0.44.10::gentoo
sys-apps/sandbox:          2.29::gentoo
sys-devel/autoconf:        2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:        1.16.5::gentoo
sys-devel/binutils:        2.37_p1-r2::gentoo
sys-devel/binutils-config: 5.4.1::gentoo
sys-devel/clang:           13.0.1::gentoo
sys-devel/gcc:             11.2.1_p20220115::gentoo
sys-devel/gcc-config:      2.5-r1::gentoo
sys-devel/libtool:         2.4.6-r6::gentoo
sys-devel/lld:             13.0.1::gentoo
sys-devel/llvm:            13.0.1::gentoo
sys-devel/make:            4.3::gentoo
sys-kernel/linux-headers:  5.15-r3::gentoo (virtual/os-headers)
sys-libs/glibc:            2.34-r10::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

menelkir
    location: /var/db/repos/menelkir
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/menelkir.git
    masters: gentoo

mv
    location: /var/db/repos/mv
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/mv.git
    masters: gentoo

xfceclassic
    location: /var/db/repos/xfceclassic
    sync-type: git
    sync-uri: https://github.com/Xfce-Classic/gentoo-overlay
    masters: gentoo

crossdev
    location: /var/db/repos/crossdev
    masters: gentoo
    priority: 10

Installed sets: @dbuspkg, @fonts, @games, @librsvg, @phone, @themes, @vm, @wm, @xfce
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/bin/startx /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/thumbnailers/ffmpegthumbnailer.thumbnailer /usr/share/thumbnailers/imagemagick-pdf.thumbnailer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS="--usepkg --binpkg-respect-use=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg buildpkg-live config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=core2 -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
INSTALL_MASK="/etc/sysctl.d/               /etc/systemd/               /lib/systemd/               /usr/lib/sysctl.d/               /usr/lib/systemd/               /run/systemd/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en fr"
MAKEOPTS="-j5"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/bash"
USE="X a52 aac acl acpi aio alsa amd64 bzip2 cairo cdda cdr cli crypt cryptsetup cups dbus device-mapper dri dts dvd dvr elogind emboss encode exif fam fftw flac gif gnat_2021 gpm graphite gtk hardened hscolour iconv icu ipv6 jpeg lcms libglvnd libnotify libtirpc lto lvm lz4 lzma lzo mad mp3 mp4 mpeg ncurses nfs nls nptl ogg opengl openmp openssl opus otr pam pango pcre pdf pgo pie png policykit ppds readline sdl seccomp sftp split-usr ssh ssl ssp startup-notification svg system-av1 system-binutils system-cairo system-clang system-cmark system-compress system-digest system-ffmpeg system-harfbuzz system-heimdal system-icu system-images system-jpeg system-jsoncpp system-lcms system-libevent system-libmspack system-libs system-libvpx system-libyaml system-llvm system-lua system-lz4 system-nss system-openjpeg system-pixman system-png system-renpy system-snappy system-sqlite system-tbb system-uulib system-vpx system-zlib sytem-leveldb tiff tk truetype udev udisks unicode upower usb vaapi verify-sig vorbis webp wxwidgets x264 xattr xcb xml xtpax xv xvid zlib zstd" ABI_X86="64" ADA_TARGET="gnat_2020" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="fr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-4 php8-0" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" QEMU_SOFTMMU_TARGETS="aarch64 arm i386 x86_64" QEMU_USER_TARGETS="aarch64 arm armeb i386 x86_64" RUBY_TARGETS="ruby26 ruby27" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, LC_ALL, LD, LEX, LFLAGS, LIBTOOL, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS
Comment 2 David Duchesne 2022-05-08 08:35:44 UTC
(In reply to David Duchesne from comment #1)
> This is a chroot used to build the binpkg for the target laptop (core2duo with 4500MHD iGPU)
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-09 00:44:34 UTC
Thanks! Could you send the report upstream please (and link it here)?
Comment 4 David Duchesne 2022-05-09 13:27:33 UTC
(In reply to Sam James from comment #3)
> Thanks! Could you send the report upstream please (and link it here)?

Hi, I'll see what I can do. I don't have much time to do it right now. And I don't have a gitlab account.. I hope 21.3.8 is not going to be removed too quickly.
Comment 5 Matt Turner gentoo-dev 2022-05-09 15:09:08 UTC
(In reply to David Duchesne from comment #4)
> (In reply to Sam James from comment #3)
> > Thanks! Could you send the report upstream please (and link it here)?
> 
> Hi, I'll see what I can do. I don't have much time to do it right now. And I
> don't have a gitlab account.. I hope 21.3.8 is not going to be removed too
> quickly.

It won't be -- the plan is to add a v21.3.8-r1 that installs in parallel with newer Mesa so you can still use the older classic drivers.
Comment 6 David Duchesne 2022-05-14 16:27:41 UTC
It seems to be somehow fixed with latest mesa code, I do not observe any crash yet (Mesa 22.2.0-devel (git-17fc7b20b1) with crocus loaded) when using palemoon.
Everything else seems to work, fullscreen video, games..
I will try the currently keyworded 22.1.0_rc5 to see if this is fixed in 22.1.* series and report back later.

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel (0x8086)
    Device: Mesa Mobile Intel® GM45 Express Chipset (CTG) (0x2a42)
    Version: 22.2.0
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: compat (0x2)
    Max core profile version: 0.0
    Max compat profile version: 2.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 2.0
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Mobile Intel® GM45 Express Chipset (CTG)
OpenGL version string: 2.1 Mesa 22.2.0-devel (git-17fc7b20b1)

[    26.819] (II) modeset(0): [DRI2]   DRI driver: crocus
[    26.833] (II) AIGLX: Loaded and initialized crocus

----

(In reply to Matt Turner from comment #5)
> (In reply to David Duchesne from comment #4)
> > (In reply to Sam James from comment #3)
> > > Thanks! Could you send the report upstream please (and link it here)?
> > 
> > Hi, I'll see what I can do. I don't have much time to do it right now. And I
> > don't have a gitlab account.. I hope 21.3.8 is not going to be removed too
> > quickly.
> 
> It won't be -- the plan is to add a v21.3.8-r1 that installs in parallel
> with newer Mesa so you can still use the older classic drivers.

Alright, good to know.
Comment 7 David Duchesne 2022-05-14 17:44:53 UTC
So, I tested 22.1.0_rc5 and it works just fine. (No crashes)
Surprisingly, current stable (22.0.3) also works fine after having updated to palemoon to v31.0.0, which is a quite important release, with lot of changes. I looked at the changelog but there is unfortunately no information regarding to glsl issues etc..
The good news is that all is working now.

Let me know what you think, I think this can be closed though because with previous palemoon (v29.4.6), the crash was occuring immediately when starting palemoon whereas now, it doesn't crash. I'm currently writing this running mesa 22.0.3.

(Sorry for the spam.)
Comment 8 Eddie Chapman 2022-05-18 20:02:24 UTC
I've just experienced this crash for the first time with exactly the same error in Xorg.0.log, after upgrading mesa from 21.3.7 to 22.0.3, but only on an old Intel i915 (Arrandale) laptop (Dell Latitude E6510). Exactly the same binaries don't produce any crash on an AMD Ryzen machine with AMD graphics.

Except it is palemoon v31.0.0 which reliably triggers the crash for me, so I don't think this is fixed in palemoon yet.

Going to try downgrading mesa back to mesa 21.3.x now, will report back.

I also found this issue which appears related, with exactly the same error message, word for word.

https://gitlab.freedesktop.org/xorg/xserver/-/issues/1336
Comment 9 Eddie Chapman 2022-05-18 21:03:28 UTC
I've downgraded mesa to 21.3.8 and restarted the laptop with it and I no longer get any X crashes, whereas before X would crash very soon after starting palemoon. Still using palemoon 31.0.0.

For reference this very recent thread sounds like exactly the same issue
https://forum.palemoon.org/viewtopic.php?f=65&t=28240

Although it is not identified as the same issue in the thread, the poster experienced an X crash with palemoon after upgrading Ubuntu on their old Intel laptop (Dell Inspiron 1564) from 20.04 to 22.04. Ubuntu 22.04 upgrades Mesa to version 22.x.x. They describe the crash happening when they click on an icon in palemoon, which is also how I have seen it happen.

Another detail to add; I had disabled palemoon's use of GPU acceleration (on the "General" tab under Advanced Preferences) but still experienced the crash. This is usually the first thing to try with palemoon graphics problems but it did not resolve it for me. Downgrading mesa has resolved it.

I'm guessing as suggested by the error message ("GLSL 1.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES") perhaps palemoon is trying to do something graphics wise that is not supported/not supposed to work with crocus? So maybe it's not really a bug just a sad fact that this older hardware will not fully work anymore under crocus. In any case it is not a Gentoo bug as Gentoo doesn't package palemoon.
Comment 10 Peter Fox 2022-05-22 13:34:35 UTC
I've seen this crash launching xsane (version media-gfx/xsane-0.999-r3::gentoo), and attempting to send an email using thunderbird. I worked around by downgrading to  x11-base/xorg-drivers-1.20-r2::gentoo and x11-base/xorg-server-1.20.14-r1:0/1.20.14::gentoo, as suggested in https://forums.gentoo.org/viewtopic-t-1146969.html.

Graphics device:
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)