Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 84106 - mondo-2.10.tgz digest problem (bug 69596)
Summary: mondo-2.10.tgz digest problem (bug 69596)
Status: RESOLVED DUPLICATE of bug 176738
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High major (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-04 10:00 UTC by Maurice Volaski
Modified: 2007-06-10 22:36 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild proposal for mondo (mondo-2.0.9.ebuild,1.66 KB, text/plain)
2006-08-07 17:10 UTC, Bruno Cornec
Details
proposal of mindi ebuild (mindi-1.0.9.ebuild,1.08 KB, text/plain)
2006-08-07 17:11 UTC, Bruno Cornec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maurice Volaski 2005-03-04 10:00:57 UTC
I'm still seeing the error reported in bug 69596:

!!! Digest verification Failed:
!!!    /usr/portage/distfiles/mondo-2.10.tgz
!!! Reason: Failed on MD5 verification

I get 
8932c216860c944c42bd46cfaba955dc  /usr/portage/distfiles/mondo-2.10.tgz

and from portage
MD5 37de3d04369e187db68b72580b95306e mondo-2.10.tgz 2259862
Comment 1 Simon Stelling (RETIRED) gentoo-dev 2005-03-04 10:30:51 UTC
did you rm the file in your distfiles folder and retry?
Comment 2 Maurice Volaski 2005-03-04 10:38:48 UTC
Yes.
Comment 3 Maurice Volaski 2005-03-04 10:45:42 UTC
The problem is that the tgz file is corrupt:

>>> Unpacking mondo-2.10.tgz to /var/tmp/portage/mondo-rescue-2.10/work

gzip: stdin: decompression OK, trailing garbage ignored
tar: Child returned status 2
tar: Error exit delayed from previous errors
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2005-03-05 00:28:39 UTC

*** This bug has been marked as a duplicate of 69596 ***
Comment 5 Maurice Volaski 2005-03-05 16:58:14 UTC
I opened this one because there doesn't seem to be a way to reopen 69596. 
Comment 6 John M. Drescher 2006-04-25 12:50:08 UTC
Ok, It's been over a year and the mondo-2.10.tgz file is still corrupted in portage. :-(
Comment 7 David Earp 2006-05-25 21:46:58 UTC
I've been having the same problem lately.

('Failed on MD5 verification', 'ec3c6882d74f67828de3ab0faac71aab', '37de3d04369e187db68b72580b95306e')
!!! Fetched file: mondo-2.10.tgz VERIFY FAILED!
!!! Reason: Failed on MD5 verification
!!! Got:      Failed on MD5 verification
!!! Expected: ec3c6882d74f67828de3ab0faac71aab
Removing corrupt distfile...

Any word on when this might get fixed?
Comment 8 Bruno Cornec 2006-08-07 17:10:39 UTC
Created attachment 93702 [details]
ebuild proposal for mondo
Comment 9 Bruno Cornec 2006-08-07 17:11:13 UTC
Created attachment 93703 [details]
proposal of mindi ebuild
Comment 10 Bruno Cornec 2006-08-08 03:09:57 UTC
I propose to remove these obsolete and non-working 2.1x version in fafour of the new and latest 2.0.9 at ftp://ftp.mondorescue.org/gentoo/1.6/
Comment 11 Bruno Cornec 2006-08-09 01:54:21 UTC
New versions available at ftp://ftp.mondorescue.org/gentoo/1.6
Comment 12 Bruno Cornec 2006-11-10 23:39:31 UTC
This bug should now be closed and a new version of mondo and mindi should be added from upstream (which I maintain) using the latest 2.2.0 (mondo) and 1.2.0 (mindi) available from ftp://ftp.mondorescue.org/gentoo/1.6 
I will shortly add the new required mindi-busybox package as well there.
Comment 13 Jeff Cranmer 2006-11-29 18:27:36 UTC
I haven't tried a restore yet, but I was able to successfully create a pair of backup DVDs with the latest version of mondo and mindi (2.2.0 and 1.2.0) on an amd64 dual-core system.

Ignore mindi-kernel, and use the command switch '-k /boot/kernel-2.6.17-gentoo-r8', replacing the kernel path with whatever kernel you're actually booting from.

I had to mess around a little with the ebuild files to get it to build (though only to correct a couple of minor differences between file naming conventions).  Looks like it is ready to add back into portage.

Jeff
Comment 14 Bruno Cornec 2007-01-04 04:22:36 UTC
A newer version (2.2.1) with ebuild packages is available at ftp://ftp.mondorescue.org/gentoo/1.6
Please provide feedback and info for return back in gentoo's tree.
Comment 15 Wolfram Schlich (RETIRED) gentoo-dev 2007-04-23 16:51:43 UTC
Sorry, I don't see myself using Mondo anytime soon :-/
Comment 16 Bruno Cornec 2007-04-23 22:27:07 UTC
Too bad for me :-(
A new version is BTW available since last friday (2.2.2) with an ebuild available (as well as for mindi and mindi-busybox). I'm ready to work with a maintainer ir order to improve what needs to be done for those ebuilds, but I need feedback from some gentoo users.
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2007-06-10 22:36:35 UTC

*** This bug has been marked as a duplicate of bug 176738 ***