Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 840278 - =media-video/pipewire-0.3.49-r1 : No sound
Summary: =media-video/pipewire-0.3.49-r1 : No sound
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2022-04-23 07:56 UTC by Adrien D
Modified: 2022-07-08 05:14 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info media-video/pipewire (emerge-info.log,7.38 KB, text/x-log)
2022-04-23 07:57 UTC, Adrien D

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien D 2022-04-23 07:56:20 UTC
I updated my system and media-video/pipewire updated from 0.3.36 to 0.3.49-r1
No sound after login in my GNOME Session. (PC and VM, so reproductible issue)
I used to use pulseaudio.
Killing manually pipewire process restore sound. Or adding exit 0; at begening of /usr/bin/gentoo-pipewire-launcher script. 

Reproducible: Always

Steps to Reproduce:
1. Install system with pulseaudio and masking pipewire > 0.3.36
2. Unmask pipewire and upgrade system
3. See the issue.
Actual Results:  
No sound

Expected Results:  
Sound OK
Comment 1 Adrien D 2022-04-23 07:57:15 UTC
Created attachment 773444 [details]
emerge --info media-video/pipewire
Comment 2 Ionen Wolkens gentoo-dev 2022-04-23 09:40:44 UTC
Cross-linking thread for reference:
Comment 3 Niklāvs Koļesņikovs 2022-04-23 18:10:24 UTC
What happens if you edit /etc/pulse/client.conf to say this:

autospawn = no

Please reboot after making the modification (and of course undo the exit 0 modification you made to the launcher script). If that helps, perhaps it's time to just fast track replacing PulseAudio with PipeWire.
Comment 4 Niklāvs Koļesņikovs 2022-04-23 18:13:05 UTC
In case if after reboot there is still no audio, then still with autospawning disabled please try to manually run gentoo-pipewire-launcher and see if that restores audio.
Comment 5 Adrien D 2022-04-24 07:49:39 UTC
I tried :
autospawn = no + enable again pipewire script.

Sound is here, i can listen audio but sound crackling, recording sound with a mic plugged is USB don't work.

Pipewire isn't stable in the real life, so i want keep pulseaudio and don't use this Pipewire
Comment 6 Niklāvs Koļesņikovs 2022-04-24 08:07:01 UTC
Thank you for verifying that disabling autospawning fixes audio. I'm not immediately sure why PipeWire is now even more prone to interfere with PulseAudio than previousl. But, as I have pointed out even before the XDG launcher script was deployed, it was the wrong solution exactly because it could brick the audio partially or fully depending on how the dice roll, so in a sense we just have arrived at what was the predicted outcome.

If the crackling is with a USB device, it might help to try a newer kernel such as one of the 5.17 kernels. Alternatively it could be that the particular client is requesting the lowest possible latency and then failing to deliver data on time. In order to isolate the cause of crackling, it might help to test more devices and client programs, if you want and can do so.

Another useful tool is to look at pw-top and observe if any of the values in the ERR column go up and which ones the most or in correlation with the crackles.
Comment 7 Adrien D 2022-04-30 08:57:43 UTC
Finally, crackling is only on OBS not with audacity.
It's a config issue with OBS.

New clean config of OBS and all is OK
Comment 8 Adrien D 2022-04-30 08:58:27 UTC
autospawn = no + pipewire script : All is okay !
Comment 9 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-07-06 06:38:05 UTC
With the USE=sound-server changes, I think this is sorted now.