Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 8401 - the USE flags should be used on the depedency too
Summary: the USE flags should be used on the depedency too
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-26 02:02 UTC by Martin Holzer (RETIRED)
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holzer (RETIRED) gentoo-dev 2002-09-26 02:02:20 UTC
the idea is to have a x-less server. i've tried it but the thirst thing i've 
emerge it was terrible.
emerge samba with the USE flag "-X" emerges xfree cause of ghostscript.

if a USE flag is set, every package has to check the USE flag.
maybe emerge should put a little info if it's unable to emerge the package 
cause of the USE flag.

should be something like: take the use flags 
from /etc/make.profile/make.defaults, then the from /etc/make.conf.

then check out every dependency from emerged package.

if that works it would be great
Comment 1 SpanKY gentoo-dev 2002-09-26 10:13:34 UTC
if you're saying 'enforce' USE variables hardcore, then there is a bug open for 
that ...

but seriously, if you want a slim server than you should go through and disable 
all the graphical stuff in your USE variable anyways ...
USE="-X -qt -svga -aalib -kde -gnome" etc...

*** This bug has been marked as a duplicate of 2272 ***