Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 83822 - kdeaddons does not compile if kdelibs was compiled with USE="-ssl"
Summary: kdeaddons does not compile if kdelibs was compiled with USE="-ssl"
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 87387 109092 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-02 07:43 UTC by Marco Fontani
Modified: 2006-11-21 09:39 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
file kopenssl.h as requested (kopenssl.h,18.41 KB, application/octet-stream)
2005-03-04 00:33 UTC, Marco Fontani
Details
Config.log as requested (config.log,139.88 KB, text/plain)
2005-03-07 00:54 UTC, Marco Fontani
Details
ksslconfig.h as requested [marco] (ksslconfig.h,1007 bytes, text/x-chdr)
2005-03-21 08:19 UTC, Marco Fontani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Fontani 2005-03-02 07:43:31 UTC
Emerging kde-base/kdeaddons-3.4.0_rc1 won't compile cleanly:

Making all in cert
make[3]: Entering directory `/mnt/tmplinux/portage/kdeaddons-3.4.0_rc1/work/kdeaddons-3.4.0/kfile-plugins/cert'
/usr/qt/3/bin/moc ./kfile_cert.h -o kfile_cert.moc
/bin/sh ../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/kde/3.4/include -I/usr/qt/3/include -I.  -I/usr/include/db4.2  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -march=pentium-m -mtune=pentium-m -O3 -ftracer -pipe -fomit-frame-pointer -momit-leaf-frame-pointer -ffast-math -fno-unroll-loops -fvisibility-inlines-hidden -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o kfile_cert.lo `test -f 'kfile_cert.cpp' || echo './'`kfile_cert.cpp
kfile_cert.cpp: In function `KSSLCertificate* readCertFromFile(const QString&)':
kfile_cert.cpp:110: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
kfile_cert.cpp:126: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
kfile_cert.cpp:127: error: 'class KOpenSSLProxy' has no member named 'd2i_X509'
kfile_cert.cpp:130: error: 'class KOpenSSLProxy' has no member named 'X509_free'
kfile_cert.cpp: In member function `virtual bool CertPlugin::readInfo(KFileMetaInfo&, uint)':
kfile_cert.cpp:156: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
make[3]: *** [kfile_cert.lo] Error 1
make[3]: Leaving directory `/mnt/tmplinux/portage/kdeaddons-3.4.0_rc1/work/kdeaddons-3.4.0/kfile-plugins/cert'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/tmplinux/portage/kdeaddons-3.4.0_rc1/work/kdeaddons-3.4.0/kfile-plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/tmplinux/portage/kdeaddons-3.4.0_rc1/work/kdeaddons-3.4.0'
make: *** [all] Error 2

!!! ERROR: kde-base/kdeaddons-3.4.0_rc1 failed.
!!! Function kde_src_compile, Line 166, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


Reproducible: Always
Steps to Reproduce:
1. unmask all of kde 3.4.0-rc1
2. emerge kde-related stuff
3. kdeaddons wont compile cleanly

Actual Results:  
build interrupted because of error message

Expected Results:  
it should have compiled cleanly

komet root # emerge info
Portage 2.0.51-r15 (default-linux/x86/2004.2, gcc-3.4.3,
glibc-2.3.4.20040808-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  8 2005, 09:14:18)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium-m -mtune=pentium-m -O3 -ftracer -pipe
-fomit-frame-pointer -momit-leaf-frame-pointer -ffast-math -fno-unroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config
/usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb
/usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3 -ftracer -pipe
-fomit-frame-pointer -momit-leaf-frame-pointer -ffast-math -fno-unroll-loops
-fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.ccccom.com
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_US"
LC_ALL="it_IT"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/mnt/tmplinux"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X aalib acpi aim alsa apache apache2 apm arts avi bash-completion
berkdb bitmap-fonts bzlib caps cdr crypt cups curl dba directfb divx4linux dvd
dvdr dvdread emboss encode esd exif f77 fam flac font-server foomaticdb fortran
ftp fvwm gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 icq imagemagick
imagemagik imlib ipv6 itcl jack jpeg kde ldap libg++ libwww mad mbox mikmod mime
mmx motif mozilla mpeg msn mysql ncurses nls nptl offensive oggvorbis opengl oss
pam pda pdflib perl php png postgres postgresql python qt quicktime readline
samba sdl slang sockets spell sqlite sse sse2 svga tcl tcltk tcpd threads tiff
tk truetype truetype-fonts type1-fonts usb userlocales video_cards_i810 wifi
wxwindows xine xml xml2 xmms xv xvid zlib linguas_it"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS
Comment 1 Gregorio Guidi (RETIRED) gentoo-dev 2005-03-02 08:13:20 UTC
Have you tried with less CFLAGS and without -fvisibility-inlines-hidden?
Comment 2 Marco Fontani 2005-03-03 00:59:22 UTC
Compiling this way:

komet root # CFLAGS="-march=pentium-m -mtune=pentium-m -O3" CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3" emerge -v kde-base/kdeaddons

Still gives the _same_ error message. It says:
kfile_cert.cpp:110: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'

It seems to me a library-related thing, or a .h file gone wild.
Any help?
Comment 3 Simone Gotti (RETIRED) gentoo-dev 2005-03-03 01:31:12 UTC
Did you removed the ALL contents of /var/tmp/portage? Please do and try again.

If it doesn't work again, can you attach your /usr/kde/3.4/include/kopenssl.h ? thanks.
Comment 4 Marco Fontani 2005-03-04 00:33:06 UTC
Created attachment 52628 [details]
file kopenssl.h as requested
Comment 5 Marco Fontani 2005-03-04 00:33:46 UTC
Tried removing my portage tempdir (/mnt/tmplinux as seen on emerge info), still _same_ problem. Attached file as requested.
-marco-
Comment 6 Simone Gotti (RETIRED) gentoo-dev 2005-03-04 02:00:44 UTC
The file is ok. Try disabling ccache (put "-ccache" in the FEATURES var in make.conf), remove the portage tmp dir and try again.
Comment 7 Marco Fontani 2005-03-04 04:42:44 UTC
I'm sincerely unhappy to tell you that the solution provided doesnt change anything:

kfile_cert.cpp: In function `KSSLCertificate* readCertFromFile(const QString&)':
kfile_cert.cpp:110: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
kfile_cert.cpp:126: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
[...]

any other suggestion?
Comment 8 Simone Gotti (RETIRED) gentoo-dev 2005-03-07 00:10:36 UTC
I don't know how it can be helpful but can you please attach your /mnt/tmplinux/kdeaddons-3.4.0_rc1/work/kdeaddons-3.4.0/config.log? Thanks.
Comment 9 Marco Fontani 2005-03-07 00:54:00 UTC
Created attachment 52831 [details]
Config.log as requested
Comment 10 Marco Fontani 2005-03-11 00:00:54 UTC
Still no resolution.
Comment 11 Simone Gotti (RETIRED) gentoo-dev 2005-03-11 01:05:02 UTC
I cannot help you, if you are sure that ccache is disabled (try also unmerging it) I cannot know where the problem is. Looks like you are the unique that has this problem.
Comment 12 Marco Fontani 2005-03-15 05:15:28 UTC
same thing.
without ccache, without any optimizations.. to no avail.
still cant find those things..

anyone got a better idea on how to check this out?
Comment 13 Nuno Alexandre 2005-03-20 03:55:46 UTC
t-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCI I_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o kfile_cert.lo `test -f 'kfi le_cert.cpp' || echo './'`kfile_cert.cpp
kfile_cert.cpp: In function `KSSLCertificate* readCertFromFile(const QString&)':
kfile_cert.cpp:110: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
kfile_cert.cpp:126: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
kfile_cert.cpp:127: error: 'class KOpenSSLProxy' has no member named 'd2i_X509'
kfile_cert.cpp:130: error: 'class KOpenSSLProxy' has no member named 'X509_free'
kfile_cert.cpp: In member function `virtual bool CertPlugin::readInfo(KFileMetaInfo&, ui nt)':
kfile_cert.cpp:156: error: 'class KOpenSSLProxy' has no member named 'ERR_clear_error'
make[3]: *** [kfile_cert.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0/kfile- plugins/cert'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0/kfile- plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0'
make: *** [all] Error 2

!!! ERROR: kde-base/kdeaddons-3.4.0 failed.
!!! Function kde_src_compile, Line 166, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.



same thing here  (~AMD64) 
Comment 14 Nuno Alexandre 2005-03-20 03:56:26 UTC
Portage 2.0.51.19 (default-linux/amd64/2004.3, gcc-3.4.3-20050110, glibc-2.3.4.20050125-r1, 2.6.11.4 x86_64)
=================================================================
System uname: 2.6.11.4 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 26 2005, 16:27:31)]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r6
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoclean autoconfig ccache distlocks noinfo notitles sandbox"
GENTOO_MIRRORS="http://mirror.uni-c.dk/gentoo/ ftp://ftp.dkuug.dk/pub/gentoo/ ftp://rsync.gentoo.diku.dk http://ftp.du.se/pub/os/gentoo"
LANG="en_US"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 ncurses"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL
Comment 15 Simone Gotti (RETIRED) gentoo-dev 2005-03-20 07:43:24 UTC
Probably I found the problem.

Can you (both Marco and Nuno) post the contents of your /usr/kde/3.4/include/ksslconfig.h ?

Thanks.
Comment 16 Marco Fontani 2005-03-21 08:19:05 UTC
Created attachment 54061 [details]
ksslconfig.h as requested [marco]

Added ksslconfig.h as requested
Comment 17 Simone Gotti (RETIRED) gentoo-dev 2005-03-21 09:01:24 UTC
#ifndef KSSLCONFIG_H
#define KSSLCONFIG_H

/* #undef KSSL_HAVE_SSL */

#endif

From your provided file I'm quite sure that the problem is that your kdelibs were compiled without openssl support (USE=-ssl). But kdeaddons configure scripts doesn't checks for this possibility.

So we should add a check that will disable the certmanager compilation if kdelibs aren't compiled with ssl support probably adding the use ssl also it.
Comment 18 Marco Fontani 2005-03-23 03:17:36 UTC
recompiling kdelibs with +SSL "solved" the problem.
Comment 19 Gregorio Guidi (RETIRED) gentoo-dev 2005-03-31 02:46:04 UTC
*** Bug 87387 has been marked as a duplicate of this bug. ***
Comment 20 Gregorio Guidi (RETIRED) gentoo-dev 2005-10-13 02:12:56 UTC
*** Bug 109092 has been marked as a duplicate of this bug. ***
Comment 21 Lars Janssen 2006-03-19 05:27:38 UTC
I can confirm that this bug affected me (AMD64, upgrading from KDE 3.4 to 3.5.1). For some reason my USE flags had -ssl.

I fixed the problem by editing make.conf to use ssl, recompiling kdelibs (3.5.1) and then emerge kde again to carry on the upgrade (kdeextras went through fine).
Comment 22 Bruno Linhares 2006-06-02 09:32:52 UTC
Gentoo Base System version 1.6.14
Portage 2.0.54-r2 (default-linux/x86/no-nptl, gcc-3.4.5, glibc-2.3.6-r3, 2.6.15-gentoo-r7 i686)
=================================================================
System uname: 2.6.15-gentoo-r7 i686 AMD Athlon(tm) XP 1600+
dev-lang/python:     2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.3.5, 1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=i686 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="pt_BR"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X alsa apm arts audiofile avi berkdb bitmap-fonts bzip2 cli crypt cups curl dri eds emboss encode expat fam foomaticdb fortran gdbm gif gmp gpm gstreamer gtk gtk2 idn imlib ipv6 isdnlog jpeg kde lcms libg++ libwww mad mikmod mmx mng motif mp3 mpeg ncurses nls ogg opengl oss pam pcre pdflib perl png pppd python qt quicktime readline reflection sdl session spell spl ssl tcltk tcpd tiff truetype truetype-fonts type1-fonts udev usb vorbis xml xml2 xmms xorg xv zlib linguas_pt_BR userland_GNU kernel_linux elibc_glibc"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS, PORTDIR_OVERLAY

*********

For me, the solution don't solved the problem.. any other suggestion?
Comment 23 Ioannis Aslanidis (RETIRED) gentoo-dev 2006-09-02 06:02:50 UTC
Would it be wise to add something like:

if ! built_with_use ssl kde-base/kdelibs; then
     die "kdelibs needs ssl use flag <put better explanation>"
fi

?
Comment 24 Charlie Shepherd (RETIRED) gentoo-dev 2006-11-20 15:17:56 UTC
Is this still a problem with kde-3.5.5?
Comment 25 Stefan Schweizer (RETIRED) gentoo-dev 2006-11-21 09:39:29 UTC
needinfo