Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 83790 - compile error when emerging qemacs 1.3.1 on ppc
Summary: compile error when emerging qemacs 1.3.1 on ppc
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: PPC Porters
Depends on:
Reported: 2005-03-02 02:35 UTC by Martin
Modified: 2005-05-14 08:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Fixes ppc segfault with qemacs (qemacs-ppc-segfault.patch,918 bytes, patch)
2005-03-12 19:55 UTC, Joe Jezak (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2005-03-02 02:35:10 UTC
emerging qemacs 1.3.1 leads to a compile error.  this is the output:

Calculating dependencies ...done!
>>> emerge (1 of 1) app-editors/qemacs-0.3.1 to /
>>> md5 src_uri ;-) qemacs-0.3.1.tar.gz
>>> Unpacking source...
>>> Unpacking qemacs-0.3.1.tar.gz to /var/tmp/portage/qemacs-0.3.1/work
 * Applying qemacs-Makefile-gentoo.patch ...                                                              [ ok ] * Applying qemacs-0.3.1-configure-gentoo.patch ...                                                       [ ok ]>>> Source unpacked.
./configure --prefix=/usr --host=powerpc-unknown-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --enable-x11 --enable-png
Install prefix   /usr
Source path      /var/tmp/portage/qemacs-0.3.1/work/qemacs-0.3.1
C compiler       gcc
Tiny build       no
X11 support      yes
Xvideo support   yes
libpng support   yes
Graphical HTML   yes
Plugins support  yes
FFMPEG support   no
Creating config.mak and config.h
make -C libqhtml all
make[1]: Entering directory `/var/tmp/portage/qemacs-0.3.1/work/qemacs-0.3.1/libqhtml'
gcc -Wall -g -O3 -pipe -mcpu=750 -I..   -c -o css.o css.c
css.c: In function `str_nextc':
css.c:240: warning: dereferencing type-punned pointer will break strict-aliasing rules
gcc -Wall -g -O3 -pipe -mcpu=750 -I..   -c -o xmlparse.o xmlparse.c
xmlparse.c:213: warning: 'offsetbuf_reset' defined but not used
xmlparse.c:220: warning: 'offsetbuf_add' defined but not used
gcc -Wall -g -O3 -pipe -mcpu=750 -I..   -c -o cssparse.o cssparse.c
gcc -Wall -g -O3 -pipe -mcpu=750 -I.. -o csstoqe csstoqe.c
./csstoqe html_style < html.css > html_style.c
gcc -Wall -g -O3 -pipe -mcpu=750 -I..   -c -o html_style.o html_style.c
./csstoqe docbook_style < docbook.css > docbook_style.c
gcc -Wall -g -O3 -pipe -mcpu=750 -I..   -c -o docbook_style.o docbook_style.c
rm -f libqhtml.a
ar rc libqhtml.a css.o xmlparse.o cssparse.o html_style.o docbook_style.o
make[1]: Leaving directory `/var/tmp/portage/qemacs-0.3.1/work/qemacs-0.3.1/libqhtml'
gcc -DHAVE_QE_CONFIG_H -DCONFIG_ALL_KMAPS -DCONFIG_UNICODE_JOIN -DCONFIG_ALL_MODES -Wall -g -O3 -pipe -mcpu=750 -I./libqhtml -o qe.o -c qe.c
qe.c: In function `init_all_modules':
qe.c:6174: warning: dereferencing type-punned pointer will break strict-aliasing rules
gcc -DHAVE_QE_CONFIG_H -DCONFIG_ALL_KMAPS -DCONFIG_UNICODE_JOIN -DCONFIG_ALL_MODES -Wall -g -O3 -pipe -mcpu=750 -I./libqhtml -o charset.o -c charset.c
gcc -DHAVE_QE_CONFIG_H -DCONFIG_ALL_KMAPS -DCONFIG_UNICODE_JOIN -DCONFIG_ALL_MODES -Wall -g -O3 -pipe -mcpu=750 -I./libqhtml -o buffer.o -c buffer.c
buffer.c: In function `eb_prevc':
buffer.c:794: warning: dereferencing type-punned pointer will break strict-aliasing rules
gcc -DHAVE_QE_CONFIG_H -DCONFIG_ALL_KMAPS -DCONFIG_UNICODE_JOIN -DCONFIG_ALL_MODES -Wall -g -O3 -pipe -mcpu=750 -I./libqhtml -o input.o -c input.c
gcc -DHAVE_QE_CONFIG_H -DCONFIG_ALL_KMAPS -DCONFIG_UNICODE_JOIN -DCONFIG_ALL_MODES -Wall -g -O3 -pipe -mcpu=750 -I./libqhtml -o unicode_join.o -c unicode_join.c
unicode_join.c: In function `unicode_ligature':
unicode_join.c:185: error: label at end of compound statement
make: *** [unicode_join.o] Error 1

!!! ERROR: app-editors/qemacs-0.3.1 failed.
!!! Function src_compile, Line 32, Exitcode 2

Reproducible: Always
Steps to Reproduce:
1.type "emerge qemacs"

Actual Results:  
installation process stopped

Expected Results:  
installation process should successfully install application

All information I found in the net about this problem is:
Comment 1 Joe Jezak (RETIRED) gentoo-dev 2005-03-05 18:49:04 UTC
Just a little fix, done in CVS.
Comment 2 Martin 2005-03-12 10:10:06 UTC
Successfully installed qemacs 1.3.1 now on my machine.  Thanks for the fix.

Sadly, now when trying to start it, I get a "Segmentation fault".  Any ideas what could be broken?

Should I mark this bug as VERIFIED now?
Comment 3 Joe Jezak (RETIRED) gentoo-dev 2005-03-12 19:54:16 UTC
No, we'll reopen the bug.  From looking at the code, it's segfaulting when it's trying to open plugins.  By switching the method it uses to another, it seems to work fine.  Can you test this patch?
Comment 4 Joe Jezak (RETIRED) gentoo-dev 2005-03-12 19:55:16 UTC
Created attachment 53302 [details, diff]
Fixes ppc segfault with qemacs
Comment 5 Martin 2005-03-16 03:02:46 UTC
I applied this patch by running the following commands, I hope this was correct:

igent:/usr/portage/app-editors/qemacs # ebuild qemacs-0.3.1.ebuild unpack
cd /var/tmp/portage/qemacs-0.3.1/work/qemacs-0.3.1
igent:/var/tmp/portage/qemacs-0.3.1/work/qemacs-0.3.1 # patch -p0 </tmp/qemacs-ppc-segfault.patch
patching file qe.c
igent:/usr/portage/app-editors/qemacs # ebuild qemacs-0.3.1.ebuild compile test install qmerge
>>> md5 src_uri ;-) qemacs-0.3.1.tar.gz
>>> Checking qemacs-0.3.1.tar.gz's mtime...
>>> WORKDIR is up-to-date, keeping...
./configure --prefix=/usr --host=powerpc-unknown-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-x11 --enable-png

These commands run successfully, as does qemacs afterwards.  So I think this is fixed.  Well done, thank you very much.
Comment 6 Joe Jezak (RETIRED) gentoo-dev 2005-03-17 05:32:48 UTC
Added to cvs.
Comment 7 Martin 2005-05-14 07:25:50 UTC
Just notized that this bug is not closed by now, so I tried to install this again by running:
  emerge qemacs
and it worked well.  So I set this to verified.
I don't know who is responsible for closing this bug.
Comment 8 Joe Jezak (RETIRED) gentoo-dev 2005-05-14 08:58:18 UTC
Closed. :)