Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 835791 - media-libs/xine-lib-1.2.12: fails to build with media-libs/dav1d-1.0.0 (dav1d.c: error: Dav1dSettings has no member named n_frame_threads)
Summary: media-libs/xine-lib-1.2.12: fails to build with media-libs/dav1d-1.0.0 (dav1d...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 835807
  Show dependency tree
 
Reported: 2022-03-22 09:28 UTC by Toralf Förster
Modified: 2022-05-19 22:46 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.05 KB, text/plain)
2022-03-22 09:28 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,177.61 KB, text/plain)
2022-03-22 09:28 UTC, Toralf Förster
Details
environment (environment,76.92 KB, text/plain)
2022-03-22 09:28 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,21.41 KB, application/x-bzip)
2022-03-22 09:28 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,25.04 KB, application/x-bzip)
2022-03-22 09:28 UTC, Toralf Förster
Details
media-libs:xine-lib-1.2.12:20220322-051823.log (media-libs:xine-lib-1.2.12:20220322-051823.log,219.13 KB, text/plain)
2022-03-22 09:28 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,32.29 KB, application/x-bzip)
2022-03-22 09:28 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-03-22 09:28:18 UTC
too long lines were shrinked:

libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib -I../../lib -DNDEBUG -D_REENTRANT -DXINE_COMPILE -
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib -I../../lib -DNDEBUG -D_REENTRANT -DXINE_COMPILE -
/bin/sh ../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../include  -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils  -I../../src/input -I../../src/input  -I../../lib -I../../lib -DNDE
dav1d.c: In function _open_plugin’:
dav1d.c:547:11: error: Dav1dSettings’ has no member named n_frame_threads’
  547 |   settings.n_frame_threads = (ncpu > 8) ? 4 : (ncpu < 2) ? 1 : ncpu/2;
      |           ^

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-j4-20220320-050006

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.3.1
 [2] x86_64-pc-linux-gnu-11.2.1 *
clang/llvm (if any):
clang version 13.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/13/bin
/usr/lib/llvm/13
13.0.1
Python 3.9.11
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby27 (with Rubygems)
  [3]   ruby31 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.59.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4
php cli:
  [1]   php7.4
  [2]   php8.0
  [3]   php8.1 *

  HEAD of ::gentoo
commit 06ea699f8e0672f9ec7c2bd12015da00847be224
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Tue Mar 22 04:19:38 2022 +0000

    2022-03-22 04:19:36 UTC

emerge -qpvO media-libs/xine-lib
[ebuild   R   ] media-libs/xine-lib-1.2.12  USE="X alsa css ipv6 mad mmap nls vorbis xv -a52 -aac -aalib (-altivec) -bluray -dts -dvb -dxr3 -fbcon -flac -gtk -imagemagick -jack -jpeg -libcaca -mng -modplug -musepack -nfs -opengl -oss -pulseaudio -samba -sdl -sftp -speex -theora -truetype -v4l -vaapi -vcd -vdpau -vdr (-vidix) (-vis) -vpx -wavpack -wayland -xinerama -xvmc"
Comment 1 Toralf Förster gentoo-dev 2022-03-22 09:28:19 UTC
Created attachment 767562 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-03-22 09:28:21 UTC
Created attachment 767563 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2022-03-22 09:28:22 UTC
Created attachment 767564 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-03-22 09:28:23 UTC
Created attachment 767565 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-03-22 09:28:24 UTC
Created attachment 767566 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-03-22 09:28:26 UTC
Created attachment 767567 [details]
media-libs:xine-lib-1.2.12:20220322-051823.log
Comment 7 Toralf Förster gentoo-dev 2022-03-22 09:28:27 UTC
Created attachment 767568 [details]
temp.tar.bz2
Comment 8 Christian Bricart 2022-03-22 10:31:49 UTC
https://sourceforge.net/p/xine/tickets/11/
Comment 9 Fabio Coatti 2022-03-22 11:45:14 UTC
(In reply to Christian Bricart from comment #8)
> https://sourceforge.net/p/xine/tickets/11/

I can confirm that the patch in this bug report allows the compilation to complete. Thanks for the hint!
Comment 10 Larry the Git Cow gentoo-dev 2022-03-22 17:02:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=377be0b52f115818ea3c2d00367f0b2b5c91b0f1

commit 377be0b52f115818ea3c2d00367f0b2b5c91b0f1
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-03-22 16:53:01 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-03-22 17:02:02 +0000

    media-libs/xine-lib: fix automagic libaom, dav1d; fix build with dav1d-1.0.0
    
    Closes: https://bugs.gentoo.org/835791
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/xine-lib-1.2.12-dav1d-1.0.0.patch        | 22 ++++++++++++++++++++++
 media-libs/xine-lib/metadata.xml                   |  3 +++
 ...lib-1.2.12.ebuild => xine-lib-1.2.12-r1.ebuild} | 13 ++++++++++---
 media-libs/xine-lib/xine-lib-1.2.9999.ebuild       |  9 ++++++---
 profiles/arch/hppa/package.use.mask                |  4 ++++
 5 files changed, 45 insertions(+), 6 deletions(-)
Comment 11 Larry the Git Cow gentoo-dev 2022-05-19 22:46:01 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=be42b487bdbb8acdb5c3765710a3a785f2e38c9e

commit be42b487bdbb8acdb5c3765710a3a785f2e38c9e
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-05-19 22:40:15 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-05-19 22:45:42 +0000

    media-libs/xine-lib: disable dav1d for 1.2.11
    
    1.2.12 has dav1d support enabled properly (and a patch for >= 1.0.0)
    but in 1.2.11, it was automagic. Let's just disable it entirely
    in 1.2.11 given that it fails to build and we've had to mask (for now)
    1.2.12 because of crashes.
    
    Closes: https://bugs.gentoo.org/846398
    Bug: https://bugs.gentoo.org/835791
    Bug: https://bugs.gentoo.org/845396
    Signed-off-by: Sam James <sam@gentoo.org>

 .../xine-lib/{xine-lib-1.2.11.ebuild => xine-lib-1.2.11-r1.ebuild}   | 5 +++--
 media-libs/xine-lib/xine-lib-1.2.9999.ebuild                         | 2 +-
 2 files changed, 4 insertions(+), 3 deletions(-)