Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 83464 - New rsync and source of Gentoo mirror in Russia
Summary: New rsync and source of Gentoo mirror in Russia
Status: RESOLVED FIXED
Alias: None
Product: Mirrors
Classification: Unclassified
Component: New Server (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mirror Admins
URL: http://www.org.kemsu.ru/gentoo
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-27 07:48 UTC by Roman Bondarev
Modified: 2007-06-04 14:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Bondarev 2005-02-27 07:48:58 UTC
Our University have setup gentoo portage and source&installation file mirror for x86 (maybe, and for Sparc). Installation only for current version (now - 2004.3).

IP address: 82.179.1.5
HTTP:  http://www.org.kemsu.ru/gentoo
FTP:    ftp://ftp.org.kemsu.ru/gentoo
RSYNC rsync://rsync.org.kemsu.ru/gentoo (exclude gentoo-portage) and
      rsync://rsync.org.kemsu.ru/gentoo-portage

The machine is located in Kemerovo (Kemerovo State University), Russia.
Our mirror administration e-mail is root@org.kemsu.ru.


Reproducible: Always
Steps to Reproduce:
1. Reproducibility of gentoo-portage now once at four o'clock.
2. Source and snapshots - once a day.
3. Installation's tree - manually.
Comment 1 Jeffrey Forman (RETIRED) gentoo-dev 2005-08-30 04:29:04 UTC
i apologize for the long delay on this bug. to be a distfiles mirror, you need
to be syncing every 4 hours from your local midnight to be considered current.

as for the rsync mirror, it is a bit off. get that syncing and i'll be happy to
add you into rotation.

-jeffrey

IP: rsync.org.kemsu.ru  BUG:
Checked (UTC)   Timestamp
================================================
     11:27:49   Wed, 17 Aug 2005 01:51:01 +0000
Comment 2 Roman Bondarev 2005-09-02 20:43:36 UTC
(In reply to comment #1)
> ...to be a distfiles mirror, you need
> to be syncing every 4 hours from your local midnight to be considered current.

Well. I have replaced parameters of updating. Now all resources of a mirror are 
updated from Russian resource ayia.ru. Distfiles and Snapshots will be updated 
each 4 hours. Try to check up through 12 hours.

BR, POMAH.
Comment 3 Jeffrey Forman (RETIRED) gentoo-dev 2005-10-20 05:59:30 UTC
Roman,

It seems your distfiles mirror is off by quite a bit:
Fri, 30 Sep 2005 19:02:47 +0000

Get that syncing again every 4 hours from midnight and I can see about getting
you added into rotation.

About the rsync mirror, it seems it is a bit off also:
IP: rsync.org.kemsu.ru
Checked at (UTC)   Timestamp
================================================
     12:58:53   Wed, 05 Oct 2005 05:20:01 +0000

Make sure that is syncing according to our rsync documents and we can get you
added into rotation. Thanks!

Cheers,
Jeffrey

Comment 4 Roman Bondarev 2005-10-22 08:33:02 UTC
(In reply to comment #3)
> About the rsync mirror, it seems it is a bit off also:
> IP: rsync.org.kemsu.ru
> Checked at (UTC)   Timestamp
> ================================================
>      12:58:53   Wed, 05 Oct 2005 05:20:01 +0000

Sorry, the mechanism of updatings was blocked (there were lock-files that 
repeated processes of updating were not started). I have repaired and have 
tried, that it did not occur any more.
Comment 5 Jeffrey Forman (RETIRED) gentoo-dev 2006-02-03 13:48:58 UTC
Roman,

Sorry about the long delay. I was just checking your mirror today and got this:

Forbidden
You don't have permission to access /gentoo/distfiles/timestamp.chk on this server.
Apache/1.3.29 Server at www.org.kemsu.ru Port 8100

Any ideas here?
Comment 6 Roman Bondarev 2006-02-07 16:36:34 UTC
(In reply to comment #5)
> Roman,
> 
> Sorry about the long delay. I was just checking your mirror today and got this:
> 
> Forbidden
> You don't have permission to access /gentoo/distfiles/timestamp.chk on this
> server.
> Apache/1.3.29 Server at www.org.kemsu.ru Port 8100
> 
Excuse, has checked up mail only today after a long break.
Нен, no ideas are present, because:
http://www.org.kemsu.ru:8101/gentoo/distfiles/timestamp.chk: (8101 - for codepage 1251)
Tue, 07 Feb 2006 20:02:49 +0000
Comment 7 Roman Bondarev 2006-02-11 08:43:04 UTC
I am sorry, the mirror is down :_( - a problem with a hard disk. Time of restoration is not known. :(
Comment 8 Roman Bondarev 2006-03-23 06:07:51 UTC
(In reply to comment #7)
> I am sorry, the mirror is down :_( - a problem with a hard disk. Time of
> restoration is not known. :(
> 

Well! The mirror is restored and updated. We wait only for you, Jeffrey! :)
Comment 9 Jeffrey Forman (RETIRED) gentoo-dev 2006-03-23 06:25:15 UTC
Roman,

I just checked your mirror and there is a serious problem. You are only mirroring x86, sparc, and amd64 architectures. This is not a viable condition for being a mirror. You have the election of excluding historical and experimental, but not selecting each individual architecture you feel like mirroring.
Comment 10 Alexey Chumakov (RETIRED) gentoo-dev 2006-04-03 02:12:01 UTC
Dear Roman,
I've recently added the 'Gentoo Linux Source Mirrors Policy' translated to Russian:
http://www.gentoo.org/doc/ru/source_mirrors.xml

Please don't hesitate to check with this document to get your mirror up soon ;)

2Jeffrey: Think it could help :)
Comment 11 Roman Bondarev 2006-04-03 07:21:35 UTC
(In reply to comment #10)
> Dear Roman,
> I've recently added the 'Gentoo Linux Source Mirrors Policy' translated to
> Russian:
> http://www.gentoo.org/doc/ru/source_mirrors.xml

Да я и так английский понимаю. Вот с обратным процессом - проблемы :)


Comment 12 Roman Bondarev 2006-04-03 07:22:51 UTC
(In reply to comment #9)
> Roman,
> 
> I just checked your mirror and there is a serious problem. You are only
> mirroring x86, sparc, and amd64 architectures. This is not a viable condition
> for being a mirror. You have the election of excluding historical and
> experimental, but not selecting each individual architecture you feel like
> mirroring.
> 
Джефри, you not so have understood me. I wished to organize a partial mirror - distfile and snapshots. And also a tree portage. Current releases are already another.
Comment 13 Roman Bondarev 2006-04-03 07:26:11 UTC
(In reply to comment #12)
> Джефри

Ups... This was been "Jeffrey". By Russian.
Comment 14 Jeffrey Forman (RETIRED) gentoo-dev 2006-04-15 16:17:14 UTC
Thanks for helping out Gentoo. I have added your mirror to our list at http://www.gentoo.org/main/en/mirrors.xml. Please start synching from masterdistfiles.gentoo.org as the email I have sent to you instructs. We would like you to subscribe to the gentoo-mirrors Mailing List by sending an email to gentoo-mirrors-subscribe@lists.gentoo.org, as we send out notifications of updates, releases, and changes in policy to the mirrors.  
Please also monitor http://mirrorstats.gentoo.org as this application is used to keep track of the up-to-date nature of our mirrors.

Once again, thanks for the hardware and bandwidth!

For Infrastructure,
Jeffrey
Comment 15 Roman Bondarev 2006-04-19 05:36:11 UTC
(In reply to comment #14)
Jeffrey, but how about rsync mirror of gentoo-portage?
Comment 16 Jeffrey Forman (RETIRED) gentoo-dev 2006-04-25 13:54:34 UTC
Thanks for helping out Gentoo. I have added the IP you specified in the bug to our access database, please start synching to rsync1.us.gentoo.org per our Rsync document at http://www.gentoo.org/doc/en/rsync.xml. We would like you to subscribe to the gentoo-mirrors Mailing List by sending an email to gentoo-mirrors-subscribe@lists.gentoo.org, as we send our notifications of updates, releases, and changes in policy to the mirrors. Once again, thanks for the hardware and bandwidth!

Please also monitor http://mirrorstats.gentoo.org/rsync as this application is used to keep track of the up-to-date nature of our mirrors

For Infrastructure,
Jeffrey

You are known as rsync2.ru.gentoo.org in the rsync.ru.gentoo.org rotation.
Comment 17 Roman Bondarev 2006-05-19 19:42:35 UTC
(In reply to comment #14)
> Thanks for helping out Gentoo. I have added your mirror to our list at
Jeffrey, where is my mirror? Why it has been removed from all lists of gentoo-mirrors?
Comment 18 Yuriy Rusinov 2007-04-26 08:12:16 UTC
(In reply to comment #17)
> (In reply to comment #14)
> > Thanks for helping out Gentoo. I have added your mirror to our list at
> Jeffrey, where is my mirror? Why it has been removed from all lists of
> gentoo-mirrors?
> 

Hello, Roman !

I try to open http://www.org.kemsu.ru/gentoo mirror, it requires authorization. Which way I have to receive login and password for this mirror ? ftp-server does not require authorization.
Comment 19 Robert Baxter 2007-06-03 22:02:05 UTC
Your mirror appears to be broken...
http://www.org.kemsu.ru/gentoo
The page cannot be found
    * Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
    * Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

Ugh.
Comment 20 Roman Bondarev 2007-06-04 14:29:17 UTC
(In reply to comment #19)
> Your mirror appears to be broken...
> http://www.org.kemsu.ru/gentoo

Oh, yes. WWW(Apache) have been removed from server by other administrators. Please, remove http address :(

P.S.: But, where my host in partial mirrors list?