Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 832526 - dev-util/hip-4.3.0-r1 '/usr/lib64/librt.so', needed by 'lib/libamdhip64.so.4.3', missing and no known rule to make it with >=glibc-2.34
Summary: dev-util/hip-4.3.0-r1 '/usr/lib64/librt.so', needed by 'lib/libamdhip64.so.4....
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard: ~arch only
Keywords:
Depends on:
Blocks: glibc-2.34
  Show dependency tree
 
Reported: 2022-02-02 01:30 UTC by Alessandro Barbieri
Modified: 2022-02-12 18:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge_info (emerge_info,36.34 KB, text/plain)
2022-02-02 01:30 UTC, Alessandro Barbieri
Details
hip-4.3.0-r1:20220201-160533.log (hip-4.3.0-r1:20220201-160533.log,11.31 KB, text/plain)
2022-02-02 01:30 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2022-02-02 01:30:20 UTC
This package fails to build on an unstable system. Attached relevant logs and emerge --info
Comment 1 Alessandro Barbieri 2022-02-02 01:30:25 UTC
Created attachment 764161 [details]
emerge_info

emerge --info
Comment 2 Alessandro Barbieri 2022-02-02 01:30:26 UTC
Created attachment 764162 [details]
hip-4.3.0-r1:20220201-160533.log

build log
Comment 3 Alessandro Barbieri 2022-02-02 01:35:36 UTC
Since glibc-2.34 librt.so isn't provided anymore
Comment 4 Alessandro Barbieri 2022-02-02 01:55:33 UTC
Re-emerging rocclr will update the cmake cache and fix the issue
Comment 5 Benda Xu gentoo-dev 2022-02-02 02:58:40 UTC
(In reply to Alessandro Barbieri from comment #4)
> Re-emerging rocclr will update the cmake cache and fix the issue

Yeah, I discovered the same solution.
Comment 6 Benda Xu gentoo-dev 2022-02-02 04:03:23 UTC
dev-libs/rocclr should be reinstalled after the glibc-2.34.  This will be taken care of by the glibc-2.34 new item in the future.