Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 83243 - www-proxy/otrproxy-0.2.0 ebuild
Summary: www-proxy/otrproxy-0.2.0 ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Default Assignee for New Packages
Keywords: EBUILD
Depends on:
Reported: 2005-02-24 17:06 UTC by Marcelo Goes (RETIRED)
Modified: 2006-01-26 11:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

otrproxy-0.2.0.ebuild (otrproxy-0.2.0.ebuild,758 bytes, text/plain)
2005-02-24 17:06 UTC, Marcelo Goes (RETIRED)
otrproxy-0.2.0.ebuild (otrproxy-0.2.0.ebuild,1.26 KB, text/plain)
2005-03-09 20:46 UTC, Rob Cakebread (RETIRED)
otrproxy-0.2.0-configure.patch (otrproxy-0.2.0-configure.patch,534 bytes, patch)
2005-03-09 21:17 UTC, Rob Cakebread (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Goes (RETIRED) gentoo-dev 2005-02-24 17:06:20 UTC
Hello there,

"This is a localhost proxy you can use with almost any AIM client in order to participate in Off-the-Record conversations."

I tried making an ebuild for it, but I'm getting an error:

checking for wxWindows version >= 2.5.0... no (version 2.4.2 is not new enough)
configure: error: wxWidgets 2.5.0 or newer is required.

(I get this even though I emerged x11-libs/wxGTK-2.5.3).

Hopefully someone who's seen this before can deal with it more efficiently than me? :-) I'm attaching my ebuild.
Comment 1 Marcelo Goes (RETIRED) gentoo-dev 2005-02-24 17:06:47 UTC
Created attachment 52076 [details]
Comment 2 Marcelo Goes (RETIRED) gentoo-dev 2005-02-25 07:03:09 UTC
Tried adding inherit wxwidgets, export WX_GTK_VER="2.5" in src_compile(), problem persists.
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2005-02-25 13:45:27 UTC
this program has nothing to do with www-proxy! 
sorry, it should be reassigned by bug-wranglers
Comment 4 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-02-25 17:41:33 UTC
gaim-bugs: maybe you'd be interested in this since it's for AIM clients.
Comment 5 Don Seiler (RETIRED) gentoo-dev 2005-03-03 07:35:40 UTC
It needs a newer version of wxWidgets than we have in portage.   I'll talk with that maintainer.

checking for wx-config... /usr/bin/wx-config
checking for wxWindows version >= 2.5.0... no (version 2.4.2 is not new enough)
configure: error: wxWidgets 2.5.0 or newer is required.
Comment 6 Don Seiler (RETIRED) gentoo-dev 2005-03-09 17:44:50 UTC
pythonhead,  can you comment on the state of wxGTK >= 2.5.0?  I see 2.5.4 is out, perhaps that might have fixed the OpenGL issues?
Comment 7 Rob Cakebread (RETIRED) gentoo-dev 2005-03-09 19:24:28 UTC
Hi Don,

It probably just needs to use the wxwidgets eclass. I'll look at it and provide a patch/new ebuild.

2.5.3 is in portage but hard-masked because only a few packages compile against it (wxpython, amule, maybe one other). wxGTK is now slotted 2.4 and 2.5 but I'm waiting for about 5 more packages I don't maintain to change their dependencies to be pegged at =2.4*. Thats the only reason 2.5.3 is hardmasked at this point.

Comment 8 Rob Cakebread (RETIRED) gentoo-dev 2005-03-09 20:46:44 UTC
Created attachment 53050 [details]

This ebuild compiled with gtk2 (ansi) and gtk2 unicode. Both started up in the
console but I guess you need to run gaim to get the gui to show up, which I
didn't test. It should compile with gtk (-gtk2) but I didn't test that.
Comment 9 Rob Cakebread (RETIRED) gentoo-dev 2005-03-09 21:17:54 UTC
Created attachment 53052 [details, diff]
Comment 10 Marcelo Goes (RETIRED) gentoo-dev 2006-01-26 11:34:24 UTC
I guess nobody cares about this one. Neither do I actually. Closing.