Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 832413 - dev-util/ccache-4.5.1 failed to rebuild with USE=doc
Summary: dev-util/ccache-4.5.1 failed to rebuild with USE=doc
Status: RESOLVED DUPLICATE of bug 681886
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-31 08:25 UTC by Leonid Kopylov
Modified: 2022-02-01 00:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,53.72 KB, text/plain)
2022-01-31 08:25 UTC, Leonid Kopylov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2022-01-31 08:25:21 UTC
# emerge -pqv '=dev-util/ccache-4.5.1::gentoo'
[ebuild   R   ] dev-util/ccache-4.5.1  USE="doc* redis static-c++ -test"

# emerge --info '=dev-util/ccache-4.5.1::gentoo'
Portage 3.0.30 (python 3.9.10-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-11.2.1, glibc-2.34-r7, 5.16.4-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.16.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-8700B_CPU_@_3.20GHz-with-glibc2.34
KiB Mem:     8120272 total,    882884 free
KiB Swap:    8388604 total,   8351996 free
Timestamp of repository gentoo: Sun, 30 Jan 2022 05:00:01 +0000
Head commit of repository gentoo: 0dbec6ec6aa08ef726cf783b5d9aab261192e853
sh bash 5.1_p16
ld GNU ld (Gentoo 2.37_p1 p2) 2.37
ccache version 4.5.1 [disabled]
app-misc/pax-utils:        1.3.3::gentoo
app-shells/bash:           5.1_p16::gentoo
dev-java/java-config:      2.3.1::gentoo
dev-lang/perl:             5.34.0-r6::gentoo
dev-lang/python:           3.9.10-r1::gentoo, 3.10.2-r1::gentoo, 3.11.0_alpha4::gentoo
dev-lang/rust-bin:         1.58.1::gentoo
dev-util/ccache:           4.5.1::gentoo
dev-util/cmake:            3.22.2::gentoo
dev-util/meson:            0.60.3::gentoo
sys-apps/baselayout:       2.8::gentoo
sys-apps/sandbox:          2.29::gentoo
sys-apps/systemd:          250.3::gentoo
sys-devel/autoconf:        2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:        1.16.5::gentoo
sys-devel/binutils:        2.37_p1-r2::gentoo
sys-devel/binutils-config: 5.4::gentoo
sys-devel/gcc:             11.2.1_p20220115::gentoo
sys-devel/gcc-config:      2.5-r1::gentoo
sys-devel/libtool:         2.4.6-r6::gentoo
sys-devel/llvm:            13.0.0::gentoo
sys-devel/make:            4.3::gentoo
sys-kernel/linux-headers:  5.16::gentoo (virtual/os-headers)
sys-libs/glibc:            2.34-r7::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA google-chrome OPERA-2018 PUEL AnyDesk-TOS geekbench TeamViewer microsoft-edge Vivaldi"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php8.1/ext-active/ /etc/php/cgi-php8.1/ext-active/ /etc/php/cli-php8.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg-live config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/bash"
USE="X a52 aac accessibility acl acpi alsa amd64 apache2 appindicator archive audit bash-completion berkdb bidi bluetooth bluray boost branding brotli bzip2 cairo cdda cdr cgi cli colord cracklib crypt cryptsetup cups curl dbi dbus device-mapper djvu dri dts dvd dvdr eds emacs encode evo examples exif expat experimental extras fam fastcgi fbcon firebird flac fontconfig fortran ftp fuse games gd gdbm geoip gif git gmp gnome gnome-keyring gnome-online-accounts gnuplot go gpg gphoto2 gpm graphviz gssapi gstreamer gtk gtk-doc gtk3 gui guile heif hscolour html http http2 iconv icu idn imagemagick imap imlib introspection iodbc ios ipv6 jack java javascript jpeg json kerberos lapack latex lcms ldap libcaca libglvnd libnotify libsamplerate libsecret libtirpc lmdb lua lvm lz4 lzma m17n-lib mad magic maildir mbox mng mongodb mono mp3 mp4 mpeg mssql mtp multilib mysqli nas nautilus ncurses netlink networkmanager nfs nls nptl odbc offensive ogg opengl openmp opus pam pango pcap pcre pdf perl pkcs11 plugins png policykit ppds pulseaudio python qdbm qt5 readline redis samba sasl sdl seccomp smtp sndfile sndio snmp sockets socks5 sound source sox spell split-usr sqlite ssh ssl startup-notification svg symlink syslog sysprof systemd tcl threads tiff tk tools tracker truetype udev udisks unicode unwind upnp upnp-av upower usb utils uuid vim-syntax vorbis wayland webkit webp widgets wxwidgets x264 xattr xcb xemacs xface xft xinerama xml xpm xv xvid zeroconf zip zlib zsh-completion zstd" ABI_X86="64 32" ADA_TARGET="gnat_2020" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US he ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell wiki-publisher scripting-javascript" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-4 php8-0" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965 iris vmware vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EMERGE_DEFAULT_OPTS, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LEX, LFLAGS, LIBTOOL, LINGUAS, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS

=================================================================
                        Package Settings
=================================================================

dev-util/ccache-4.5.1::gentoo was built with the following:
USE="redis static-c++ -doc -test" ABI_X86="(64)"
FEATURES="usersync binpkg-dostrip buildpkg-live news network-sandbox distlocks usersandbox ipc-sandbox assume-digests sfperms unmerge-logs merge-sync parallel-fetch pid-sandbox userfetch qa-unresolved-soname-deps binpkg-logs config-protect-if-modified xattr ebuild-locks protect-owned binpkg-docompress multilib-strict strict preserve-libs unknown-features-warn sandbox unmerge-orphans userpriv fixlafiles"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -static-libstdc++"
Comment 1 Leonid Kopylov 2022-01-31 08:25:54 UTC
Created attachment 764021 [details]
build.log
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-31 22:55:17 UTC
[31mFAILED: [0mdoc/AUTHORS.html /var/tmp/portage/dev-util/ccache-4.5.1/work/ccache-4.5.1_build/doc/AUTHORS.html 
cd /var/tmp/portage/dev-util/ccache-4.5.1/work/ccache-4.5.1_build/doc && /usr/bin/asciidoctor -o AUTHORS.html -a revnumber="4.5.1" -a icons=font -a toc=left -a sectanchors -a stylesheet="/var/tmp/portage/dev-util/ccache-4.5.1/work/ccache-4.5.1/doc/ccache-doc.css" -b html /var/tmp/portage/dev-util/ccache-4.5.1/work/ccache-4.5.1/doc/AUTHORS.adoc
/usr/bin/asciidoctor:9:in `load': cannot load such file -- /usr/lib64/ruby/gems/3.0.0/gems/asciidoctor-2.0.16/bin/asciidoctor (LoadError)
	from /usr/bin/asciidoctor:9:in `<main>'

Is asciidoctor installed for 30?
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-01 00:43:04 UTC

*** This bug has been marked as a duplicate of bug 681886 ***