Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 832035 - dev-lang/julia-1.7.1-r2: segfault with net-misc/curl-7.81.0
Summary: dev-lang/julia-1.7.1-r2: segfault with net-misc/curl-7.81.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
: 832064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-25 11:45 UTC by mischdele
Modified: 2022-05-26 22:38 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Building julia succeeds with curl 7.80 installed (build-success-curl-7.80.log.xz,46.41 KB, application/x-xz)
2022-01-26 11:42 UTC, mischdele
Details
Building julia fails with curl 7.81 installed (build-fail-curl-7.81.log.xz,21.89 KB, application/x-xz)
2022-01-26 11:43 UTC, mischdele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mischdele 2022-01-25 11:45:04 UTC
Julia segfaults after upgrading to curl 7.81.0 when trying to update packages. Downgrading curl to 7.80.0 fixes the problem. Maybe it's this issue:

https://github.com/JuliaLang/Downloads.jl/issues/163
https://github.com/JuliaLang/Downloads.jl/pull/164

Arch Linux has a related patch:

https://github.com/archlinux/svntogit-community/blob/master/julia/trunk/julia-curl-7.81.patch

Reproducible: Always

Steps to Reproduce:
1. Run julia -e 'using Pkg; Pkg.update()' with net-misc/curl-7.81.0 installed
Actual Results:  
$ julia -e 'using Pkg; Pkg.update()'
    Updating registry at `~/.julia/registries/General.toml`

signal (11): Segmentation fault
in expression starting at none:1
unknown function (ip: 0x7f56554d7b71)
unknown function (ip: 0x7f56554c05d5)
unknown function (ip: 0x7f56554c1b52)
curl_multi_socket_action at /usr/bin/../lib64/julia/libcurl.so (unknown line)
unknown function (ip: 0x7f565c2d72bf)
unknown function (ip: 0x7f565c2d75e8)
unknown function (ip: 0x7f565c2df168)
unknown function (ip: 0x7f565c2df30f)
unknown function (ip: 0x7f565c3197ae)
unknown function (ip: 0x7f56554bdeb4)
curl_multi_add_handle at /usr/bin/../lib64/julia/libcurl.so (unknown line)
unknown function (ip: 0x7f565c2614e4)
unknown function (ip: 0x7f565c261ad8)
unknown function (ip: 0x7f565bc8376e)
unknown function (ip: 0x7f565bc84629)
unknown function (ip: 0x7f565bc84ad7)
unknown function (ip: 0x7f565bc84cb8)
unknown function (ip: 0x7f565bc84d37)
unknown function (ip: 0x7f565c2d24c3)
unknown function (ip: 0x7f565c2d579d)
unknown function (ip: 0x7f565c2d5986)
unknown function (ip: 0x7f565bc8546e)
unknown function (ip: 0x7f565bc85e97)
unknown function (ip: 0x7f565be0799e)
unknown function (ip: 0x7f565be07a2f)
unknown function (ip: 0x7f565bc1ace9)
unknown function (ip: 0x7f565bc1ae71)
unknown function (ip: 0x7f565c290e81)
unknown function (ip: 0x7f565be04923)
pkg_server_registry_url at /var/tmp/portage/dev-lang/julia-1.7.1-r2/work/julia-1.7.1/usr/share/julia/stdlib/v1.7/Pkg/src/Registry/Registry.jl:64 [inlined]
#update#54 at /var/tmp/portage/dev-lang/julia-1.7.1-r2/work/julia-1.7.1/usr/share/julia/stdlib/v1.7/Pkg/src/Registry/Registry.jl:357
unknown function (ip: 0x7f566921c08f)
Allocations: 1368035 (Pool: 1367394; Big: 641); GC: 2
Segmentation fault (core dumped)

Expected Results:  
No segfault

Portage 3.0.30 (python 3.10.2-final-0, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-11.2.1, glibc-2.34-r6, 5.16.2-gentoo x86_64)
=================================================================
System uname: Linux-5.16.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-7500U_CPU_@_2.70GHz-with-glibc2.34
KiB Mem:    16154028 total,   1907844 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of repository gentoo: Tue, 25 Jan 2022 09:30:01 +0000
Head commit of repository gentoo: f7ec6b60b66ee4dc2459e8734e8f2113e8cc9e88

sh bash 5.1_p16
ld GNU ld (Gentoo 2.37_p1 p1) 2.37
app-misc/pax-utils:        1.3.3::gentoo
app-shells/bash:           5.1_p16::gentoo
dev-lang/perl:             5.34.0-r6::gentoo
dev-lang/python:           2.7.18_p13::gentoo, 3.9.10-r1::gentoo, 3.10.2-r1::gentoo
dev-lang/rust:             1.58.1::gentoo
dev-util/cmake:            3.22.1::gentoo
dev-util/meson:            0.60.3::gentoo
sys-apps/baselayout:       2.8::gentoo
sys-apps/sandbox:          2.29::gentoo
sys-apps/systemd:          250.3::gentoo
sys-devel/autoconf:        2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:        1.16.5::gentoo
sys-devel/binutils:        2.37_p1-r1::gentoo
sys-devel/binutils-config: 5.4::gentoo
sys-devel/clang:           13.0.0::gentoo
sys-devel/gcc:             11.2.1_p20211127::gentoo
sys-devel/gcc-config:      2.5-r1::gentoo
sys-devel/libtool:         2.4.6-r6::gentoo
sys-devel/lld:             13.0.0::gentoo
sys-devel/llvm:            13.0.0::gentoo
sys-devel/make:            4.3::gentoo
sys-kernel/linux-headers:  5.16::gentoo (virtual/os-headers)
sys-libs/glibc:            2.34-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

localrepo
    location: /usr/local/portage
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php8.1/ext-active/ /etc/php/cgi-php8.1/ext-active/ /etc/php/cli-php8.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg-live config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/zsh"
USE="X a52 aac acl acpi activities alsa amd64 bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus declarative dri dts encode exif flac fortran gdbm gif gles gles2 gui iconv icu ipv6 jpeg kde kipi kwallet laptop lcms libglvnd libnotify libtirpc mad mmx mng mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf plasma png policykit ppds pulseaudio qml qt5 readline screencast sdl seccomp semantic-desktop spell split-usr sse sse2 ssl startup-notification svg systemd tiff truetype udev udisks uefi unicode upower usb user-session vaapi vdpau vorbis vulkan wayland widgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2020" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-4 php8-0" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_10" PYTHON_TARGETS="python3_10" RUBY_TARGETS="ruby26 ruby27" USERLAND="GNU" VIDEO_CARDS="intel iris" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EMERGE_DEFAULT_OPTS, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LEX, LFLAGS, LIBTOOL, LINGUAS, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS
Comment 1 Jonas Stein gentoo-dev 2022-01-25 18:43:34 UTC
Thank you for the report. We need to have all information at hand before ticket assignment. This includes
* the complete build.log as attachment and
* paste the emerge info 
as described on https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
Comment 2 mischdele 2022-01-26 11:42:49 UTC
Created attachment 763662 [details]
Building julia succeeds with curl 7.80 installed
Comment 3 mischdele 2022-01-26 11:43:08 UTC
Created attachment 763663 [details]
Building julia fails with curl 7.81 installed
Comment 4 foufou33 2022-02-04 01:57:18 UTC
even 1.6x is affected.
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-04 04:59:33 UTC
*** Bug 832064 has been marked as a duplicate of this bug. ***
Comment 6 Maciej Barć gentoo-dev 2022-05-26 22:38:22 UTC
It was discovered a while ago that curl >=7.81 does NOT work with Julia, I added version constraints for curl as soon as I found it out.
Please, sync your tree and re-emerge Curl & Julia.
I'm very sorry for inconvenience, 
closing this because "fixes" are already in ::gentoo.