Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 829099 - x11-libs/qwtpolar-1.1.1-r2 - qwt_polar_fitter.cpp: error: aggregate QPolygonF fittedPoints has incomplete type and cannot be defin
Summary: x11-libs/qwtpolar-1.1.1-r2 - qwt_polar_fitter.cpp: error: aggregate QPolygonF...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-13 17:12 UTC by Toralf Förster
Modified: 2022-02-09 07:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.94 KB, text/plain)
2021-12-13 17:12 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,228.76 KB, text/plain)
2021-12-13 17:12 UTC, Toralf Förster
Details
environment (environment,55.78 KB, text/plain)
2021-12-13 17:12 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,16.85 KB, application/x-bzip)
2021-12-13 17:12 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,16.48 KB, application/x-bzip)
2021-12-13 17:12 UTC, Toralf Förster
Details
x11-libs:qwtpolar-1.1.1-r2:20211213-165048.log (x11-libs:qwtpolar-1.1.1-r2:20211213-165048.log,10.93 KB, text/plain)
2021-12-13 17:12 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-12-13 17:12:44 UTC
                 from qwt_polar_fitter.cpp:9:
/usr/include/qwt6/qwt_curve_fitter.h:16:7: note: forward declaration of ‘class QPolygonF’
   16 | class QPolygonF;
      |       ^~~~~~~~~
qwt_polar_fitter.cpp:74:15: error: aggregate ‘QPolygonF fittedPoints’ has incomplete type and cannot be defined
   74 |     QPolygonF fittedPoints;
      |               ^~~~~~~~~~~~
qwt_polar_fitter.cpp:76:21: error: invalid use of incomplete type ‘const class QPolygonF’
   76 |     int numPoints = points.size() + ( points.size() - 1 ) * d_data->stepCount;

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j4-20211210-190248

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.1 *
clang version 13.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/13/bin
/usr/lib/llvm/13
13.0.0
Python 3.9.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby27 (with Rubygems)
  [3]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.57.0 *
The following VMs are available for generation-2:
1)	IcedTea JDK 3.21.0 [icedtea-8]
*)	AdoptOpenJDK 8.312_p07 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-8 
  [2]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4
php cli:
  [1]   php7.3
  [2]   php7.4
  [3]   php8.1 *

  HEAD of ::gentoo
commit ed9d83a2733429c6e58cb170e9c63c693248e189
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Mon Dec 13 16:21:45 2021 +0000

    2021-12-13 16:21:43 UTC

emerge -qpvO x11-libs/qwtpolar
[ebuild  N    ] x11-libs/qwtpolar-1.1.1-r2
Comment 1 Toralf Förster gentoo-dev 2021-12-13 17:12:45 UTC
Created attachment 758820 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-12-13 17:12:47 UTC
Created attachment 758821 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-12-13 17:12:48 UTC
Created attachment 758822 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-12-13 17:12:49 UTC
Created attachment 758823 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-12-13 17:12:50 UTC
Created attachment 758824 [details]
temp.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-12-13 17:12:51 UTC
Created attachment 758825 [details]
x11-libs:qwtpolar-1.1.1-r2:20211213-165048.log
Comment 7 Andreas Sturmlechner gentoo-dev 2021-12-13 17:20:26 UTC
This is likely obsolete with qwt-6.2.0: "Since Qwt 6.2 all classes have been moved to the Qwt package".

https://sourceforge.net/projects/qwtpolar/
Comment 8 Dennis Schridde 2021-12-13 22:14:05 UTC
(In reply to Andreas Sturmlechner from comment #7)
> This is likely obsolete with qwt-6.2.0: "Since Qwt 6.2 all classes have been
> moved to the Qwt package".
> 
> https://sourceforge.net/projects/qwtpolar/

On my system x11-libs/qwtpolar is required by sci-geosciences/qgis[polar].  Could it be updated to depend on `polar? ( || ( >=x11-libs/qwt-6.2.0 x11-libs/qwtpolar ) )`?