Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 82682 - Patch to increase system memory to 1GB without enabling HIGHMEM
Summary: Patch to increase system memory to 1GB without enabling HIGHMEM
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://kerneltrap.org/node/2450?PHPSE...
Whiteboard:
Keywords:
: 92237 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-20 07:03 UTC by Pedro Castro
Modified: 2005-06-02 10:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to use 1GB Low Memory (1g_lowmem1_i386.diff,1.35 KB, patch)
2005-02-20 07:05 UTC, Pedro Castro
Details | Diff
Patch to get VMWARE modules to compile when using 1g_lowmem (vmware-config.1gb.lowmem.patch,557 bytes, patch)
2005-02-20 15:52 UTC, Ted White
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Castro 2005-02-20 07:03:40 UTC
This is the ck-sources 1g_lowmem_i386 patch, changed accordingly to patch gentoo-dev-sources 2.10 kernel. Currently, gentoo-dev-sources can only use up to 896MB of RAM, but nowadays 1GB seems to be slightly common limit.

Reproducible: Always
Steps to Reproduce:
1. Boot Linux
Actual Results:  
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
896MB LOWMEM available.
Comment 1 Pedro Castro 2005-02-20 07:05:20 UTC
Created attachment 51665 [details, diff]
Patch to use 1GB Low Memory

Use in /usr/src/linux.
Comment 2 Daniel Drake (RETIRED) gentoo-dev 2005-02-20 07:47:57 UTC
This breaks things like vmware and cxoffice. If it is truly "the good solution" to the 1GB lowmem problem, then get it accepted into the official kernel tree first and then it will automatically be included in gentoo-dev-sources.
Comment 3 Ted White 2005-02-20 14:58:31 UTC
Can't speak to cxoffice, but the vmware problem is easy to fix.  I have a diff for the vmware-config.pl that allows me to use vmware with the 1g_lowmem patch...
Should I attach?
Comment 4 Pedro Castro 2005-02-20 15:36:49 UTC
Well, i agree that breaking applications isn't a good thing, but i wonder whether the problem is in the application itself or in the kernel change. I think the level of dependency between the kernel and the applications should be minimal, and so this kind of modification theoreticaly shouldn't be impeded by a set of applications.
I've submited this bug to kernel.org, it can be tracked in http://bugzilla.kernel.org/show_bug.cgi?id=4232.

Ted White, i think your patch would be useful, so anyone using the 1GB patch would know how to handle the vmware problem.
Comment 5 Ted White 2005-02-20 15:52:53 UTC
Created attachment 51724 [details, diff]
Patch to get VMWARE modules to compile when using 1g_lowmem
Comment 6 Sridhar Dhanapalan 2005-02-20 16:58:16 UTC
I have no problems running cxoffice 3.0 on a ck-sources kernel with 1gb-LOWMEM turned on.
Comment 7 Sridhar Dhanapalan 2005-03-05 01:44:42 UTC
I can confirm that cxoffice 4.1 works on a ck-sources kernel with 1gb-LOWMEM turned on.
Comment 8 Stefan Schweizer (RETIRED) gentoo-dev 2005-03-05 01:51:01 UTC
Then get upstream (lkml.org) to accept it please and it will be in all further kernels.
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2005-05-11 06:28:40 UTC
*** Bug 92237 has been marked as a duplicate of this bug. ***
Comment 10 Kerin Millar 2005-05-27 15:23:15 UTC
> This breaks things like vmware and cxoffice

It's these applications that are fundamentally broken, not the patch. I don't
see what the big issue is there because the patch provides a feature which is
entirely _optional_. Provided that the help text for the Kconfig option is clear
on the matter, then people are duly forwarned of the (very) limited scope for
breakage. Users of vmware/cxoffice can leave the feature disabled and use
HIGHMEM instead! In the meantime this is incredibly useful for people like me
who run servers with 1G of memory and don't wish to be encumbered with the
overhead of HIGHMEM. The patch works and is utterly stable. I have also tested a
variant patch I prepared which supports PaX (in fact that patch has also been
deployed by a developer for some time now) and it works perfectly. I suspect
that there would be resistance upstream on the basis of breaking pre-cooked
"binary" modules but this is a complete non-issue for gentoo. Would you not
re-consider this matter in view of its clear usefulness and proven stability?
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2005-05-30 15:37:18 UTC
No, because we generally just don't accept feature patches. If it is so
useful/correct/good, you should have no problem getting it into the mainline
kernel, right? :)
Comment 12 Ivan Yosifov 2005-06-02 08:30:03 UTC
There is an open bug about this in kernel bugzilla.

http://bugme.osdl.org/show_bug.cgi?id=4232

So far nobody has responded though :(
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2005-06-02 10:13:34 UTC
You could try starting a discussion on the linux kernel mailing list.