Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 82658 - Bash completion fails to correctly address ebuilds in ${PORTDIR_OVERLAY}
Summary: Bash completion fails to correctly address ebuilds in ${PORTDIR_OVERLAY}
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2005-02-20 02:50 UTC by Tom Fredrik Blenning Klaussen
Modified: 2005-07-22 11:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Fredrik Blenning Klaussen 2005-02-20 02:50:16 UTC
Bash completion fails to correctly address ebuilds in ${PORTDIR_OVERLAY}.

In addition, I would add esearch to the gentoo-completion, it could easily be added without modifications as the _emerge function. 

Reproducible: Always
Steps to Reproduce:
Comment 1 Aaron Walker (RETIRED) gentoo-dev 2005-03-09 16:52:16 UTC
I'll see about adding portdir support.

As far as esearch goes, _emerge would make no sense...  emerge has tons of more options.  Also, it doesn't make any sense to do package name completion with esearch since it's a search string/regex.

I wouldn't mind writing one that simply does esearch's command-line options, but that's something that should be included with esearch itself not in gentoo-bashcomp.
Comment 2 Tom Fredrik Blenning Klaussen 2005-03-09 23:43:36 UTC
Well, it might be overkill and technically incorrect to use _emerge, I just did a quick hack, and it seemed to work for me.

As far as esearch goes, at least for me, the primary use is to bring up packet information _quick_.
Comment 3 Aaron Walker (RETIRED) gentoo-dev 2005-03-14 03:06:53 UTC
PORTDIR_OVERLAY support added.  Will be available next release.

I'm thinking about breaking gentoo-bashcomp out into its own ebuild, since I release a lot more often that the previous maintainer(s).  If so, I'll probably wait until then to close this bug.
Comment 4 Tom Fredrik Blenning Klaussen 2005-03-14 03:57:50 UTC
What comes into mind is to do that, and make gentoo-bash-completion a run-time dependency with a use flag for bash-completion. That way people will get both from only installing bash-completion, but the release cycle could be considerably higher on the gentoo-part.

As a counter-argument, the total size of the package is minimal, so theres no real strain connected to a rapid update cycle.

Well anyway, just random ranting.
Comment 5 Aaron Walker (RETIRED) gentoo-dev 2005-03-16 04:46:02 UTC
app-shells/gentoo-bashcomp-20050316 is in the tree.
Comment 6 Tom Fredrik Blenning Klaussen 2005-07-22 11:44:05 UTC
Me happy :)