Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 821898 - dev-lang/rust-1.56.1 & co: stabilize
Summary: dev-lang/rust-1.56.1 & co: stabilize
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Rust Project
Depends on: 821862 822138
Blocks: 821157 823209 823221
  Show dependency tree
Reported: 2021-11-05 09:31 UTC by Georgy Yakovlev
Modified: 2021-12-25 17:10 UTC (History)
4 users (show)

See Also:
Package list:
dev-lang/rust-bin-1.56.1 dev-lang/rust-1.56.1 virtual/rust-1.56.1
Runtime testing required: ---
nattka: sanity-check+


Note You need to log in before you can comment on or make changes to this bug.
Description Georgy Yakovlev archtester gentoo-dev 2021-11-05 09:31:56 UTC
it's time.
Comment 1 Georgy Yakovlev archtester gentoo-dev 2021-11-05 09:34:12 UTC
let's wait for llvm-13 to get stable at least on amd64 before proceeding.
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-05 20:08:36 UTC
For observers: this is on hold due to possible Firefox bugs with new LLVM or Rust(?), possibly related to bug 821505.
Comment 3 Piotr Karbowski (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2021-11-06 13:38:11 UTC
I can confirm something is off if firefox is built with this very version.
Comment 4 Sven Hesse 2021-11-06 20:02:57 UTC
I can also confirm that something is really off with Firefox with 1.56.1.

It's a bit of a weird tale, but I ran a world update on the night from Thursday to Friday, before a roleplaying session (which we do via Foundry VTT) on Friday evening. This included rust 1.56.1 and firefox 94.0.1.

Turns out, something really broke and Foundry VTT in Firefox kept weirdly deadlocking. With animations still happening, but mouse input ignored, and also closing the tab and Firefox itself either delayed or not working.

At first I thought it was Firefox 94.0.1, so I downgraded to 93.0, which previously worked. But nope, still happening.

Then I noticed it only happens when pulseaudio is running. So it might be something sound, sound IPC, whatever related?

Another thing that breaks is the Firefox profiler ( After ending a recording, a new tabs opens where the profile would be loaded, but that never finishes loading and the tab stays empty.

Basically took the whole day today to try various things. But downgrading to rust 1.53.0 and recompiling Firefox fixes the issues for me. I also downgraded llvm and clang to 12 (and rebuilt Firefox), but that alone was not enough.

As for the connection with #821505... Dunno, I still get the "Channel closing: too late to send/recv, messages will be lost" messages with Firefox 93, rust 1.53.0 and clang/llvm 12. And I have Firefox compiled with -pgo at any rate.
Comment 5 Sven Hesse 2021-11-07 09:35:33 UTC
Okay, Rust 1.56.0-r1 also show this broken behaviour, not just 1.56.1.

I've now got llvm and clang back to 13, Rust to 1.55.0 and Firefox to 94.0.1, and the bug is gone. So >=dev-lang/rust-1.56.0 is the issue.
Comment 6 NATTkA bot gentoo-dev 2021-11-08 10:36:27 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2021-11-08 10:44:28 UTC Comment hidden (obsolete)
Comment 8 Mike Limansky 2021-11-09 15:39:32 UTC
Can we have rust 1.55 stabilized now, since LLVM 13 is already stable and 1.56.x is blocked by firefox issue?
Comment 9 Mike Limansky 2021-11-09 15:54:54 UTC
Oh, I see, rust-1.55 is still using llvm 12.
Comment 10 Georgy Yakovlev archtester gentoo-dev 2021-11-09 21:30:45 UTC
fix landed to firefox in

so try ff 94.0.1-r1

if problems are solved we can continue with stablereq, but still waiting ofc for more data to come in from users.
Comment 11 Sven Hesse 2021-11-09 23:08:51 UTC
I can confirm that the issue I had in Foundry VTT ( ) are gone with dev-lang/rust-1.56.1 and www-client/firefox-94.0.1-r1.

However, the Firefox Profiler is still broken. That seems to be a separate issue. That bug is also present when pulseaudio is not running, so I already suspected that the cubeb-pulse-rs fix is not going to change that.

Steps to reproduce:

1. Create a new profile, just to be sure
2. Start Firefox with the new profile and go to 
3. Click "Enable Firefox Profiler Menu Button". This will create a new button in the space to the right of the navigation bar
4. Click the new button. This will start a new recording
5. Click the button again. This will stop the recording
6. Wait a few seconds. A new tab will open, navigating to

What should happen now: the recording data is loaded into the new tabs and a detailed view is shown displaying the data associated with the recording.

What does happen instead: the new tab stays blank forever. When closing the tab and opening a new tab, you can't even navigate to any URL now

This happens with Firefox is compiled with dev-lang/rust-1.59.1, but not with dev-lang/rust-1.55.

It's very possible that this is a very similar Thread sync deadlock to the one found in cubeb-pulse-rs, but related to the loading of the recording data.
Comment 12 Georgy Yakovlev archtester gentoo-dev 2021-11-09 23:56:29 UTC
it's FF code issue, not exactly rust's, rust-1.56 is just a trigger as I understand, not the failure reason.

I'd say worth filing a separate bug for firefox if it's not filed yet.
Comment 13 NATTkA bot gentoo-dev 2021-11-10 17:40:26 UTC Comment hidden (obsolete)
Comment 14 NATTkA bot gentoo-dev 2021-11-10 19:08:29 UTC Comment hidden (obsolete)
Comment 15 Georgy Yakovlev archtester gentoo-dev 2021-11-11 08:16:00 UTC
got ack from mozilla team to go on with stablereq, adding arches
Comment 16 Georgy Yakovlev archtester gentoo-dev 2021-11-11 18:19:12 UTC
ppc64 done
Comment 17 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-12 20:53:02 UTC
amd64 done
Comment 18 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-12 22:54:44 UTC
x86 done
Comment 19 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-13 02:58:20 UTC
arm64 done
Comment 20 Arthur Zamarin archtester Gentoo Infrastructure gentoo-dev 2021-12-25 17:10:53 UTC
arm done

all arches done