Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 821103 - kde-frameworks/kio-5.85.0: 20 sec freeze when changing folders in kde-apps/dolphin and kde-apps/kate
Summary: kde-frameworks/kio-5.85.0: 20 sec freeze when changing folders in kde-apps/do...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://invent.kde.org/frameworks/kio...
Whiteboard:
Keywords: CC-ARCHES, UPSTREAM
Depends on: frameworks-5.88-stable
Blocks:
  Show dependency tree
 
Reported: 2021-10-31 17:44 UTC by Norman Back
Modified: 2021-12-14 09:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
nattka: sanity-check-


Attachments
revert to parsing disc manually patch (revert-to-parsing-disc-manually.patch,3.46 KB, patch)
2021-11-02 19:23 UTC, Norman Back
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Back 2021-10-31 17:44:16 UTC
In summary:
kde-frameworks-5.82.0 allows changing folders within dolphin and kate, without any freeze.
Using kde-frameworks-5.85.0 and kde-frameworks-5.87.0 results in a 20 sec freeze when changing folders 
within dolphin and kate.

I upgrade kde to the lastest stable release on 13th Sept 2021. Everthing seemed to work OK at first but
I later found that when I use dolphin or kate the application freezes for 20 secs when changing to a diffent folder.
I downgraded the whole of kde to the release in use prior to the 13th Sept 2021 and the issue disappeared, confirming that 
the problem was in the lastest stable release of kde.
After some thought I upgraded all but kde-frameworks to the lastest stable release of kde leaving 
kde-frameworks at 5.82.0. There was no 20 sec freeze.
Wondering if the unstable kde-frameworks 5.87.0 might also be OK I upgraded to that but the freeze returned.

I also noted that when starting dolphin from the command line with kde-frameworks-5.85.0 a large number of errors were
reported on the console. However kde-frameworks-5.87.0 did not maifest this so is not relavent to this issue.


Reproducible: Always

Steps to Reproduce:
1. Install kde-frameworks to 5.85.0 or 5.8.7.0
2. Start dolphin

Actual Results:  
1. switch selection between two folder containing a large number of files/folders
2. observe the freeze ( 20 secs on my box ) before dolphin is responsive again.

Expected Results:  
1. switch selection between two folder containing a large number of files/folders
2. no freeze occurs.

emerge --info
Portage 3.0.28 (python 3.9.7-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-11.2.0, glibc-2.33-r1, 5.14.15-gentoo x86_64)
=================================================================
System uname: Linux-5.14.15-gentoo-x86_64-AMD_Ryzen_9_3900X_12-Core_Processor-with-glibc2.33
KiB Mem:    65799592 total,  61537776 free
KiB Swap:   58720236 total,  58720236 free
Timestamp of repository gentoo: Sat, 30 Oct 2021 01:45:01 +0000
Head commit of repository gentoo: 3920f5a53eb30b35019f8a857e13aeed1e13fcd3
sh bash 5.1_p8
ld GNU ld (Gentoo 2.37_p1 p0) 2.37
distcc 3.4 x86_64-pc-linux-gnu [disabled]
ccache version 4.4.2 [disabled]
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0-r3::gentoo
dev-lang/python:          2.7.18_p13::gentoo, 3.8.12_p1::gentoo, 3.9.7_p1::gentoo
dev-lang/rust:            1.53.0::gentoo
dev-util/ccache:          4.4.2::gentoo
dev-util/cmake:           3.20.5::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.43.5-r1::gentoo
sys-apps/sandbox:         2.25::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.4::gentoo
sys-devel/binutils:       2.37_p1::gentoo
sys-devel/gcc:            11.2.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://datastoreone/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

eclipse
    location: /var/lib/layman/eclipse
    masters: gentoo
    priority: 50

Installed sets: @kernels
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/vmware-installer"
CXXFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe"
DISTDIR="/mnt/portage.autofs/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y -j52 --load-average=52 --quiet-build=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://www.mirrorservice.org/sites/distfiles.gentoo.org/ http://mirror.bytemark.co.uk/gentoo/ http://mirrors.gethosted.online/gentoo http://mirrors.soeasyto.com/distfiles.gentoo.org/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/ http://ftp.free.fr/mirrors/ftp.gentoo.org/ https://mirrors.ircam.fr/pub/gentoo-distfiles/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j52 --load-average=52"
PKGDIR="/mnt/portage.autofs/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git --exclude=lost+found/"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac accessibility acl acpi activities aes alsa amarok amd64 amr authdaemond avx avx2 bash-completion bluetooth bluray branding bzip2 cairo caps cdda cdr cli crypt cups dbus declarative dri dts dv dvd dvdr dvdread elogind emboss encode exif f16c fam flac fma3 fortran gdbm gif gpm gtk gui iconv icu ieee1394 ipv6 jpeg jumbo-build kde kipi kwallet lcms libglvnd libnotify libtirpc lm-sensors lm_sensors lock mad mmx mmxext mng mp3 mp4 mpeg multilib mysql ncurses network nls nptl ofx ogg opencl opengl openmp oss pam pango pclmul pcre pdf plasma png policykit popcnt ppds pulseaudio qml qt3 qt5 rdrand readline samba sasl sdl seccomp session sha spell split-usr sse sse2 sse3 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification svg tcpd thunar tiff truetype udev udisks uk_bleb uk_rt unicode upower usb v4l v4l2 vdpau vorbis widgets wxwidgets x264 xattr xcb xinerama xml xv xvid xvmc zlib" ABI_X86="64" ADA_TARGET="gnat_2019" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgi cgid slotmem_shm unixd access_compat authz_core socache_shmcb authn_core" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64 pc multiboot mount" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby26 ruby27" SANE_BACKENDS="hp5590 hp net abaton agfafocus apple artec artec_eplus48u as6e avision bh canon canon630u canon_dr canon_pp cardscan coolscan coolscan2 coolscan3 dc210 dc240 dc25 dell1600n_net dmc epjitsu epson epson2 fujitsu genesys gt68xx hp3500 hp3900 hp4200 hp5400 hpljm1005 hpsj5s hs2p ibm kodak kvs1025 kvs20xx leo lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_pp mustek_usb nec niash p5 pie pixma plustek plustek_pp pnm qcam ricoh rts8891 s9036 sceptre sharp sm3600 sm3840 snapscan sp15c st400 stv680 tamarack teco1 teco2 teco3 test u12 umax umax1220u umax_pp xerox_mfp" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 1 Norman Back 2021-10-31 18:19:36 UTC
During the 20 second freeze, high IO ( > 50% ) can be observed on many hard drives via atop.
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-01 13:51:36 UTC
Please report this issue upstream if you can.
Comment 3 Norman Back 2021-11-01 17:08:22 UTC
(In reply to Sam James from comment #2)
> Please report this issue upstream if you can.

Reported upstream https://bugs.kde.org/show_bug.cgi?id=444786
Comment 4 Norman Back 2021-11-02 19:21:35 UTC
I have applied the patch at https://invent.kde.org/frameworks/kio/-/commit/221a94a66c4d2f6e4f2dc938ee8a63a6ca739477 to kde-frameworks 5.85 and 5.87 and can report that it resolves the issue.
Comment 5 Norman Back 2021-11-02 19:23:31 UTC
Created attachment 748092 [details, diff]
revert to parsing disc manually patch
Comment 6 Larry the Git Cow gentoo-dev 2021-11-03 10:56:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/kde.git/commit/?id=1466f3198297e68289b17f09979fcff974d347f7

commit 1466f3198297e68289b17f09979fcff974d347f7
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-11-03 10:56:31 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-11-03 10:56:31 +0000

    kde-frameworks/kio: Drop unused dependency
    
    Upstream commit 221a94a66c4d2f6e4f2dc938ee8a63a6ca739477
    
    KDE-bug: https://bugs.kde.org/show_bug.cgi?id=442106
    Bug: https://bugs.gentoo.org/821103
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-frameworks/kio/kio-9999.ebuild | 1 -
 1 file changed, 1 deletion(-)
Comment 7 Larry the Git Cow gentoo-dev 2021-11-05 16:24:16 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ec28b59c42e6c7a7de5c17c4ac2cfe9763192524

commit ec28b59c42e6c7a7de5c17c4ac2cfe9763192524
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-11-05 16:22:55 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-11-05 16:24:00 +0000

    kde-frameworks/kio: KMountPoint: Revert to pre-libblkid parsing
    
    Upstream commit 221a94a66c4d2f6e4f2dc938ee8a63a6ca739477
    
    KDE-bug: https://bugs.kde.org/show_bug.cgi?id=442106
    Thanks-to: Norman Back <gentoo2@thebacks.co.uk>
    Bug: https://bugs.gentoo.org/821103
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 ...kio-5.85.0-revert-to-pre-libblkid-parsing.patch | 128 +++++++++++++++++++++
 kde-frameworks/kio/kio-5.85.0-r2.ebuild            | 100 ++++++++++++++++
 kde-frameworks/kio/kio-5.87.0-r1.ebuild            |  98 ++++++++++++++++
 3 files changed, 326 insertions(+)
Comment 8 Andreas Sturmlechner gentoo-dev 2021-11-05 16:25:29 UTC
Thanks for reporting; please confirm kde-frameworks/kio-5.85.0-r2 works for you.
Comment 9 Norman Back 2021-11-08 15:33:29 UTC
(In reply to Andreas Sturmlechner from comment #8)
> Thanks for reporting; please confirm kde-frameworks/kio-5.85.0-r2 works for
> you.

I confirm that kde-frameworks/kio-5.85.0-r2 works for me.
Comment 10 Jakov Smolić gentoo-dev 2021-11-18 14:01:05 UTC
amd64 done
Comment 11 Agostino Sarubbo gentoo-dev 2021-11-22 07:51:12 UTC
x86 stable
Comment 12 Mike Lothian 2021-12-06 18:16:11 UTC
So I have a horrible feeling this fix, broke things for me

I'm now seeing slow downs in Dolphin and file pickers
Comment 13 Andreas Sturmlechner gentoo-dev 2021-12-06 20:22:09 UTC
(In reply to Mike Lothian from comment #12)
> So I have a horrible feeling this fix, broke things for me
Unlikely.
Comment 14 NATTkA bot gentoo-dev 2021-12-14 09:32:35 UTC
Unable to check for sanity:

> no match for package: kde-frameworks/kio-5.85.0-r2
Comment 15 Andreas Sturmlechner gentoo-dev 2021-12-14 09:39:45 UTC
arm64 failed to stabilise before package version was cleaned up.