Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 820836 - net-libs/libtorrent-rasterbar-2.0.4-r3: deps/asio-gnutls/include/boost/asio/gnutls/stream.hpp:248:52: error: reference to '_1' is ambiguous
Summary: net-libs/libtorrent-rasterbar-2.0.4-r3: deps/asio-gnutls/include/boost/asio/g...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: boost-1.76
  Show dependency tree
 
Reported: 2021-10-30 10:03 UTC by nicotroost
Modified: 2021-10-31 11:59 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (file_820836.txt,278.92 KB, text/plain)
2021-10-30 10:03 UTC, nicotroost
Details
build.log net-libs/libtorrent-rasterbar-2.0.4-r5 (file_820836.txt,242.88 KB, text/plain)
2021-10-31 09:03 UTC, nicotroost
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nicotroost 2021-10-30 10:03:38 UTC
Created attachment 747489 [details]
build.log

ninja: build stopped: subcommand failed.
 * ERROR: net-libs/libtorrent-rasterbar-2.0.4-r3::gentoo failed (compile phase):
 *   ninja -v -j4 -l0 failed
 * 
 * Call stack:
 *     ebuild.sh, line  127:  Called src_compile
 *   environment, line 3035:  Called cmake_src_compile
 *   environment, line 1227:  Called cmake_build
 *   environment, line 1196:  Called eninja
 *   environment, line 1703:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 * 

# emerge --info '=net-libs/libtorrent-rasterbar-2.0.4-r3::gentoo'
Portage 3.0.28 (python 3.9.7-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-11.2.0, glibc-2.33-r1, 4.14.245-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.245-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-glibc2.33
KiB Mem:     8161188 total,   2276260 free
KiB Swap:   10239996 total,  10222844 free
Timestamp of repository gentoo: Sat, 30 Oct 2021 08:45:01 +0000
Head commit of repository gentoo: 96e02bb987e516beab964a8e78fcf80501ef4369
sh bash 5.1_p8
ld GNU ld (Gentoo 2.37_p1 p0) 2.37
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0-r3::gentoo
dev-lang/python:          3.9.7_p1::gentoo
dev-lang/rust:            1.53.0::gentoo
dev-util/cmake:           3.20.5::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.43.5-r1::gentoo
sys-apps/sandbox:         2.25::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:       1.16.4::gentoo
sys-devel/binutils:       2.37_p1::gentoo
sys-devel/gcc:            11.2.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r1::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 

crossdev
    location: /usr/local/portage-crossdev
    masters: gentoo
    priority: 10

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=core2 -O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="nl"
MAKEOPTS="-j4"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acpi alsa amd64 avr branding bzip2 cairo cdda cddb cdr cli crypt cups dbus declarative designer dri dts dvd dvdr elogind emboss encode epub exif ffmpeg flac fortran gdbm gif gnutls gpm gtk gui iconv icu imlib ipv6 java javascript jpeg kde kdesu kipi kwallet lame lcms libglvnd libnotify libtirpc lirc lm-sensors mad markdown matroska mng mp3 mp4 mpeg mtp multilib musepack ncurses networkmanager nptl nsplugin office ogg opengl openmp opus oss pam pango pcre pdf plasma png policykit ppds python qml qt5 quicktime rar readline seccomp semantic-desktop spell split-usr sqlite ssl startup-notification svg tcpd theora thumbnails tiff tk truetype udev udisks unicode upower usb v4l vdpau vorbis vpx widgets wxwidgets x264 xattr xcb xine xml xscreensaver xv xvid xvmc zip zlib" ABI_X86="64" ADA_TARGET="gnat_2019" ALSA_CARDS="hda_intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev libinput mouse keyboard" KERNEL="linux" L10N="nl" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26 ruby27" USERLAND="GNU" VIDEO_CARDS="nouveau vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS


# emerge -pqv '=net-libs/libtorrent-rasterbar-2.0.4-r3::gentoo'
[ebuild  r  U ] net-libs/libtorrent-rasterbar-2.0.4-r3 [1.2.14] USE="dht gnutls%* python ssl -debug -test (-doc%) (-examples%) (-static-libs%)" PYTHON_SINGLE_TARGET="python3_9%* -python3_8%" PYTHON_TARGETS="(-python3_8%) (-python3_9%*)" 
[ebuild  rR   ] net-p2p/qbittorrent-4.3.8  USE="X dbus -debug -webui" 

The following packages are causing rebuilds:

  (net-libs/libtorrent-rasterbar-2.0.4-r3:0/2.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-p2p/qbittorrent-4.3.8:0/0::gentoo, ebuild scheduled for merge)
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-10-31 04:21:38 UTC
Interesting that it worked for me and this is the first report...

... but anyway, it bundles asio-gnutls and there's a fix upstream (but not yet in libtorrent-rasterbar) for this: https://github.com/paullouisageneau/boost-asio-gnutls/commit/895105972e5a9318d572b147c1872f64d23e2a8e.
Comment 2 Larry the Git Cow gentoo-dev 2021-10-31 04:22:30 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=116d6431c3830f6332bc67e1ec591fcbe6542bdc

commit 116d6431c3830f6332bc67e1ec591fcbe6542bdc
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-31 04:22:03 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-31 04:22:03 +0000

    net-libs/libtorrent-rasterbar: add Boost 1.76(?) patch
    
    Closes: https://bugs.gentoo.org/820836
    Signed-off-by: Sam James <sam@gentoo.org>

 .../libtorrent-rasterbar-2.0.4-boost-1.76.patch    | 58 ++++++++++++++++++++++
 .../libtorrent-rasterbar-2.0.4-r3.ebuild           |  1 +
 2 files changed, 59 insertions(+)
Comment 3 Larry the Git Cow gentoo-dev 2021-10-31 04:28:02 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f6a5c546311ea26c022e860ef18ebda12ccdc66f

commit f6a5c546311ea26c022e860ef18ebda12ccdc66f
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-31 04:27:51 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-31 04:27:51 +0000

    net-libs/libtorrent-rasterbar: add link to upstream patch
    
    Bug: https://bugs.gentoo.org/820836
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/libtorrent-rasterbar-2.0.4-boost-1.76.patch                    | 1 +
 1 file changed, 1 insertion(+)
Comment 4 nicotroost 2021-10-31 09:03:12 UTC
Created attachment 747651 [details]
build.log net-libs/libtorrent-rasterbar-2.0.4-r5

Still doesn't compile, but a different error.
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-10-31 09:18:15 UTC
(In reply to nicotroost from comment #4)
> Created attachment 747651 [details]
> build.log net-libs/libtorrent-rasterbar-2.0.4-r5
> 
> Still doesn't compile, but a different error.

In future, please file a new bug if you can to reduce the risk of missing something (and because it's a separate issue).

But I've reproduced this with your USE flags, so hang on...
Comment 6 Larry the Git Cow gentoo-dev 2021-10-31 09:20:16 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=aaad7203e82a69cfde21d34a43da180daddf989a

commit aaad7203e82a69cfde21d34a43da180daddf989a
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-31 09:19:55 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-31 09:19:55 +0000

    net-libs/libtorrent-rasterbar: fix build with python + gnutls
    
    Closes: https://bugs.gentoo.org/820836
    Signed-off-by: Sam James <sam@gentoo.org>

 ...libtorrent-rasterbar-2.0.4-asio-ssl-error.patch | 29 ++++++++++++++++++++++
 .../libtorrent-rasterbar-2.0.4-r5.ebuild           |  1 +
 2 files changed, 30 insertions(+)
Comment 7 nicotroost 2021-10-31 11:59:04 UTC
net-libs/libtorrent-rasterbar-2.0.4-r4 compiled.
Thanks for the quick fix.