Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 81893 - net-im/amsn ebuild is b0rked, new ebuild and version bump
Summary: net-im/amsn ebuild is b0rked, new ebuild and version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
: 125416 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-13 11:49 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-12-16 22:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Cleaned up ebuild (amsn-0.94.ebuild,1.80 KB, text/plain)
2005-02-13 11:51 UTC, Diego Elio Pettenò (RETIRED)
Details
Ebuild with domenu (amsn-0.94.ebuild,1.77 KB, text/plain)
2005-02-13 13:35 UTC, Diego Elio Pettenò (RETIRED)
Details
This time with inheritance.. (amsn-0.94.ebuild,1.79 KB, text/plain)
2005-02-13 13:48 UTC, Diego Elio Pettenò (RETIRED)
Details
amsn-0.95-r3.ebuild (amsn-0.95-r3.ebuild,1.43 KB, text/plain)
2006-06-29 09:11 UTC, Samuli Suominen
Details
amsn-095-r4.ebuild (amsn-0.95-r4.ebuild,2.03 KB, text/plain)
2006-06-29 12:19 UTC, Víctor Enríquez
Details
amsn-0.95-r3.ebuild (amsn-0.95-r3.ebuild,1.38 KB, text/plain)
2006-06-29 15:39 UTC, Samuli Suominen
Details
a cleaned ebuild for amsn0.96RC1 (IUSE="" added) (amsn-0.96_rc1.ebuild,1.45 KB, text/plain)
2006-07-06 14:00 UTC, Boris Faure
Details
a cleaned ebuild for amsn0.96RC1 (amsn-0.96_rc1.ebuild,1.45 KB, text/plain)
2006-07-08 10:16 UTC, Boris Faure
Details
amsn-0.98.4.ebuild (amsn-0.98.4.ebuild,1.85 KB, text/plain)
2010-12-16 22:25 UTC, (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2005-02-13 11:49:54 UTC
The attached ebuild is a little rework of the amsn ebuild, which doesn't make use of cp and rm to install it, but uses doins and dosym.

It also installs the icon in the right way into the hicolor structure, and fixes the .desktop file to use it in the right way (changing the icon from msn.png to amsn).

I hope it works, because I can't install and so test it. I know this isn't the right way to work, but I hope some user, if not developers, could take a look at it and tell me if it works (I haven't so much time, and I haven't tcl/tk installed).

HTH, Diego
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-02-13 11:51:06 UTC
Created attachment 51141 [details]
Cleaned up ebuild
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-02-13 13:35:46 UTC
Created attachment 51154 [details]
Ebuild with domenu
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-02-13 13:48:11 UTC
Created attachment 51156 [details]
This time with inheritance.. 

bad thing being unable to test the ebuilds.
Comment 4 Don Seiler (RETIRED) gentoo-dev 2005-04-25 10:43:07 UTC
Why can't you test the ebuilds?
Comment 5 Olivier Crete (RETIRED) gentoo-dev 2005-04-25 12:13:32 UTC
One big problem... your changes to the .desktop don't work... gnome-panel doesnt find the icon... 
Comment 6 Víctor Enríquez 2006-06-27 10:26:09 UTC
Please take a look at bug 134375 maybe it can help you
Comment 7 Samuli Suominen gentoo-dev 2006-06-29 09:07:17 UTC
Current amsn-0.95-r2.ebuild breaks freedesktop.org standards,

http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html
http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html

This way, it doesn't need USE="gnome" or USE="kde" at all. In fact, it could "inherit fdo-mime" and do "fdo-mime_desktop_database_update" and "do-mime_mime_database_update" in pkg_postinst().

This way, it won't break other desktops following f.d.o standards.
Comment 8 Samuli Suominen gentoo-dev 2006-06-29 09:11:29 UTC
Created attachment 90441 [details]
amsn-0.95-r3.ebuild

Started cleaning out -r2 and got to this. I'm sure it needs more work, -r2 is a mess.
Comment 9 Víctor Enríquez 2006-06-29 12:19:22 UTC
Created attachment 90457 [details]
amsn-095-r4.ebuild

i have been working on my amsn-svn ebuild to install amsn-0.95, i think xmms is deprecated so the xmms use must be removed and all the others use flags too. I think we must let amsn do it's own make install process and then copy the results to is respective path, so you don't have to rm all MacOSx and Windows files. I have used your changes too to update icon database and I parse with sed de amsn.desktop to use /use/share/amsn/icons/48x48/msn.png so no need to copy the icons to /usr/share/pixmaps or /use/share/icons/hicolor.
Comment 10 Samuli Suominen gentoo-dev 2006-06-29 15:38:00 UTC
current amsn in portage:

- breaks f.d.o stuff
- installs duplicate documentation, unpacked and packed
- tries to use libng, which is never installed
- installs debian/ directory to build debs
- installs windows utilities
- installa macosx utilities
- ebuild uses ln instead of dosym
- ebuild uses chmod instead of fperms
- ebuild uses Microsoft Windows(TM) icon by default, and only in size 32
- ebuild tries to remove files, which aren't even there
- doesn't dosym amsn-remote and amsn-remote-CLI
- installs GNUGPL, an unwanted license file
Comment 11 Samuli Suominen gentoo-dev 2006-06-29 15:39:37 UTC
Created attachment 90483 [details]
amsn-0.95-r3.ebuild

fixes everything mentioned in my last comment.

I also obsoleted these other attachments as they have most, if not all of the flaws mentioned before. I got some good ideas from ebuild by flameeyes though, thanks.
Comment 12 Víctor Enríquez 2006-06-29 15:59:09 UTC
I'm still thinking that is better to use the make install from amsn, than doing all of this: 
rm -rf GNUGPL AGREEMENT TODO README FAQ CREDITS HELP amsn.desktop icons \
utils/windows utils/macosx docs lang/LANG-HOWTO debian
The reason is future compatibility, if you change the version of my ebuild you can make a version bump without changing anything.

If you use the make install from amsn you dont have to do that rm -rf please see me -r4 ebuild. Also if you use the make install the icons are installed in /usr/share/amsn/icons so no need to copy all the icons, you can sed de amsn.desktop to use a icon from /usr/share/amsn/icons like i do in my ebuild but i think this is only a cosmetical change.

Also i think xmms use must be removed but i'm not sure cause i never use that feature (really is it included in the latest version? i can't see it).
Comment 13 Olivier Crete (RETIRED) gentoo-dev 2006-06-29 16:14:38 UTC
The last I tried to use the make install from aMSN, it was completely b0rked so that's why I ended up doing the ugly copy+delete.  I believe the xmms infopipe plugin is still there. I'll try to have a look at the ebuilds on this bug and improve the one in the tree at some point.. But the aMSN ebuild is very tricky to get right since the amsn configure/install stuff sucks so much.
Comment 14 Víctor Enríquez 2006-06-29 16:43:01 UTC
If you use it without configurin it properly you can't use make install from amsn because sandbox but if you configure it like this you can use it:

src_compile() {
      
    cd "${WORKDIR}"/msn
    mv * ../
	cd ../
    dodir ${WORKDIR}/fakeroot
	dodir ${WORKDIR}/fakeroot/usr/bin -p
	dodir ${WORKDIR}/fakeroot/usr/share -p
	econf --prefix=${WORKDIR}/fakeroot/usr/ --bindir=${WORKDIR}/fakeroot/usr/bin \
	--datadir=${WORKDIR}/fakeroot/usr/share || die
	make || die
	
	ewarn "Installing Amsn on a fake directory"
	make install || die
	
}

As you can see we configure all the paths that can cause that sandbox warning using a "fakeroot", then we compile it and then we install it (make install) in the "fakeroot", then you have amsn like if you install it ,without portage, in the fakeroot and you don't have to delette anything because all the plugins are well configured, so you only have to copy the contents to their respective paths and all is done, but well im not a developer only do what you think is more correct. You can solve the icon problem also like in my ebuild, but that is only cosmetical, the important part is using fdo-mime like in the -r3 ebuild.
I will continue using my ebuild because i'm using svn builds and my configures it well without rm -rf so if they change a directory or anything you don't have to reedit the ebuild.
Sorry my english I'm spanish.
Comment 15 Samuli Suominen gentoo-dev 2006-06-29 17:06:00 UTC
(In reply to comment #12)
> I'm still thinking that is better to use the make install from amsn, than doing
> all of this: 
> rm -rf GNUGPL AGREEMENT TODO README FAQ CREDITS HELP amsn.desktop icons \
> utils/windows utils/macosx docs lang/LANG-HOWTO debian
> The reason is future compatibility, if you change the version of my ebuild you
> can make a version bump without changing anything.

I'm believe you are right, because cleaning up utils -directory is an impossible mission. And yes, it make version bumps easier. 

Anyhow, the ebuild in portage now should be hardmasked immediately, it's totally false.

I was wrong about --enable-libng, it actually is being used but found out another funny thing when adding $(use_enable debug), when --enable-debug is given it disables debug, and other way around.

I'm going to look into this more tomorrow. Night.
Comment 16 Boris Faure 2006-07-06 14:00:01 UTC
Created attachment 91075 [details]
a cleaned ebuild for amsn0.96RC1 (IUSE="" added)

this ebuild use the upcoming amsn 0.96 RC1 version. (you should consider this version as stable)
It uses the bz2 package because the tar.gz seems corrupted on SF mirrors. That's why amsn0.96 will not released so soon (wait roughly a week).

Then, don't make this version stable in portage because all the mirrors are not yet synced. I'll use this ebuild on amsn's website, so if it needs some modifications, please, tell me ! (and if you have questions or willing about amsn, you can ask me (about our 'make install' for example :D ).
Greets
Comment 17 Samuli Suominen gentoo-dev 2006-07-06 14:16:32 UTC
(In reply to comment #16)
> Created an attachment (id=91075) [edit]
> a cleaned ebuild for amsn0.96RC1

You forgot IUSE="" from your ebuild.
Comment 18 Boris Faure 2006-07-07 08:56:08 UTC
Comment on attachment 91075 [details]
a cleaned ebuild for amsn0.96RC1 (IUSE="" added)

# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils fdo-mime

MY_P=${P/_rc/RC}
S="${WORKDIR}/${MY_P}"

DESCRIPTION="Alvaro's Messenger client for MSN"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
HOMEPAGE="http://amsn.sourceforge.net"

RESTRICT="test"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

DEPEND=">=dev-lang/tcl-8.4
	>=dev-lang/tk-8.4
	>=dev-tcltk/tls-1.4.1
	"
RDEPEND="${DEPEND}"

src_install() {
	dodir /usr/share/amsn/

	sed -i -e 's:Icon=msn.png:Icon=amsn:' "${S}"/amsn.desktop
	domenu amsn.desktop

	for res in 32 48 64 96 128; do
		insinto /usr/share/icons/hicolor/${res}x${res}/apps
		newins ${S}/icons/${res}x${res}/aMSN_${res}.png	amsn.png
	done
	
	dodoc AGREEMENT TODO README FAQ CREDITS docs/*

	rm -rf GNUGPL AGREEMENT TODO README FAQ CREDITS HELP amsn.desktop icons \
		utils/windows utils/macosx docs lang/LANG-HOWTO debian
	
	insinto /usr/share/amsn/ 
	insopts -m644
	doins -r "${S}"/*

	dosym ../share/amsn/amsn /usr/bin/amsn
	dosym ../share/amsn/amsn-remote /usr/bin/amsn-remote
	dosym ../share/amsn/amsn-remote-CLI /usr/bin/amsn-remote-CLI
	chmod +x "${D}"/usr/share/amsn/amsn
	chmod +x "${D}"/usr/share/amsn/amsn-remote
	chmod +x "${D}"/usr/share/amsn/amsn-remote-CLI

}

pkg_postinst() {
	fdo-mime_desktop_database_update
	fdo-mime_mime_database_update
	ewarn "You might have to remove ~/.amsn prior to running as user if amsn hangs on start-up."
}
Comment 19 Boris Faure 2006-07-08 10:16:02 UTC
Created attachment 91216 [details]
a cleaned ebuild for amsn0.96RC1

This time IUSE="" is really added.
If you want, you can put amsn0.96RC1 in portage. (Fedora has already it, and the news on the website is only postponed because the tar.gz is corrupted, and SF mirrors are not all synced)
Don't wait for amsn0.96, there may be none.
Comment 20 Olivier Crete (RETIRED) gentoo-dev 2006-07-09 14:33:11 UTC
*** Bug 125416 has been marked as a duplicate of this bug. ***
Comment 21 Olivier Crete (RETIRED) gentoo-dev 2006-07-09 14:54:32 UTC
Sorry for taking so much time to fix this.
I've added 0.95-r3 to the tree with all the fixes
as well as 0.96_rc1 (which is the same ebuild anyways).
Comment 22 Samuli Suominen gentoo-dev 2006-07-10 04:54:33 UTC
(In reply to comment #21)
> Sorry for taking so much time to fix this.

Not a problem, I'm glad that is it sorted out now. Thanks.
Comment 23 (RETIRED) 2010-12-16 22:25:17 UTC
Created attachment 257381 [details]
amsn-0.98.4.ebuild

amsn-0.98.4.ebuild