Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 813837 - dev-util/lttng-ust-2.11.0 - Cannot find liburcu-bp lib
Summary: dev-util/lttng-ust-2.11.0 - Cannot find liburcu-bp lib
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Yixun Lan
URL:
Whiteboard:
Keywords:
Depends on: 763564
Blocks:
  Show dependency tree
 
Reported: 2021-09-19 09:15 UTC by Alessandro Calorì
Modified: 2021-09-24 06:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Portage configuration (emerge.info,7.41 KB, text/plain)
2021-09-19 16:46 UTC, Alessandro Calorì
Details
config.log (config.log,98.58 KB, text/x-log)
2021-09-19 16:50 UTC, Alessandro Calorì
Details
build.log (build.log,12.78 KB, text/x-log)
2021-09-19 16:51 UTC, Alessandro Calorì
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Calorì 2021-09-19 09:15:51 UTC
Today I updated my (stable) Gentoo workstation and dev-util/lttng-ust has to be rebuilt due to dev-libs/userspace-rcu being bumped to 0.13. The rebuild fails during the configuration phase with the message:


checking for synchronize_rcu_bp in -lurcu-bp... no
configure: error: Cannot find liburcu-bp lib. Use LDFLAGS=-Ldir to specify its location.


Masking =dev-libs/userspace-rcu-0.13.0 solves the issue.
Comment 1 Conrad Kostecki gentoo-dev 2021-09-19 11:09:51 UTC
Please attach full build.log and config.log.
Comment 2 Alessandro Calorì 2021-09-19 16:46:52 UTC
Created attachment 740097 [details]
Portage configuration
Comment 3 Alessandro Calorì 2021-09-19 16:50:03 UTC
Created attachment 740100 [details]
config.log
Comment 4 Alessandro Calorì 2021-09-19 16:51:35 UTC
Created attachment 740103 [details]
build.log
Comment 5 John Moe 2021-09-19 21:06:49 UTC
FWIW, I'm having the same issue:

configure: error: Cannot find liburcu-bp lib. Use LDFLAGS=-Ldir to specify its location.

Happy to provide extra info if helpful.
Comment 6 Sam James archtester gentoo-dev Security 2021-09-19 21:54:18 UTC
Please retry with dev-util/lttng-ust-2.12.1.
Comment 7 Alessandro Calorì 2021-09-20 05:59:37 UTC
I can confirm that dev-util/lttng-ust-2.12.1 now merges successfully with dev-libs/userspace-rcu-0.13.0 on my workstation. Thank you.
Comment 8 Yixun Lan archtester gentoo-dev 2021-09-24 06:10:06 UTC
so fixed at >=dev-util/lttng-ust-2.12.1, I'm closing it..