Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 813639 - Packages using pkgconf for systemd/udev install paths install files in /${ROOT}/${SYSROOT}...
Summary: Packages using pkgconf for systemd/udev install paths install files in /${ROO...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo systemd Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-18 12:56 UTC by Johannes Geiss
Modified: 2021-10-01 14:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Geiss 2021-09-18 12:56:26 UTC
Crossdev creates a make.conf file with ROOT="/usr/${CHOST}/".
So far, so good. But some packages like systemd install some files (not all) into
/usr/CHOST/usr/CHOST instead of /usr/CHOST.
Comment 1 Johannes Geiss 2021-09-18 12:56:56 UTC
Example (reproduced in Docker, but can be reproduced without it):

1. docker pull gentoo/stage3
2. docker tag gentoo/stage3:latest gentoo/stage3:2021-09
3. docker rmi gentoo/stage3:latest
4. docker run --name $USER.gentoo-session -w /root -tiv /var/db/repos/gentoo:/var/db/repos/gentoo -v $PWD:/mnt gentoo/stage3:2021-09
5. mkdir -p /etc/portage/repos.conf
6. cat >/etc/portage/repos.conf/gentoo.conf <<EOF
[DEFAULT]
main-repo = gentoo

[gentoo]
location = /var/db/repos/gentoo
sync-type = rsync
sync-uri = rsync://rsync.europe.gentoo.org/gentoo-portage
auto-sync = yes
sync-rsync-verify-jobs = 1
sync-rsync-verify-metamanifest = yes
sync-rsync-verify-max-age = 24
sync-openpgp-key-path = /usr/share/openpgp-keys/gentoo-release.asc
sync-openpgp-key-refresh-retry-count = 40
sync-openpgp-key-refresh-retry-overall-timeout = 1200
sync-openpgp-key-refresh-retry-delay-exp-base = 2
sync-openpgp-key-refresh-retry-delay-max = 60
sync-openpgp-key-refresh-retry-delay-mult = 4
priority = 20
EOF

7. chmod 0644 /etc/portage/repos.conf/gentoo.conf
8. emerge -v crossdev
9. mkdir -p /var/db/repos/private-overlay/{profiles,metadata}
10. echo "private-overlay" >/var/db/repos/private-overlay/profiles/repo_name
11. echo "masters = gentoo" >/var/db/repos/private-overlay/metadata/layout.conf
12. echo "thin-manifests = true" >>/var/db/repos/private-overlay/metadata/layout.conf
13. chown -R portage:portage /var/db/repos/private-overlay/{profiles,metadata}
14. echo "[private-overlay]" >/etc/portage/repos.conf/private.conf
15. echo "location = /var/db/repos/private-overlay" >>/etc/portage/repos.conf/private.conf
16. echo "priority = 10" >>/etc/portage/repos.conf/private.conf
17. echo "masters = gentoo" >>/etc/portage/repos.conf/private.conf
18. echo "auto-sync = no" >>/etc/portage/repos.conf/private.conf
19. export CT=arm-unknown-linux-gnueabi
20. crossdev --stable -oS gentoo -oO /var/db/repos/private-overlay --target $CT
21. sed -i 's/USE="${ARCH} -pam"/USE="-* ${ARCH} split-usr systemd -kill"/g' /usr/$CT/etc/portage/make.conf
22. mkdir /usr/$CT/etc/portage/package.use
23. echo >/usr/$CT/etc/portage/package.use/util-linux sys-apps/util-linux -systemd kill
24. $CT-emerge -v sys-apps/dbus
Comment 2 Johannes Geiss 2021-09-18 12:57:26 UTC
Result:
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/udev
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/udev/rules.d
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/udev/rules.d/40-gentoo.rules
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system-preset
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system-preset/99-default.preset
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system-generators
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system-generators/gentoo-local-generator
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/multi-user.target.wants
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/multi-user.target.wants/dbus.service
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/sockets.target.wants
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/sockets.target.wants/dbus.socket
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/dbus.socket
/usr/arm-unknown-linux-gnueabi/usr/arm-unknown-linux-gnueabi/lib/systemd/system/dbus.service
Comment 3 Johannes Geiss 2021-09-18 12:57:36 UTC
Expected:
/usr/arm-unknown-linux-gnueabi/lib/
/usr/arm-unknown-linux-gnueabi/lib/udev
/usr/arm-unknown-linux-gnueabi/lib/udev/rules.d
/usr/arm-unknown-linux-gnueabi/lib/udev/rules.d/40-gentoo.rules
/usr/arm-unknown-linux-gnueabi/lib/systemd
/usr/arm-unknown-linux-gnueabi/lib/systemd/system-preset
/usr/arm-unknown-linux-gnueabi/lib/systemd/system-preset/99-default.preset
/usr/arm-unknown-linux-gnueabi/lib/systemd/system-generators
/usr/arm-unknown-linux-gnueabi/lib/systemd/system-generators/gentoo-local-generator
/usr/arm-unknown-linux-gnueabi/lib/systemd/system
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/multi-user.target.wants
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/multi-user.target.wants/dbus.service
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/sockets.target.wants
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/sockets.target.wants/dbus.socket
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/dbus.socket
/usr/arm-unknown-linux-gnueabi/lib/systemd/system/dbus.service
Comment 4 Johannes Geiss 2021-09-18 12:58:00 UTC
Portage 3.0.20 (python 3.9.6-final-0, default/linux/amd64/17.1, gcc-10.3.0, glibc-2.33-r1, 5.10.61-gentoo-mizar x86_64)
=================================================================
System uname: Linux-5.10.61-gentoo-mizar-x86_64-Intel-R-_Core-TM-_i7-3615QM_CPU_@_2.30GHz-with-glibc2.33
KiB Mem: 16309744 total, 10246696 free
KiB Swap: 33554112 total, 31206340 free
Timestamp of repository gentoo: Sun, 12 Sep 2021 23:15:01 +0000
Head commit of repository gentoo: 30ec74abc214189b8dc11cc4968f0e9e6965754e
sh bash 5.1_p8
ld GNU ld (Gentoo 2.36.1 p5) 2.36.1
app-shells/bash: 5.1_p8::gentoo
dev-lang/perl: 5.34.0::gentoo
dev-lang/python: 3.9.6_p2::gentoo
sys-apps/baselayout: 2.7::gentoo
sys-apps/openrc: 0.43.5::gentoo
sys-apps/sandbox: 2.24::gentoo
sys-devel/autoconf: 2.69-r5::gentoo
sys-devel/automake: 1.16.3-r1::gentoo
sys-devel/binutils: 2.36.1-r2::gentoo
sys-devel/gcc: 10.3.0-r2::gentoo
sys-devel/gcc-config: 2.4::gentoo
sys-devel/libtool: 2.4.6-r6::gentoo
sys-devel/make: 4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc: 2.33-r1::gentoo
Repositories:

private-overlay
    location: /var/db/repos/private-overlay
    masters: gentoo
    priority: 10

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: 20
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 bzip2 cli crypt dri fortran gdbm iconv ipv6 libglvnd libtirpc multilib ncurses nls nptl openmp pam pcre readline seccomp split-usr ssl systemd tcpd unicode xattr zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 5 Mike Gilbert gentoo-dev 2021-09-18 13:47:23 UTC
These are installed by sys-apps/gentoo-systemd-integration:

/lib/udev/rules.d/40-gentoo.rules
/lib/systemd/system-generators/gentoo-local-generator
/lib/systemd/system-preset/99-default.preset

These are installed by sys-apps/dbus:

/lib/systemd/system/multi-user.target.wants/dbus.service
/lib/systemd/system/sockets.target.wants/dbus.socket
/lib/systemd/system/dbus.socket
/lib/systemd/system/dbus.service
Comment 6 Mike Gilbert gentoo-dev 2021-09-18 13:51:58 UTC
This is probably due to pkgconf misbehaving.

https://github.com/pkgconf/pkgconf/issues/205
Comment 7 Mike Gilbert gentoo-dev 2021-09-18 14:50:46 UTC
I sent a patch series to gentoo-dev that should resolve the problem for these packages.

https://archives.gentoo.org/gentoo-dev/message/41415ec4c4d045051af93fef9a463c60

I'm not sure if it makes sense to set PKGCONF_PKG_PKGF_FDO_SYSROOT_RULES in cross-pkg-config: there may be instances where we actually want SYSROOT to be prepended to pkgconfig variable values.
Comment 8 Larry the Git Cow gentoo-dev 2021-09-19 21:38:43 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3037b9ea3bc955792dedef480efc27ce493dfe7b

commit 3037b9ea3bc955792dedef480efc27ce493dfe7b
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2021-09-18 14:22:51 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-09-19 21:38:26 +0000

    sys-apps/dbus: pass systemduserunitdir to configure
    
    Closes: https://bugs.gentoo.org/813639
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 sys-apps/dbus/dbus-1.12.20-r3.ebuild | 1 +
 1 file changed, 1 insertion(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8c1e17dde18dc56831b368d66429b1b4760ec895

commit 8c1e17dde18dc56831b368d66429b1b4760ec895
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2021-09-18 14:16:09 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-09-19 21:38:25 +0000

    sys-apps/gentoo-systemd-integration: pass systemd dirs to configure
    
    This prevents install paths from being prefixed with SYSROOT by
    pkg-config.
    
    Bug: https://bugs.gentoo.org/813639
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 .../gentoo-systemd-integration-8.ebuild                      | 10 ++++++++++
 .../gentoo-systemd-integration-9.ebuild                      | 12 +++++++++++-
 .../gentoo-systemd-integration-9999.ebuild                   | 12 +++++++++++-
 3 files changed, 32 insertions(+), 2 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b8f91fee6a8314dc58c1da011b65d9b857ef963f

commit b8f91fee6a8314dc58c1da011b65d9b857ef963f
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2021-09-18 14:35:51 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-09-19 21:38:24 +0000

    systemd.eclass: introduce systemd_get_systempresetdir
    
    Bug: https://bugs.gentoo.org/813639
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 eclass/systemd.eclass | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3fc8be35607dc65897279f666c8171b174dd2bf2

commit 3fc8be35607dc65897279f666c8171b174dd2bf2
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2021-09-18 14:10:53 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-09-19 21:38:24 +0000

    udev.eclass: set PKG_CONFIG_FDO_SYSROOT_RULES
    
    This prevents pkgconf from prepending install paths with SYSROOT.
    
    Bug: https://bugs.gentoo.org/813639
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 eclass/udev.eclass | 2 ++
 1 file changed, 2 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b6a14ebec15b54b109f93b9d330d2083a663aa1c

commit b6a14ebec15b54b109f93b9d330d2083a663aa1c
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2021-09-18 14:09:34 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2021-09-19 21:38:23 +0000

    systemd.eclass: set PKG_CONFIG_FDO_SYSROOT_RULES
    
    This prevents pkgconf from prepending install paths with SYSROOT.
    
    Bug: https://bugs.gentoo.org/813639
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 eclass/systemd.eclass | 3 +++
 1 file changed, 3 insertions(+)
Comment 9 Johannes Geiss 2021-10-01 07:24:33 UTC
Maybe simmilar to https://bugs.gentoo.org/815520
Comment 10 Johannes Geiss 2021-10-01 07:25:59 UTC
(In reply to Johannes Geiss from comment #9)
> Maybe simmilar to https://bugs.gentoo.org/815520

Sorry, this comment in an error and belongs to https://bugs.gentoo.org/815520