Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 81077 - gnomemeeting 1.2 fails to emerge because of missing XML::Parser perl module
Summary: gnomemeeting 1.2 fails to emerge because of missing XML::Parser perl module
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Stefan Knoblich (RETIRED)
Depends on:
Reported: 2005-02-06 23:59 UTC by Mihai Pora
Modified: 2006-04-16 09:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Bug caused by problem in perl install (config.log,4.08 KB, text/plain)
2005-11-01 09:54 UTC, Mike Howard

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Pora 2005-02-06 23:59:02 UTC
I did an 'ACCEPT_KEYWORDS=~x86 emerge gnomemeeting".
All dependencies were succesfully installe except gnomemeeting 1.2 which produced an error during .configure : XML::Parser was missing.
I installed XML::Parser module using 'perl -MCPAN -e 'install XML::Parser'. After that the error disapeared and compilation went on.

Reproducible: Always
Steps to Reproduce:
1. prerequisite : must not have XML::Parser perl module installed
2. ACCEPT_KEYWORDS=~x86 emerge gnomemeeting => error
3. to solve the problem run : perl -MCPAN -e 'install XML::Parser

Actual Results:  
step 2 => error
step 3 => compilation begins

Expected Results:  
XML::Parser module should have been detected as a dependency for gnomemeeting
1.2 and installed by emerge.
Comment 1 Mihai Pora 2005-02-07 00:14:03 UTC
After installing XML::Parser from CPAN, gnomemeeting failed to compile with this error (unrelated to the previour provblem) :

if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -DGNOMELOCALEDIR=\""/usr/share/locale"\" -I../src -I../lib -I../lib/widgets -I../lib/xdap  -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -DDISABLE_GNOME -I/usr/include/ptlib -I/usr/include/ptclib  -I/usr/include/openh323   -I/usr/include -DPTRACING -DNDEBUG -Wall -Os -g -DP_USE_PRAGMA -D_REENTRANT -fno-exceptions -DGNOMEMEETING_IMAGES=\""/usr/share/pixmaps/"\" -DGNOMEMEETING_SOUNDS=\""/usr/share/sounds/gnomemeeting/"\" -DSCHEMA_AGE=55 -DGNOMEMEETING_DATADIR=\""/usr/share"\"     -O3 -march=pentium3 -fprefetch-loop-arrays -funroll-loops -pipe -MT main_window.o -MD -MP -MF ".deps/main_window.Tpo" \
  -c -o main_window.o `test -f 'main_window.cpp' || echo './'`main_window.cpp; \
then mv -f ".deps/main_window.Tpo" ".deps/main_window.Po"; \
else rm -f ".deps/main_window.Tpo"; exit 1; \
main_window.cpp: In function `void gm_mw_init_menu(GtkWidget*)':
main_window.cpp:1131: error: `fullscreen_changed_cb' undeclared (first use this 
main_window.cpp:1131: error: (Each undeclared identifier is reported only once 
   for each function it appears in.)
make[2]: *** [main_window.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnomemeeting-1.2.0/work/gnomemeeting-1.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnomemeeting-1.2.0/work/gnomemeeting-1.2.0'
make: *** [all] Error 2

!!! ERROR: net-im/gnomemeeting-1.2.0 failed.
!!! Function src_compile, Line 79, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-07 02:02:09 UTC
Please don't pre-assign bugs unless you know the proper place to put them.
Comment 3 Mike Howard 2005-11-01 09:54:27 UTC
Created attachment 71885 [details]
Bug caused by problem in perl install

Runing with CHOST="i686-pc-linux-gnu", perl puts XML::Parser and friends
in /usr/lib/perl5/vendor_perl/5.8.6/i386-linux rather than in

I tried:
 - downloading XML::Parser from CPAN
 - symbolic link from /usr/.../i686-linux/XML to ../i386-linux/XML [ls resolves

   files, but perl can't]
 - cp -rp i386-linux/XML/ i686-linux/

none of these worked.  [perl -MXML::Parser -e shell fails to find either
   XML::Parser or XML::Parser:Expat.

Anyway, the perl install is munged for CHOST=i686-pc-linux-gnu
Comment 4 Mike Howard 2005-11-01 18:44:16 UTC
Comment on attachment 71885 [details]
Bug caused by problem in perl install

I did the following and the problem went away:
 1. rm -rf /usr/lib/perl5/vendor_perl
 2. emerge --unmerge perl
 3. emerge perl
 4. emerge --unmerge dev-perl/XML-Parser
 5. emerge dev-perl/XML-Parser

I don't know which steps were necessary, but XML::Parser is finally installed
in the right place and gdm is installing.
Comment 5 Andrew Corrigan 2006-04-15 06:27:04 UTC
When I was updating my system, it got to emerge-ing intltool at which point I got the same exact error regarding XML::Parser.

However, I just followed part of Mike Howard's recommendation and did
emerge --unmerge dev-perl/XML-Parser
emerge --merge dev-perl/XML-Parser

then went back to emerge --deep --newuse --update world

and intltool was emerged fine.
Comment 6 Carsten Lohrke (RETIRED) gentoo-dev 2006-04-16 09:06:54 UTC
The problem is, that you did not ran the perl-cleaner script after updating perl. This affects all perl related packages, so do it.

*** This bug has been marked as a duplicate of 41124 ***