Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80990 - icecast2 doesn't create propper log directory.
Summary: icecast2 doesn't create propper log directory.
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 84002 95662 95666 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-06 08:32 UTC by Olliver Schinagl
Modified: 2007-04-17 03:38 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild (icecast-2.2.0-r1-ebuild.patch,1.45 KB, patch)
2005-12-10 10:12 UTC, Chris Mayo
Details | Diff
The patch for icecast.xml for user ice:ice (icecast-xml.patch,421 bytes, patch)
2005-12-10 10:13 UTC, Chris Mayo
Details | Diff
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild (icecast-2.2.0-r1-ebuild.patch,1.25 KB, patch)
2005-12-11 02:35 UTC, Chris Mayo
Details | Diff
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild (icecast-2.2.0-r1.patch,1.11 KB, patch)
2006-05-30 11:28 UTC, Chris Mayo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olliver Schinagl 2005-02-06 08:32:28 UTC
When emerging icecast icecast gets installed but the default config file points to non existing log file.

Reproducible: Always
Steps to Reproduce:
1.emerge icecast
2.start icecast


Actual Results:  
icecast says it started, but it did not. (because it is unable to write to the
log file)

Expected Results:  
icecast should have started or the startup script should have said it failed
starting.

It would make more sense to use /var/log/icecast for icecast logs? /var/lib/log
does not even exist on my system.

Also, on a side note, default config file has uid/gid degradation disabled,
where icecast starts with an error message that you cannot run it as root.
However the default config file is only used by root anyhow?
(/etc/icecast2/icecast.xml)
Comment 1 Eric Shattow 2005-03-12 02:53:23 UTC
AFAIK you're supposed to edit the config file before being able to sucessfully run icecast2 from a fresh install.  Should we make this more clearer?
Comment 2 Eric Shattow 2005-03-12 02:58:02 UTC
*** Bug 84002 has been marked as a duplicate of this bug. ***
Comment 3 Olliver Schinagl 2005-03-12 12:10:56 UTC
It does not matter wether you should edit the config file or not the default path should be sane : ).

I know there are a lot of people who won't properly read/edit a file. On the other hand should users have to worry about config files as little as possible. E.g. have sane default values so you have to change as little as possible.

Thats what I think anyway.
Comment 4 Paul Handly 2005-03-31 22:05:43 UTC
I just fiddled around with icecast, finally managing to get it going - IMHO, the ebuild needs to be revised to manage the icecast user/group automatically, and modify the config file to something sane OR (much easier) print out a list of instructions necessary to get this working more or less out of the box. (einfo style)

If I have time, I'll get on this, after I figure out why anything that isn't an .xsl file 404s in the web administration interface.
Comment 5 Jeremy Huddleston (RETIRED) gentoo-dev 2005-05-04 15:27:45 UTC
If you could provide patches, this will have a higher chance of getting solved as most of us are content the way it is and have more pressing issues.  thanks.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-06-10 04:14:01 UTC
*** Bug 95666 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-06-10 04:14:49 UTC
*** Bug 95662 has been marked as a duplicate of this bug. ***
Comment 8 Chris Mayo 2005-12-10 10:12:25 UTC
Created attachment 74443 [details, diff]
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild

Suggested changes to:
 - Create logs in /var/log/icecast
 - Run as ice:ice (including modifying icecast.xml)
 - Add theora flag to ensure required version of theora libs are installed
Comment 9 Chris Mayo 2005-12-10 10:13:05 UTC
Created attachment 74444 [details, diff]
The patch for icecast.xml for user ice:ice
Comment 10 Chris Mayo 2005-12-11 02:35:03 UTC
Created attachment 74474 [details, diff]
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild

Use eutils enewuser and enewgroup
Comment 11 Luká Polívka 2006-05-06 03:26:59 UTC
I've installed icecast-2.3.1 and /var/log/icecast has wrong owner (root). It must be "icecast".
Comment 12 Chris Mayo 2006-05-30 11:28:46 UTC
Created attachment 87893 [details, diff]
Patch to convert icecast-2.2.0.ebuild to icecast-2.2.0-r1.ebuild

Create pkg_preinst() for enewgroup and enewuser functions.
Comment 13 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-08-03 16:17:30 UTC
I'm going to vote wontfix here, since the defaults are upstreams.