Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80933 - gl-117 segfaults early in the intro
Summary: gl-117 segfaults early in the intro
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2005-02-05 17:52 UTC by Beetle B.
Modified: 2005-02-15 17:05 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Beetle B. 2005-02-05 17:52:08 UTC
When I start, it shows the intro, and then segfaults.

Output at maximum debug level:

"Info: Entering debug level 5
Info: Found gl-117 data directory /usr/share/games/gl-117
Info: Startup gl-117, V1.3 ...
Debug: Getting directory locations
Info: Loading /home/mueen/.gl-117/conf
Info: Saving /home/mueen/.gl-117/conf
Info: Loading /home/mueen/.gl-117/conf.interface
Info: Saving /home/mueen/.gl-117/conf.interface
Debug: Creating/Loading pilots list
Info: Using SDL and GLUT
Debug: Setting SDL caption
Debug: Creating sound system
Info: Using SDL_mixer
Debug: Playing startup music
Debug: Calling main initialization method
Debug: Creating calculation tables
Debug: Creating advanced OpenGL methods
Debug: Loading textures
Debug: Loading Fonts
Debug: Loading 3ds models:
Debug:  * gl-16.3ds
Debug:  * gl-15.3ds
Debug:  * gl-14c.3ds
Debug:  * gl-14d.3ds
Debug:  * gl-21b.3ds
Debug:  * gl-21.3ds
Debug:  * gl-14b.3ds
Debug:  * gl-14.3ds
Debug:  * gl-29.3ds
Debug:  * gl-50.3ds
Debug:  * transp2.3ds
Debug:  * transp4.3ds
Debug:  * cannon1.3ds
Debug:  * cannon1b.3ds
Debug:  * cannon2.3ds
Debug:  * cannon2b.3ds
Debug:  * flare1.3ds
Debug:  * chaff1.3ds
Debug:  * missile1.3ds
Debug:  * missile2.3ds
Debug:  * missile3.3ds
Debug:  * missile4.3ds
Debug:  * missile5.3ds
Debug:  * missile6.3ds
Debug:  * missile7.3ds
Debug:  * missile8.3ds
Debug:  * flak2.3ds
Debug:  * flarak1.3ds
Debug:  * ship1.3ds
Debug:  * tent1.3ds
Debug:  * gl-117.3ds
Debug:  * tank1.3ds
Debug:  * container1.3ds
Debug:  * ship2.3ds
Debug:  * truck1.3ds
Debug:  * truck2.3ds
Debug:  * trsam.3ds
Debug:  * pickup1.3ds
Debug:  * pickup2.3ds
Debug:  * tank2.3ds
Debug:  * tent4.3ds
Debug:  * hall1.3ds
Debug:  * hall2.3ds
Debug:  * oilrig.3ds
Debug:  * egg.3ds
Debug:  * radar.3ds
Debug:  * mine1.3ds
Debug:  * aster1.3ds
Debug:  * base1.3ds
Debug:  * barrier.3ds
Debug:  * rubble.3ds
Debug:  * depot1.3ds
Debug: Setting up world geometry
Debug: Querying joystick
Info: No joystick found
Debug: Entering SDL main loop (GLUT emulation)
Segmentation fault"

I recently installed the new ATI drivers (am using Radeon 8500LE) for XOrg. I don't know if that has anything to do with it. Nor do I know if it worked earlier (never really tried till now).
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2005-02-05 17:54:45 UTC
include emerge --info in your bug report.

reopen with that please.
Comment 2 Beetle B. 2005-02-05 18:42:27 UTC
emerge --info output:

Portage 2.0.51-r15 (default-linux/x86/2004.0, gcc-3.3.5, glibc-, 2.4.20-gentoo-r8 i686)
System uname: 2.4.20-gentoo-r8 i686 Intel(R) Pentium(R) 4 CPU 2.53GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4,dev-lang/python-2.2.3-r5 [2.3.4 (#1,Jan  9 2005, 20:10:17)]
dev-lang/python:     2.3.4, 2.2.3-r5
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r3, 1.6.3, 1.7.9-r1, 1.4_p6, 1.9.4
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.19-r1, 2.4.21-r1
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks fixpackages sandbox sfperms"
USE="3dnow 3dnowex X aalib acpi alsa apache2 apm arts avi berkdb bitmap-fonts bonobo cdparanoia cdr crypt cups dga directfb divx4linux doc dvd dvdr dvdread emacs encode esd f77 fam fbcon fbdev flac font-server foomaticdb fortran gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile imagemagick imap imlib ipv6ir java jpeg junit justify kde lcms ldap leim libg++ libwww live mad maild mboxmikmod mmx motif mozilla mpeg mysql ncurses network nls oav ofx oggvorbis opengl oss pam pda pdflib perl pgp plotutils png pnp python qt quicktime readline real samba sasl sdl slang speex spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts usb vesa wmf x86 xinerama xml xml2 xmms xv xvid zlib video_cards_radeon"
Comment 3 Mr. Bones. (RETIRED) gentoo-dev 2005-02-05 20:34:36 UTC
Can I get the output of emerge -evp gl117 please.

Also, what version of libsdl and ati-drivers are you running?  Might be worth
checking to see if this problem occurs with earlier versions of the ati-drivers.
Comment 4 Beetle B. 2005-02-05 21:45:39 UTC
Version of libsdl: 1.2.7-r3
Version of ati-drivers: 8.8.25-r3

Output of emerge -evp gl117:

emerge -evp gl117

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] sys-devel/patch-2.5.9  -build -debug -static 197 kB
[ebuild  N    ] sys-libs/gpm-1.20.1  (-selinux) 558 kB
[ebuild  N    ] sys-devel/gnuconfig-20040214  (-uclibc) 30 kB
[ebuild  N    ] sys-libs/ncurses-5.4-r5  -bootstrap -build -debug +doc +gpm -nocxx (-uclibc) -unicode 2,103 kB
[ebuild  N    ] sys-devel/gettext-0.12.1-r2  +emacs +nls 5,592 kB
[ebuild  N    ] sys-devel/m4-1.4.1  +nls 335 kB
[ebuild  N    ] sys-devel/bison-1.875d  -debug +nls -static 0 kB
[ebuild  N    ] sys-apps/sed-4.0.9  -bootstrap -build -debug +nls -static 751 kB
[ebuild  N    ] sys-libs/zlib-1.2.2  -build -debug 0 kB
[ebuild  N    ] dev-python/python-fchksum-1.7.1  26 kB
[ebuild  N    ] app-arch/bzip2-1.0.2-r4  -build -debug -static 0 kB
[ebuild  N    ] sys-apps/debianutils-1.16.7-r4  -build -debug -static 25 kB
[ebuild  N    ] app-shells/bash-2.05b-r9  -build -debug +nls (-uclibc) 1,923 kB
[ebuild  N    ] sys-libs/readline-4.3-r5  947 kB
[ebuild  N    ] sys-devel/flex-2.5.4a-r5  -build -debug -static 372 kB
[ebuild  N    ] sys-devel/bc-1.06-r5  -debug +readline -static 272 kB
[ebuild  N    ] sys-apps/diffutils-2.8.7  -debug +nls -static 0 kB
[ebuild  N    ] dev-java/java-config-1.2.11  0 kB
[ebuild  N    ] dev-java/blackdown-jre-  +mozilla 0 kB
[ebuild  N    ] app-arch/unzip-5.50-r2  1,043 kB
[ebuild  N f  ] dev-java/java-sdk-docs-1.4.2  0 kB
[ebuild  N    ] dev-java/blackdown-jdk-  +doc +mozilla 0 kB
[ebuild  N    ] dev-lang/tcl-8.4.6  -threads 3,367 kB
[ebuild  N    ] sys-libs/db-4.1.25_p1-r4  -bootstrap +doc +java -nocxx +tcltk 0kB
[ebuild  N    ] sys-apps/texinfo-4.7-r1  -build -debug +nls -static 0 kB
[ebuild  N    ] sys-apps/groff-1.19.1-r2  +X -debug 0 kB
[ebuild  N    ] sys-apps/cronbase-0.3.1  0 kB
[ebuild  N    ] sys-apps/man-1.5p  -debug +nls 0 kB
[ebuild  N    ] sys-libs/db-1.85-r1  264 kB
[ebuild  N    ] sys-libs/gdbm-1.8.3-r1  +berkdb -debug 223 kB
[ebuild  N    ] sys-devel/libperl-5.8.5  +berkdb -debug +gdbm -ithreads (-uclibc) 0 kB
[ebuild  N    ] dev-lang/perl-5.8.5-r3  +berkdb -debug +doc +gdbm -ithreads -perlsuid (-uclibc) 0 kB
[ebuild  N    ] dev-libs/openssl-0.9.7d-r2  -debug +emacs (-uclibc) 4,866 kB
[ebuild  N    ] dev-lang/tk-8.4.6-r1  -threads 3,155 kB
[ebuild  N    ] dev-libs/expat-1.95.8  -test 0 kB
[ebuild  N    ] dev-python/python-docs-2.3.4  1,220 kB
[ebuild  N    ] dev-lang/python-2.3.4  +X +berkdb -bootstrap -build -debug +doc+gdbm +ipv6 +ncurses +readline +ssl +tcltk -ucs2 7,020 kB
[ebuild  N    ] sys-apps/portage-2.0.51-r15  -build -debug (-selinux) 0 kB
*** Please update portage to the above version before proceeding.
    Failure to do so may result in failed or improper merges.
    A simple 'emerge -u portage' is sufficient.

[ebuild  N    ] sys-devel/gcc-config-1.3.8-r4  0 kB
[ebuild  N    ] sys-devel/binutils-  -bootstrap -build -debug -multitarget +nls (-uclibc) 0 kB
[ebuild  N    ] sys-devel/gcc-3.3.5-r1  -bootstrap -boundschecking -build -debug +fortran -gcj +gtk -hardened (-ip28) (-multilib) -multislot (-n32) (-n64) +nls-nocxx -objc -static (-uclibc) 0 kB
[ebuild  N    ] sys-apps/gawk-3.1.3-r2  -build +nls (-uclibc) 0 kB
[ebuild  N    ] sys-kernel/linux-headers-2.4.21-r1  -build 27,864 kB
[ebuild  N    ] sys-apps/baselayout-1.9.4-r6  -bootstrap -build -debug -livecd (-selinux) -static (-uclibc) 197 kB
[ebuild  N    ] sys-libs/glibc-  -build -debug -erandom -hardened (-multilib) +nls -nptl -pic -userlocales 1,147 kB
[ebuild  N    ] sys-apps/grep-2.5.1-r6  -build -debug +nls -pcre -static (-uclibc) 667 kB
[ebuild  N    ] app-crypt/hashalot-0.3  78 kB
[ebuild  N    ] dev-libs/glib-1.2.10-r5  -debug 411 kB
[ebuild  N    ] sys-devel/autoconf-2.13  0 kB
[ebuild  N    ] sys-devel/autoconf-wrapper-2  0 kB
[ebuild  N    ] sys-devel/autoconf-2.59-r6  0 kB
[ebuild  N    ] sys-devel/automake-1.5  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-1.8.5-r3  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-1.6.3  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-1.7.9-r1  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-1.4_p6  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-wrapper-1  0 kB
[ebuild  N    ] sys-devel/automake-1.9.4  (-uclibc) 0 kB
[ebuild  N    ] sys-apps/miscfiles-1.3-r1  (-uclibc) 2,153 kB
[ebuild  N    ] sys-libs/cracklib-2.7-r10  -debug +pam (-uclibc) 20 kB
[ebuild  N    ] sys-libs/pam-0.77-r6  +berkdb -debug -pwdb (-selinux) 0 kB
[ebuild  N    ] sys-apps/pam-login-3.14  -livecd +nls (-selinux) 137 kB
[ebuild  N    ] sys-fs/e2fsprogs-1.35-r1  -debug -diet +nls -static 3,078 kB
[ebuild  N    ] sys-apps/util-linux-2.12i-r1  +crypt -debug +nls +pam +perl (-selinux) -static 0 kB
[ebuild  N    ] media-libs/libpng-1.2.8  -debug 0 kB
[ebuild  N    ] sys-devel/libtool-1.5.10-r4  (-uclibc) 0 kB
[ebuild  N    ] media-libs/freetype-2.1.5-r1  -bindist -cjk -debug +doc +zlib 830 kB
[ebuild  N    ] x11-misc/ttmkfdir-3.0.9-r2  -debug 19 kB
[ebuild  N    ] x11-base/opengl-update-2.1_pre4  0 kB
[ebuild  N    ] media-libs/fontconfig-2.2.3  732 kB
[ebuild  N    ] x11-base/xorg-x11-6.8.0-r4  -3dfx +3dnow +bitmap-fonts -cjk -debug -dlloader -dmx +doc +font-server -hardened -insecure-drivers +ipv6 -minimal +mmx +nls +opengl +pam -sdk +sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 167 kB
[ebuild  N    ] sys-apps/file-4.12  -build -debug +python 0 kB
[ebuild  N    ] sys-apps/which-2.16  122 kB
[ebuild  N    ] app-arch/cpio-2.6-r1  +nls 0 kB
[ebuild  N    ] app-arch/rpm2targz-9.0-r2  2 kB
[ebuild  N    ] sys-apps/utempter-  -debug 0 kB
[ebuild  N    ] x11-terms/xterm-197  -Xaw3d -debug +truetype -unicode 0 kB
[ebuild  N    ] media-libs/svgalib-1.9.19-r1  -build -debug 913 kB
[ebuild  N    ] media-libs/audiofile-0.2.6-r1  365 kB
[ebuild  N    ] sys-apps/tcp-wrappers-7.6-r8  +ipv6 0 kB
[ebuild  N    ] media-libs/jpeg-6b-r4  -debug 598 kB
[ebuild  N    ] media-gfx/graphviz-1.10  +tcltk 3,278 kB
[ebuild  N    ] dev-util/dialog-1.0.20040731  -unicode 0 kB
[ebuild  N    ] sys-apps/ed-0.2-r6  181 kB
[ebuild  N    ] sys-apps/procps-3.2.4-r2  -debug 0 kB
[ebuild  N    ] dev-db/mysql-4.0.22-r2  +berkdb -debug -innodb +perl +readline (-selinux) +ssl -static +tcpd 0 kB
[ebuild  N    ] net-libs/libwww-5.4.0-r2  +mysql +ssl 1,110 kB
[ebuild  N    ] app-text/tetex-2.0.2-r5  +X -debug +doc 0 kB
[ebuild  N    ] dev-perl/Net-Daemon-0.37  0 kB
[ebuild  N    ] dev-perl/Storable-2.07-r1  0 kB
[ebuild  N    ] dev-perl/PlRPC-0.2016-r1  0 kB
[ebuild  N    ] dev-perl/DBI-1.38-r1  0 kB
[ebuild  N    ] dev-perl/DBD-mysql-2.1027  0 kB
[ebuild  N    ] dev-util/pkgconfig-0.15.0  596 kB
[ebuild  N    ] media-fonts/gnu-gs-fonts-std-8.11  3,664 kB
[ebuild  N    ] media-libs/tiff-3.7.1-r1  0 kB
[ebuild  N    ] net-print/cups-1.1.23-r1  -debug +nls +pam +samba -slp +ssl 0 kB
[ebuild  N    ] app-text/ghostscript-7.07.1-r7  +X -cjk +cups -debug +emacs 5,273 kB
[ebuild  N    ] dev-libs/libxml2-2.6.16  -debug +ipv6 +python +readline 0 kB
[ebuild  N    ] dev-perl/Digest-MD4-1.3  28 kB
[ebuild  N    ] dev-perl/Crypt-SmbHash-0.02  7 kB
[ebuild  N    ] dev-libs/popt-1.7-r1  +nls 561 kB
[ebuild  N    ] dev-perl/XML-Parser-2.34  0 kB
[ebuild  N    ] dev-perl/digest-base-1.05  0 kB
[ebuild  N    ] dev-perl/Digest-MD5-2.33  0 kB
[ebuild  N    ] dev-perl/Authen-SASL-2.04  0 kB
[ebuild  N    ] dev-perl/MIME-Base64-3.05  0 kB
[ebuild  N    ] dev-perl/URI-1.35  0 kB
[ebuild  N    ] dev-perl/Convert-ASN1-0.17  0 kB
[ebuild  N    ] dev-perl/Net-SSLeay-1.23  0 kB
[ebuild  N    ] dev-perl/IO-Socket-SSL-0.94  0 kB
[ebuild  N    ] dev-perl/perl-ldap-0.31  +sasl +ssl +xml 0 kB
[ebuild  N    ] dev-libs/cyrus-sasl-2.1.20  -authdaemond +berkdb -debug +gdbm +java -kerberos +ldap +mysql +pam -postgres +ssl -static 0 kB
[ebuild  N    ] net-nds/openldap-2.1.30-r2  +berkdb +crypt -debug +gdbm +ipv6 -odbc +perl +readline +samba +sasl -slp +ssl +tcpd 1,996 kB
[ebuild  N    ] net-fs/samba-3.0.10  -acl +cups -debug +doc -kerberos +ldap -libclamav +mysql +oav +pam -postgres +python -quotas +readline (-selinux) -winbind+xml +xml2 0 kB
[ebuild  N    ] media-libs/lcms-1.13  +jpeg +python +tiff +zlib 0 kB
[ebuild  N    ] media-libs/libmng-1.0.4  555 kB
[ebuild  N    ] media-libs/giflib-4.1.0-r3  +X +gif 0 kB
[ebuild  N    ] media-libs/libungif-4.1.3  +X +gif 0 kB
[ebuild  N    ] x11-libs/qt-3.3.3  +cups -debug +doc -firebird +gif -icc -immqt-immqt-bc +ipv6 +mysql -nas -odbc +opengl -postgres -sqlite +xinerama +zlib 0 kB
[ebuild  N    ] app-doc/doxygen-  +doc +qt +tetex 0 kB
[ebuild  N    ] media-sound/alsa-headers-1.0.8_rc1  0 kB
[ebuild  N    ] sys-apps/module-init-tools-3.0-r2  -debug 0 kB
[ebuild  N    ] sys-devel/make-3.80-r1  -build -debug +nls -static (-uclibc) 0 kB
[ebuild  N    ] app-text/sgml-common-0.6.3-r4  74 kB
[ebuild  N    ] app-text/opensp-1.5-r1  +nls 1,257 kB
[ebuild  N    ] app-text/openjade-1.3.2-r1  -debug 873 kB
[ebuild  N    ] app-text/docbook-sgml-dtd-4.1-r2  55 kB
[ebuild  N    ] app-text/docbook-sgml-dtd-4.0-r2  54 kB
[ebuild  N    ] app-text/docbook-xml-simple-dtd-  34 kB
[ebuild  N    ] dev-perl/SGMLSpm-1.03-r5  0 kB
[ebuild  N    ] app-text/jadetex-3.12  251 kB
[ebuild  N    ] app-text/docbook-dsssl-stylesheets-1.77-r2  385 kB
[ebuild  N    ] app-text/docbook-sgml-dtd-3.0-r2  42 kB
[ebuild  N    ] app-text/docbook-sgml-dtd-3.1-r2  54 kB
[ebuild  N    ] net-www/lynx-2.8.5  -debug +ipv6 +nls +ssl 0 kB
[ebuild  N    ] app-text/build-docbook-catalog-1.2  0 kB
[ebuild  N    ] app-text/docbook-xsl-stylesheets-1.65.1  1,504 kB
[ebuild  N    ] app-text/docbook-xml-dtd-4.3  81 kB
[ebuild  N    ] app-text/docbook-sgml-utils-0.6.12  +tetex 115 kB
[ebuild  N    ] sys-kernel/gentoo-sources-2.4.28-r5  -build +doc -symlink 0 kB
[ebuild  N    ] media-sound/alsa-driver-1.0.8_rc1  -debug +doc +oss 0 kB
[ebuild  N    ] media-libs/alsa-lib-1.0.7  +doc -jack -static 0 kB
[ebuild  N    ] media-sound/esound-0.2.34  +alsa +ipv6 +tcpd 310 kB
[ebuild  N    ] sys-libs/slang-1.4.9-r1  -cjk -unicode 616 kB
[ebuild  N    ] media-libs/aalib-1.4_rc4-r2  +X +gpm +slang -static 381 kB
[ebuild  N    ] dev-lang/nasm-0.98.38-r1  -build +doc 0 kB
[ebuild  N    ] media-libs/a52dec-0.7.4-r3  -debug -djbfft +oss -static 235 kB
[ebuild  N    ] media-libs/libmpeg3-1.5.2  -debug 611 kB
[ebuild  N    ] dev-libs/DirectFB-0.9.20-r1  -debug +fbcon -fusion +gif +jpeg +mmx +mpeg +png +sdl +sse -static +truetype 1,276 kB
[ebuild  N    ] media-libs/libmad-0.15.1b  -debug 490 kB
[ebuild  N    ] dev-libs/libgpg-error-1.0-r1  +nls 0 kB
[ebuild  N    ] dev-libs/libgcrypt-1.1.94  +nls 827 kB
[ebuild  N    ] dev-libs/libxslt-1.1.9-r1  +crypt +python 0 kB
[ebuild  N    ] app-text/docbook-xml-dtd-4.1.2-r5  73 kB
[ebuild  N    ] dev-util/gtk-doc-1.2-r1  +emacs 131 kB
[ebuild  N    ] dev-libs/glib-2.4.8  +doc 0 kB
[ebuild  N    ] media-libs/libogg-1.1.2  0 kB
[ebuild  N    ] kde-base/kde-env-3-r3  0 kB
[ebuild  N    ] media-libs/libvorbis-1.1.0  -aotuv -debug 0 kB
[ebuild  N    ] media-libs/libid3tag-0.15.1b  -debug 330 kB
[ebuild  N    ] kde-base/arts-1.3.2  +alsa +arts -artswrappersuid -debug +esd -hardened -jack -kdeenablefinal +mad +oggvorbis +xinerama 0 kB
[ebuild  N    ] media-libs/libsdl-1.2.7-r3  +X +aalib +alsa +arts +dga +directfb +esd +fbcon -ggi -libcaca -nas -noaudio -nojoystick -novideo +opengl +oss +svga +xinerama +xv 2,413 kB
[ebuild  N    ] media-libs/glut-3.7.1  2,479 kB
[ebuild  N    ] dev-util/intltool-0.31.2  0 kB
[ebuild  N    ] x11-libs/gtk+-1.2.10-r11  -debug +nls 2,880 kB
[ebuild  N    ] media-libs/smpeg-0.4.4-r4  +X -debug +gtk +opengl 307 kB
[ebuild  N    ] media-libs/sdl-mixer-1.2.5-r1  +mikmod +mpeg +oggvorbis 914 kB
[ebuild  N    ] games-simulation/gl117-1.3.1  0 kB

Total size of downloads: 110,132 kB
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2005-02-09 21:54:04 UTC
try it with different versions of the ati-drivers please.   works fine here with nvidia.
Comment 6 Mr. Bones. (RETIRED) gentoo-dev 2005-02-14 11:40:33 UTC
also, try it with the xorg-x11 opengl.  reopen after trying these things.  Thanks.
Comment 7 Beetle B. 2005-02-14 21:45:00 UTC
A different ati driver version would require me to downgrade from xorg 6.8.x, which is too much trouble.

I did change to the xorg-x11 opengl library, and it worked. However, as I expected, it's quite slow. When I run it with the ATI library, the intro comes on, and is much faster (i.e. the "normal" speed). 

Xorg and ATI Radeon didn't work together until the new drivers (all serious graphics apps were unbearably slow with the previous driver versions, including the xorg radeon versions). Now at least some games work fine. 

I take it then that this is an ATI driver issue? 

If I find out about other games/apps not performing (seemingly because of the ATI driver), is there a more appropriate place to post about it?
Comment 8 Mr. Bones. (RETIRED) gentoo-dev 2005-02-14 22:38:34 UTC
I think there's not much to be done about this one.  I don't recommend the ati-drivers because many people have experienced issues with them.  In your case, it could be caused by too aggressive CFLAGS so if I were in your situation I would drop down to CFLAGS="-O2 -pipe" and emerge -ev world to see if it helped.  However, since downgrading xorg-x11 is by itself too much trouble, I think you're on your own.  Sorry.

CC'd x11 in case they have any additional thoughts about this.
Comment 9 Luca Barbato gentoo-dev 2005-02-15 00:34:11 UTC
I'll try to reproduce the issue, a backtrace could help
Comment 10 Luca Barbato gentoo-dev 2005-02-15 00:42:41 UTC
update: it works fine for me
Comment 11 Beetle B. 2005-02-15 17:05:33 UTC
Are you using a Radeon based ATI card?