Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808897 - net-libs/libtorrent-rasterbar-2.0.4 - /.../allocating_handler.hpp: error: static assertion failed: Handler buffer not large enough
Summary: net-libs/libtorrent-rasterbar-2.0.4 - /.../allocating_handler.hpp: error: sta...
Status: RESOLVED DUPLICATE of bug 808084
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-18 16:07 UTC by Toralf Förster
Modified: 2021-08-18 16:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.64 KB, text/plain)
2021-08-18 16:07 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,177.31 KB, text/plain)
2021-08-18 16:07 UTC, Toralf Förster
Details
environment (environment,121.01 KB, text/plain)
2021-08-18 16:07 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,23.63 KB, application/x-bzip)
2021-08-18 16:07 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,5.10 KB, application/x-bzip)
2021-08-18 16:07 UTC, Toralf Förster
Details
net-libs:libtorrent-rasterbar-2.0.4:20210818-114241.log (net-libs:libtorrent-rasterbar-2.0.4:20210818-114241.log,147.14 KB, text/plain)
2021-08-18 16:07 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,33.86 KB, application/x-bzip)
2021-08-18 16:07 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-18 16:07:18 UTC
/var/tmp/portage/net-libs/libtorrent-rasterbar-2.0.4/work/libtorrent-rasterbar-2.0.4/include/libtorrent/aux_/allocating_handler.hpp:180:47: error: static assertion failed: Handler buffer not large enough, please increase it
  180 |                 static_assert(Required::value <= Available::value
      |                                         ~~~~~~^~~~~~~~~~~~~~~~~~~
/var/tmp/portage/net-libs/libtorrent-rasterbar-2.0.4/work/libtorrent-rasterbar-2.0.4/include/libtorrent/aux_/allocating_handler.hpp:180:47: note: ‘(((long unsigned int)libtorrent::aux::required_size<128>::value) <= ((long unsigned int)libtorrent::aux::available_size<112>::value))’ evaluates to false
/var/tmp/portage/net-libs/libtorrent-rasterbar-2.0.4/work/libtorrent-rasterbar-2.0.4/include/libtorrent/aux_/allocating_handler.hpp: In instantiation of ‘struct libtorrent::aux::assert_message<libtorrent::aux::required_size<160>, libtorrent::aux::available_size<144>, libtorrent::aux::udp_handler>’:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-j4-20210816-205927

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Rust versions:
  [1]   rust-1.54.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4
  [1]   php7.3
  [2]   php7.4
  [3]   php8.0 *

  HEAD of ::gentoo
commit 0087429ccdb5565e3722741aba71d37fba4e25e8
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Wed Aug 18 10:53:12 2021 +0000

    2021-08-18 10:53:06 UTC

emerge -qpvO net-libs/libtorrent-rasterbar
[ebuild  N    ] net-libs/libtorrent-rasterbar-2.0.4  USE="dht ssl -debug -gnutls -python -test"
Comment 1 Toralf Förster gentoo-dev 2021-08-18 16:07:19 UTC
Created attachment 733847 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-18 16:07:21 UTC
Created attachment 733849 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-08-18 16:07:23 UTC
Created attachment 733851 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-08-18 16:07:24 UTC
Created attachment 733853 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-08-18 16:07:25 UTC
Created attachment 733855 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-18 16:07:26 UTC
Created attachment 733857 [details]
net-libs:libtorrent-rasterbar-2.0.4:20210818-114241.log
Comment 7 Toralf Förster gentoo-dev 2021-08-18 16:07:27 UTC
Created attachment 733859 [details]
temp.tar.bz2
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-18 16:12:30 UTC

*** This bug has been marked as a duplicate of bug 808084 ***