Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808705 - media-sound/snapcast-0.25.0-r1 - /.../wchar_t.hpp: error: transform is not a member of std (maybe gcc-11 related)
Summary: media-sound/snapcast-0.25.0-r1 - /.../wchar_t.hpp: error: transform is not a ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jakov Smolić
URL: https://github.com/badaix/snapcast/is...
Whiteboard:
Keywords:
Depends on:
Blocks: boost-1.77
  Show dependency tree
 
Reported: 2021-08-17 07:18 UTC by Toralf Förster
Modified: 2021-11-06 19:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.70 KB, text/plain)
2021-08-17 07:18 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,227.24 KB, text/plain)
2021-08-17 07:18 UTC, Toralf Förster
Details
environment (environment,90.74 KB, text/plain)
2021-08-17 07:18 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,27.45 KB, application/x-bzip)
2021-08-17 07:18 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,5.04 KB, application/x-bzip)
2021-08-17 07:18 UTC, Toralf Förster
Details
media-sound:snapcast-0.25.0:20210817-023210.log (media-sound:snapcast-0.25.0:20210817-023210.log,40.21 KB, text/plain)
2021-08-17 07:18 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,25.21 KB, application/x-bzip)
2021-08-17 07:18 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-17 07:18:38 UTC
/usr/include/boost/process/detail/traits/wchar_t.hpp: In static member function ‘static std::vector<std::__cxx11::basic_string<wchar_t> > boost::process::detail::char_converter<wchar_t, std::vector<std::__cxx11::basic_string<char> > >::conv(const std::vector<std::__cxx11::basic_string<char> >&)’:
/usr/include/boost/process/detail/traits/wchar_t.hpp:150:14: error: ‘transform’ is not a member of ‘std’
  150 |         std::transform(in.begin(), in.end(), ret.begin(),
      |              ^~~~~~~~~
/usr/include/boost/process/detail/traits/wchar_t.hpp: In static member function ‘static std::vector<std::__cxx11::basic_string<wchar_t> > boost::process::detail::char_converter<wchar_t, std::initializer_list<std::__cxx11::basic_string<char> > >::conv(const std::initializer_list<std::__cxx11::basic_string<char> >&)’:
/usr/include/boost/process/detail/traits/wchar_t.hpp:165:14: error: ‘transform’ is not a member of ‘std’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no_multilib_systemd-j3-20210815-050010

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
The following VMs are available for generation-2:
Available Java Virtual Machines:
  (none found)


  HEAD of ::gentoo
commit c30fa9e37056c2f872368b3358ddabdf77502c27
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Tue Aug 17 01:06:37 2021 +0000

    2021-08-17 01:06:36 UTC

emerge -qpvO media-sound/snapcast
[ebuild  N    ] media-sound/snapcast-0.25.0  USE="client expat flac opus server vorbis zeroconf -tremor"
Comment 1 Toralf Förster gentoo-dev 2021-08-17 07:18:39 UTC
Created attachment 733449 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-17 07:18:41 UTC
Created attachment 733451 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-08-17 07:18:42 UTC
Created attachment 733453 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-08-17 07:18:44 UTC
Created attachment 733455 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-08-17 07:18:45 UTC
Created attachment 733457 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-17 07:18:46 UTC
Created attachment 733459 [details]
media-sound:snapcast-0.25.0:20210817-023210.log
Comment 7 Toralf Förster gentoo-dev 2021-08-17 07:18:47 UTC
Created attachment 733461 [details]
temp.tar.bz2
Comment 8 Jakov Smolić gentoo-dev 2021-08-29 14:27:47 UTC
This seems to be boost-1.77 related
Comment 9 Agostino Sarubbo gentoo-dev 2021-10-05 09:29:20 UTC
ci has reproduced this issue with version 0.25.0-r1 - Updating summary.
Comment 11 Larry the Git Cow gentoo-dev 2021-11-06 19:40:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4f80001703d1300bf35141adcfca5593da5fdb9f

commit 4f80001703d1300bf35141adcfca5593da5fdb9f
Author:     Jakov Smolić <jsmolic@gentoo.org>
AuthorDate: 2021-11-06 19:40:17 +0000
Commit:     Jakov Smolić <jsmolic@gentoo.org>
CommitDate: 2021-11-06 19:40:17 +0000

    media-sound/snapcast: Apply c++17 patch
    
    Thanks to Andreas Sturmlechner for providing the patch link.
    
    Closes: https://bugs.gentoo.org/808705
    Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>

 .../snapcast/files/snapcast-0.25.0-cxx17.patch     | 27 ++++++++++++++++++++++
 media-sound/snapcast/snapcast-0.25.0-r1.ebuild     |  5 +++-
 2 files changed, 31 insertions(+), 1 deletion(-)