Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808534 - app-office/libreoffice-7.1.3.2 invalid ‘static_cast’ from type ‘std::__cxx11::basic_ostringstream<char>’ to type ‘std::ostringstream&
Summary: app-office/libreoffice-7.1.3.2 invalid ‘static_cast’ from type ‘std::__cxx11:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard: fixed in 7.1.5.2
Keywords:
Depends on: 809131
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-08-16 01:39 UTC by peter@prh.myzen.co.uk
Modified: 2021-08-26 14:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=app-office/libreoffice-7.1.3.2::gentoo' (emerge.info,7.29 KB, text/plain)
2021-08-16 01:39 UTC, peter@prh.myzen.co.uk
Details
Build log (build.log.gz,402.18 KB, application/gzip)
2021-08-16 01:41 UTC, peter@prh.myzen.co.uk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter@prh.myzen.co.uk 2021-08-16 01:39:17 UTC
Created attachment 733177 [details]
emerge --info '=app-office/libreoffice-7.1.3.2::gentoo'

app-office/libreoffice-7.1.3.2 fails to compile on ~amd64, reporting "error: invalid ‘static_cast’ from type ‘std::__cxx11::basic_ostringstream<char>’ to type ‘std::ostringstream&’ {aka ‘std::__cxx11::basic_ostringstream<char>&’} "
Comment 1 Sam James archtester gentoo-dev Security 2021-08-16 01:40:56 UTC
Could you attach the full build.log? You may need to compress it.
Comment 2 peter@prh.myzen.co.uk 2021-08-16 01:41:47 UTC
Created attachment 733180 [details]
Build log
Comment 3 Sam James archtester gentoo-dev Security 2021-08-16 01:42:23 UTC
(In reply to peter@prh.myzen.co.uk from comment #2)
> Created attachment 733180 [details]
> Build log

Sorry for being impatient ;)
Comment 4 Sam James archtester gentoo-dev Security 2021-08-16 01:52:27 UTC
Oh, now I get it. You're running ~arch (hence GCC 11), but building stable LibreOffice. We can't yet guarantee all GCC 11 fixes have filtered down to stable.

This seems to be https://bugs.documentfoundation.org/show_bug.cgi?id=142326 upstream.

Can you please try the latest version in ~arch? (7.1.5.2)?
Comment 5 peter@prh.myzen.co.uk 2021-08-16 02:01:01 UTC
Ah, that makes sense. I'm compiling it now and I'll report when it's finished.
Comment 6 peter@prh.myzen.co.uk 2021-08-16 10:37:06 UTC
Version 7.1.5.2 compiled just fine.

Thanks for pointing out the cause of my problem.
Comment 7 Sam James archtester gentoo-dev Security 2021-08-16 23:55:11 UTC
(In reply to peter@prh.myzen.co.uk from comment #6)
> Version 7.1.5.2 compiled just fine.
> 
> Thanks for pointing out the cause of my problem.

Thank you for getting back to me!
Comment 8 Andreas Sturmlechner gentoo-dev 2021-08-17 06:57:29 UTC
shouldn't this block gcc-11 instead, then a LO-7.1.5.2 stable request block gcc-11-stable tracker?
Comment 9 Jack 2021-08-19 18:45:23 UTC
Just another confirmation.  I have a mostly stable amd64 system with some (~) packages.  With gcc-11.2.0, failure as noted with libreoffice 7.1.3.2, successful emerge for libreoffice-7.1.5.2.  Let me know if you want versions of any other packages.
Comment 10 Sam James archtester gentoo-dev Security 2021-08-19 18:57:40 UTC
(In reply to Andreas Sturmlechner from comment #8)
> shouldn't this block gcc-11 instead, then a LO-7.1.5.2 stable request block
> gcc-11-stable tracker?

Given that ~arch works, I've been using gcc-11-stable to collect thing that need stabilisation.