Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808053 - dev-util/bazel-1.2.1 - external/.../mapped_file_unix.cc: error: numeric_limits is not a member of std (maybe gcc-11 related)
Summary: dev-util/bazel-1.2.1 - external/.../mapped_file_unix.cc: error: numeric_limit...
Status: RESOLVED DUPLICATE of bug 787248
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-08-13 17:20 UTC by Toralf Förster
Modified: 2021-08-13 17:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.10 KB, text/plain)
2021-08-13 17:20 UTC, Toralf Förster
Details
dev-util:bazel-1.2.1:20210813-125459.log (dev-util:bazel-1.2.1:20210813-125459.log,153.73 KB, text/plain)
2021-08-13 17:20 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,171.41 KB, text/plain)
2021-08-13 17:20 UTC, Toralf Förster
Details
environment (environment,114.74 KB, text/plain)
2021-08-13 17:20 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,17.87 KB, application/x-bzip)
2021-08-13 17:20 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,11.37 KB, application/x-bzip)
2021-08-13 17:20 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-13 17:20:15 UTC
    Compiling external/bazel_tools/.../zlib/deflate.c [for host]; 0s local
external/bazel_tools/third_party/ijar/mapped_file_unix.cc: In constructor 'devtools_ijar::MappedOutputFile::MappedOutputFile(const char*, size_t)':
external/bazel_tools/third_party/ijar/mapped_file_unix.cc:115:21: error: 'numeric_limits' is not a member of 'std'
  115 |                std::numeric_limits<size_t>::max());
      |                     ^~~~~~~~~~~~~~
external/bazel_tools/third_party/ijar/mapped_file_unix.cc:115:42: error: expected primary-expression before '>' token
  115 |                std::numeric_limits<size_t>::max());

  -------------------------------------------------------------------

  This is an stable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_systemd-j3_stable-20210811-190454

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.53.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm


  HEAD of ::gentoo
commit 93d3e6da95da60d539d568c8cef95d1634733028
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Fri Aug 13 12:07:09 2021 +0000

    2021-08-13 12:07:08 UTC

emerge -qpvO dev-util/bazel
[ebuild  N    ] dev-util/bazel-1.2.1  USE="-examples -tools"
Comment 1 Toralf Förster gentoo-dev 2021-08-13 17:20:16 UTC
Created attachment 732661 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-13 17:20:18 UTC
Created attachment 732663 [details]
dev-util:bazel-1.2.1:20210813-125459.log
Comment 3 Toralf Förster gentoo-dev 2021-08-13 17:20:20 UTC
Created attachment 732665 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-08-13 17:20:21 UTC
Created attachment 732667 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-08-13 17:20:23 UTC
Created attachment 732669 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-13 17:20:24 UTC
Created attachment 732671 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2021-08-13 17:20:41 UTC

*** This bug has been marked as a duplicate of bug 787248 ***