Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 806342 - games-engines/box2d-2.4.1 - /.../doctest.h: error: size of array altStackMem is not an integral constant-expression
Summary: games-engines/box2d-2.4.1 - /.../doctest.h: error: size of array altStackMem ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL: https://github.com/erincatto/box2d/is...
Whiteboard:
Keywords:
Depends on: 816954 817434
Blocks: glibc-2.34
  Show dependency tree
 
Reported: 2021-08-04 08:33 UTC by Toralf Förster
Modified: 2021-10-11 00:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.99 KB, text/plain)
2021-08-04 08:33 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,341.55 KB, text/plain)
2021-08-04 08:33 UTC, Toralf Förster
Details
environment (environment,89.07 KB, text/plain)
2021-08-04 08:33 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,27.61 KB, application/x-bzip)
2021-08-04 08:33 UTC, Toralf Förster
Details
games-engines:box2d-2.4.1:20210803-203419.log (games-engines:box2d-2.4.1:20210803-203419.log,36.49 KB, text/plain)
2021-08-04 08:33 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,4.55 KB, application/x-bzip)
2021-08-04 08:33 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,24.18 KB, application/x-bzip)
2021-08-04 08:33 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-04 08:33:33 UTC
/usr/bin/x86_64-pc-linux-gnu-g++ -DB2_SHARED -I/var/tmp/portage/games-engines/box2d-2.4.1/work/box2d-2.4.1/src/../include  -pipe -march=native -fno-diagnostics-color -O2 -fvisibility=hidden -fvisibility-inlines-hidden -std=c++11 -MD -MT unit-test/CMakeFiles/unit_test.dir/hello_world.cpp.o -MF unit-test/CMakeFiles/unit_test.dir/hello_world.cpp.o.d -o unit-test/CMakeFiles/unit_test.dir/hello_world.cpp.o -c /var/tmp/portage/games-engines/box2d-2.4.1/work/box2d-2.4.1/unit-test/hello_world.cpp
In file included from /var/tmp/portage/games-engines/box2d-2.4.1/work/box2d-2.4.1/unit-test/hello_world.cpp:25:
/var/tmp/portage/games-engines/box2d-2.4.1/work/box2d-2.4.1/unit-test/doctest.h:4021:47: error: size of array ‘altStackMem’ is not an integral constant-expression
 4021 |         static char             altStackMem[4 * SIGSTKSZ];
      |                                               ^
ninja: build stopped: subcommand failed.
 * ERROR: games-engines/box2d-2.4.1::gentoo failed (compile phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no_multilib_systemd-j3-20210730-192258

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.53.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4
  (none found)

  HEAD of ::gentoo
commit 4866136d3d5ea4084e10b583d47348afefd45e76
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Tue Aug 3 20:06:36 2021 +0000

    2021-08-03 20:06:35 UTC

emerge -qpvO games-engines/box2d
[ebuild  N    ] games-engines/box2d-2.4.1  USE="-doc"
Comment 1 Toralf Förster gentoo-dev 2021-08-04 08:33:35 UTC
Created attachment 729950 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-04 08:33:36 UTC
Created attachment 729952 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-08-04 08:33:38 UTC
Created attachment 729954 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-08-04 08:33:39 UTC
Created attachment 729956 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-08-04 08:33:41 UTC
Created attachment 729958 [details]
games-engines:box2d-2.4.1:20210803-203419.log
Comment 6 Toralf Förster gentoo-dev 2021-08-04 08:33:42 UTC
Created attachment 729960 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2021-08-04 08:33:43 UTC
Created attachment 729962 [details]
temp.tar.bz2
Comment 8 FR 2021-08-28 14:26:33 UTC
This was fixed, or worked around, by adding "-DBOX2D_BUILD_UNIT_TESTS=OFF" to the src_configure() section of the box2d-2.4.1.ebuild file.

the problem is related to changes in glibc-2.34 and seems only to affect the unit test code.
Comment 9 Sam James archtester gentoo-dev Security 2021-09-05 03:02:00 UTC
(In reply to FR from comment #8)
> This was fixed, or worked around, by adding "-DBOX2D_BUILD_UNIT_TESTS=OFF"
> to the src_configure() section of the box2d-2.4.1.ebuild file.
> 
> the problem is related to changes in glibc-2.34 and seems only to affect the
> unit test code.

Thanks, let's include that workaround to speed up the build anyway.
Comment 10 Larry the Git Cow gentoo-dev 2021-09-05 05:48:32 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=adea094719995c15eb6642c5cc7691899972ad80

commit adea094719995c15eb6642c5cc7691899972ad80
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-09-05 03:02:11 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-09-05 05:24:44 +0000

    games-engines/box2d: conditionally build tests
    
    This is also a workaround for the glibc 2.34 build failure.
    
    Bug: https://bugs.gentoo.org/806342
    Signed-off-by: Sam James <sam@gentoo.org>

 games-engines/box2d/box2d-2.4.1.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
Comment 11 Larry the Git Cow gentoo-dev 2021-10-11 00:40:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e27625bafd1ff9d1e04b6e8b308638723531ee4c

commit e27625bafd1ff9d1e04b6e8b308638723531ee4c
Author:     Ionen Wolkens <ionen@gentoo.org>
AuthorDate: 2021-10-08 12:26:59 +0000
Commit:     Ionen Wolkens <ionen@gentoo.org>
CommitDate: 2021-10-11 00:39:12 +0000

    games-engines/box2d: unbundle doctest to fix tests with glibc-2.34
    
    Skipping leaving a bugref in the ebuild not to imply this should be
    removed after it's fixed with glibc-2.34 (upstream has bumped
    doctest in upcoming version, but may as well use system's anyway).
    
    While not the cleanest, use a symlink to avoid patching files.
    
    Closes: https://bugs.gentoo.org/806342
    Signed-off-by: Ionen Wolkens <ionen@gentoo.org>

 games-engines/box2d/box2d-2.4.1.ebuild | 9 +++++++++
 1 file changed, 9 insertions(+)