Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 806085 - media-sound/mixxx-2.2.4 - scons: *** [lib/.../moc_bytearrayclass.cc] TypeError _defines() missing 2 required positional arguments:
Summary: media-sound/mixxx-2.2.4 - scons: *** [lib/.../moc_bytearrayclass.cc] TypeErro...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
: 814491 (view as bug list)
Depends on: 809305
Blocks:
  Show dependency tree
 
Reported: 2021-08-01 19:24 UTC by Toralf Förster
Modified: 2022-05-17 17:33 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.37 KB, text/plain)
2021-08-01 19:24 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,236.08 KB, text/plain)
2021-08-01 19:24 UTC, Toralf Förster
Details
environment (environment,110.68 KB, text/plain)
2021-08-01 19:24 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,22.27 KB, application/x-bzip)
2021-08-01 19:24 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,5.52 KB, application/x-bzip)
2021-08-01 19:24 UTC, Toralf Förster
Details
media-sound:mixxx-2.2.4:20210801-191740.log (media-sound:mixxx-2.2.4:20210801-191740.log,23.51 KB, text/plain)
2021-08-01 19:24 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,30.56 KB, application/x-bzip)
2021-08-01 19:24 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-01 19:24:18 UTC
  242 |       double adj;
      |              ^~~
scons: *** [lib/qtscript-bytearray/moc_bytearrayclass.cc] TypeError `_defines() missing 2 required positional arguments: 'target' and 'source'' trying to evaluate `${_defines(QT5_MOCDEFPREFIX, CPPDEFINES, QT5_MOCDEFSUFFIX, __env__)}'
scons: building terminated because of errors.
 * ERROR: media-sound/mixxx-2.2.4::gentoo failed (compile phase):
 *   escons failed.
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j3-20210729-223822

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.53.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4
  (none found)

  HEAD of ::gentoo
commit f8d945e80b17fb744a85bdbb3fdcd3415fbf5557
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sun Aug 1 18:51:51 2021 +0000

    2021-08-01 18:51:50 UTC

emerge -qpvO media-sound/mixxx
[ebuild  N    ] media-sound/mixxx-2.2.4  USE="aac mp3 mp4 -doc -ffmpeg -hid -lv2 -opus -shout -wavpack"
Comment 1 Toralf Förster gentoo-dev 2021-08-01 19:24:20 UTC
Created attachment 729465 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-01 19:24:21 UTC
Created attachment 729468 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-08-01 19:24:23 UTC
Created attachment 729471 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-08-01 19:24:24 UTC
Created attachment 729474 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-08-01 19:24:27 UTC
Created attachment 729477 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-01 19:24:28 UTC
Created attachment 729480 [details]
media-sound:mixxx-2.2.4:20210801-191740.log
Comment 7 Toralf Förster gentoo-dev 2021-08-01 19:24:29 UTC
Created attachment 729483 [details]
temp.tar.bz2
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-01 19:39:10 UTC
Likely a duplicate. Should be fixed now.

*** This bug has been marked as a duplicate of bug 806043 ***
Comment 9 Toralf Förster gentoo-dev 2021-08-01 20:23:46 UTC
happened with latest scons
Comment 10 Anton Gubarkov 2021-08-26 12:59:29 UTC
The build of mixxx-2.2.4-r1 still fails for me. I do have the updated scons as per #806043.
Comment 11 Anton Gubarkov 2021-08-30 18:49:34 UTC
Not sure someone reading this... I feel reluctant to create another duplicate of this bug report... 

I experience exactly the same behaviour building mixxx and I don't see how https://bugs.gentoo.org/show_bug.cgi?id=806043 is related to what I see...
Comment 12 Rémi Cardona (RETIRED) gentoo-dev 2021-09-24 18:51:36 UTC
*** Bug 814491 has been marked as a duplicate of this bug. ***
Comment 13 Rémi Cardona (RETIRED) gentoo-dev 2021-09-25 12:19:20 UTC
Hit this too. I tried googling around but came up empty handed. I really don't know what's going on: is Qt complaining? scons is? Any help, pointers or anything would be greatly appreciated to try to figure this out.

Cheers
Comment 14 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-10-03 00:53:10 UTC
(In reply to Rémi Cardona from comment #13)
> Hit this too. I tried googling around but came up empty handed. I really
> don't know what's going on: is Qt complaining? scons is? Any help, pointers
> or anything would be greatly appreciated to try to figure this out.
> 
> Cheers

Seems to be Scons to me, but it looks like they've completely ditched it upstream. Someone's made a PR for the new version: https://github.com/gentoo/gentoo/pull/22402.
Comment 15 Adrien D 2021-10-11 19:32:03 UTC
Mixxx 2.2.4 can compile if downgrade scons to 4.1.0-r1


emerge =dev-util/scons-4.1.0-r1
emerge media-sound/mixxx

And now it's okay
Comment 16 Timo Ollech 2021-10-13 22:27:17 UTC
(In reply to Sam James from comment #14)
> 
> Seems to be Scons to me, but it looks like they've completely ditched it
> upstream.

Indeed they say so: "Add CMake build system with ccache and sccache support for faster compilation times and remove SCons #2280 #3618" https://manual.mixxx.org/2.3/en/chapters/appendix/changelog.html#other

Latest release upstream is 2.3.1 btw: https://mixxx.org/news/2021-09-30-mixxx-2-3-1-released/
Comment 17 Timo Ollech 2021-10-13 22:31:35 UTC
version bump to 2.3.1 is in bug 809305
Comment 18 Larry the Git Cow gentoo-dev 2021-10-14 09:13:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f8ed35f55c54975905d50c213837bfa6559e810c

commit f8ed35f55c54975905d50c213837bfa6559e810c
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-14 09:13:23 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-14 09:13:33 +0000

    media-sound/mixxx: depend on older scons
    
    A PR is pending for the CMake port.
    
    Bug: https://bugs.gentoo.org/806085
    Signed-off-by: Sam James <sam@gentoo.org>

 media-sound/mixxx/mixxx-2.2.4-r1.ebuild | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6342804cddb5845db79f752a74f262ffd6f74cc7

commit 6342804cddb5845db79f752a74f262ffd6f74cc7
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-14 09:11:41 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-14 09:11:41 +0000

    dev-util/scons: Revert "Remove old" (restore 4.1.0 for now)
    
    This reverts commit cfaacfcffc6895ebe3d021acedf2d71de76f7dc8.
    
    Restore 4.1.0 for now because Mixxx can't build without it.
    
    Bug: https://bugs.gentoo.org/806085
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/scons/Manifest                            |  4 +
 .../files/scons-4.0.0-respect-cc-etc-r1.patch      | 88 +++++++++++++++++++
 dev-util/scons/scons-4.1.0-r1.ebuild               | 98 ++++++++++++++++++++++
 3 files changed, 190 insertions(+)
Comment 19 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-22 01:17:25 UTC
Fixed by 2.3.x which ports to CMake.
Comment 20 jospezial 2022-05-17 11:43:10 UTC
The last scons ebuilds of mixxx are gone now from the tree.
The cmake based ebuilds don't have this bug.

Please close as obsolete.