Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 805914 - >=sys-auth/yubico-piv-tool-2.2.0-r1 - /.../core_dispatch.h: error: expected expression before ) token
Summary: >=sys-auth/yubico-piv-tool-2.2.0-r1 - /.../core_dispatch.h: error: expected e...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Marek Szuba
URL: https://github.com/Yubico/yubico-piv-...
Whiteboard:
Keywords:
: 812284 (view as bug list)
Depends on:
Blocks: openssl-3.0
  Show dependency tree
 
Reported: 2021-08-01 09:09 UTC by Toralf Förster
Modified: 2021-11-15 19:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.26 KB, text/plain)
2021-08-01 09:09 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,183.38 KB, text/plain)
2021-08-01 09:09 UTC, Toralf Förster
Details
environment (environment,88.58 KB, text/plain)
2021-08-01 09:09 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,16.51 KB, application/x-bzip)
2021-08-01 09:09 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,4.97 KB, application/x-bzip)
2021-08-01 09:09 UTC, Toralf Förster
Details
sys-auth:yubico-piv-tool-2.2.0-r1:20210801-085259.log.bz2 (sys-auth:yubico-piv-tool-2.2.0-r1:20210801-085259.log.bz2,211.67 KB, application/x-bzip)
2021-08-01 09:10 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,233.89 KB, application/x-bzip)
2021-08-01 09:10 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-01 09:09:52 UTC
      | ^~~~~~~~~~~~~~~~~~~
/usr/include/openssl/core_dispatch.h:67:1: note: each undeclared identifier is reported only once for each function it appears in
/usr/include/openssl/core_dispatch.h:67:1: error: expected expression before ‘)’ token
   67 | OSSL_CORE_MAKE_FUNC(int,core_get_params,(const OSSL_CORE_HANDLE *prov,
      | ^~~~~~~~~~~~~~~~~~~
/usr/include/openssl/core_dispatch.h: At top level:
/usr/include/openssl/core_dispatch.h:70:1: error: unknown type name ‘OSSL_DISPATCH’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no_multilib-j3-20210730-195527

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.53.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  HEAD of ::gentoo
commit 37b6b25817c3493975a8a946f856737fe695030c
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sun Aug 1 07:51:35 2021 +0000

    2021-08-01 07:51:33 UTC

emerge -qpvO sys-auth/yubico-piv-tool
[ebuild  N    ] sys-auth/yubico-piv-tool-2.2.0-r1  USE="-test"
Comment 1 Toralf Förster gentoo-dev 2021-08-01 09:09:53 UTC
Created attachment 729102 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-01 09:09:55 UTC
Created attachment 729105 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-08-01 09:09:56 UTC
Created attachment 729108 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-08-01 09:09:58 UTC
Created attachment 729111 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-08-01 09:09:58 UTC
Created attachment 729114 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-08-01 09:10:00 UTC
Created attachment 729117 [details]
sys-auth:yubico-piv-tool-2.2.0-r1:20210801-085259.log.bz2
Comment 7 Toralf Förster gentoo-dev 2021-08-01 09:10:02 UTC
Created attachment 729120 [details]
temp.tar.bz2
Comment 8 Larry the Git Cow gentoo-dev 2021-08-01 16:54:56 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8536175c55b3efadc919e496918c8d8ef8ee7ac9

commit 8536175c55b3efadc919e496918c8d8ef8ee7ac9
Author:     Marek Szuba <marecki@gentoo.org>
AuthorDate: 2021-08-01 16:42:20 +0000
Commit:     Marek Szuba <marecki@gentoo.org>
CommitDate: 2021-08-01 16:54:51 +0000

    sys-auth/yubico-piv-tool: block OpenSSL-3
    
    Bug: https://bugs.gentoo.org/805914
    Signed-off-by: Marek Szuba <marecki@gentoo.org>

 sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.0-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 Larry the Git Cow gentoo-dev 2021-09-09 15:16:20 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=05f4d5714b8b5835fd8d76f821c6fc953966cce3

commit 05f4d5714b8b5835fd8d76f821c6fc953966cce3
Author:     Marek Szuba <marecki@gentoo.org>
AuthorDate: 2021-09-09 15:13:33 +0000
Commit:     Marek Szuba <marecki@gentoo.org>
CommitDate: 2021-09-09 15:16:13 +0000

    sys-auth/yubico-piv-tool: fix OpenSSL-3 blocking
    
    3.0.0_betaX does in fact match <dev-libs/openssl-3.0.0 so require
    <2.99.99 instead.
    
    Bug: https://bugs.gentoo.org/805914
    Signed-off-by: Marek Szuba <marecki@gentoo.org>

 sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.0-r1.ebuild | 2 +-
 sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild    | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 10 Marek Szuba (RETIRED) archtester gentoo-dev 2021-09-09 15:17:15 UTC
*** Bug 812284 has been marked as a duplicate of this bug. ***
Comment 11 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-09-09 22:52:59 UTC
Reopening because this doesn't fix the core issue; it's incompatible with OpenSSL 3.
Comment 12 Larry the Git Cow gentoo-dev 2021-11-15 19:32:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9fa3fb2c429652631b76f18ee3feec3b9c068b04

commit 9fa3fb2c429652631b76f18ee3feec3b9c068b04
Author:     Marek Szuba <marecki@gentoo.org>
AuthorDate: 2021-11-15 19:29:53 +0000
Commit:     Marek Szuba <marecki@gentoo.org>
CommitDate: 2021-11-15 19:29:53 +0000

    sys-auth/yubico-piv-tool-2.2.1: support openssl-3.0
    
    Backported upstream fix, i.e. should no longer be needed come next
    release.
    
    Closes: https://bugs.gentoo.org/805914
    Signed-off-by: Marek Szuba <marecki@gentoo.org>

 .../files/yubico-piv-tool-2.2.1-openssl3.patch     | 32 ++++++++++++++++++++++
 .../yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild   |  1 +
 2 files changed, 33 insertions(+)