Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 804957 - media-plugins/gst-plugins-jack-1.18.4 Invalid version of dependency, need 'jack' ['>= 1.9.7'] found '0.125.0'.
Summary: media-plugins/gst-plugins-jack-1.18.4 Invalid version of dependency, need 'ja...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 2 votes (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: 812836
  Show dependency tree
 
Reported: 2021-07-29 07:28 UTC by Michal Jakubowski
Modified: 2021-09-15 01:30 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,14.89 KB, text/x-log)
2021-07-29 07:32 UTC, Michal Jakubowski
Details
gst-plugins-jack-1.18.4-r1.ebuild (gst-plugins-jack-1.18.4-r1.ebuild,371 bytes, text/plain)
2021-07-30 07:15 UTC, Michal Jakubowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Jakubowski 2021-07-29 07:28:32 UTC
Dependency gtk+-3.0 skipped: feature gtk3 disabled
Dependency jack found: NO found 0.125.0 but need: '>= 1.9.7'
Found CMake: /usr/bin/cmake (3.21.1)
Run-time dependency jack found: NO 

../gst-plugins-good-1.18.4/ext/jack/meson.build:9:0: ERROR: Invalid version of dependency, need 'jack' ['>= 1.9.7'] found '0.125.0'.

Reproducible: Always
Comment 1 Michal Jakubowski 2021-07-29 07:29:31 UTC
media-sound/jack-audio-connection-kit:0 ("media-sound/jack-audio-connection-kit:0" is blocking media-sound/jack2-1.9.19)
Comment 2 Michal Jakubowski 2021-07-29 07:32:35 UTC
Created attachment 727590 [details]
build.log
Comment 3 Michal Jakubowski 2021-07-30 07:15:14 UTC
Created attachment 728175 [details]
gst-plugins-jack-1.18.4-r1.ebuild

FIX
Comment 4 Niklāvs Koļesņikovs 2021-07-31 07:47:05 UTC
The fix is not entirely correct because that would omit very likely compatible media-video/pipewire[jack-sdk] (which I have also brought up in the PR). Additionally Gentoo currently seems to prefer to fix the build system to accept JACK1, provided that it builds fine against it (and all currently known projects do). Not that I think it's good to keep dragging around JACK1 but that's beyond this bug report.
Comment 5 Larry the Git Cow gentoo-dev 2021-09-14 05:45:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ccbddc6f17df999384f731b842d225132a2c37de

commit ccbddc6f17df999384f731b842d225132a2c37de
Author:     Haelwenn (lanodan) Monnier <contact@hacktivis.me>
AuthorDate: 2021-07-31 06:48:08 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-09-14 05:44:55 +0000

    media-plugins/gst-plugins-jack: Fix jack2 dependency
    
    Closes: https://bugs.gentoo.org/804957
    Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
    Closes: https://github.com/gentoo/gentoo/pull/21843
    Signed-off-by: Sam James <sam@gentoo.org>

 ...ugins-jack-1.18.4.ebuild => gst-plugins-jack-1.18.4-r1.ebuild} | 8 ++++++--
 media-plugins/gst-plugins-meta/gst-plugins-meta-1.18.4.ebuild     | 2 +-
 2 files changed, 7 insertions(+), 3 deletions(-)
Comment 6 Sam James archtester gentoo-dev Security 2021-09-14 06:31:13 UTC
Rekeywording in bug 807616.