Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 802618 - dev-python/sphinx_rtd_theme: needs <dev-python/docutils-0.17
Summary: dev-python/sphinx_rtd_theme: needs <dev-python/docutils-0.17
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on: 829788
Blocks: 722500
  Show dependency tree
 
Reported: 2021-07-17 16:12 UTC by Davyd McColl
Modified: 2022-05-06 09:15 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davyd McColl 2021-07-17 16:12:14 UTC
when attempting to do a world update (emerge --sync && emerge --update --newuse --changed-use --deep --changed-deps --keep-going @world -a), I get the following at the end of the list of packages which are to be updated:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/docutils:0

  (dev-python/docutils-0.17.1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8" conflicts with
    <dev-python/docutils-0.17[python_targets_python3_9(-)] required by (dev-python/sphinx_rtd_theme-0.5.2:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"


If I'm reading this correctly, this is saying that an update to docutils (to 0.17.1) cannot be performed becausesphinx_rtd_theme requires exactly 0.17 of docutils; however there's no other version of sphinx_rtd_theme available (again, from my understanding):

Keywords for dev-python/sphinx_rtd_theme:
         |                             |   u   |  
         | a   a     p s   a   r       |   n   |  
         | m   r h   p p   l i i m m s | e u s | r
         | d a m p p c a x p a s 6 i 3 | a s l | e
         | 6 r 6 p p 6 r 8 h 6 c 8 p 9 | p e o | p
         | 4 m 4 a c 4 c 6 a 4 v k s 0 | i d t | o
---------+-----------------------------+-------+-------
[I]0.5.2 | + + + + + + + + ~ ~ ~ o o ~ | 7 o 0 | gentoo


I saw this about a week ago and figured it would get sorted out, but hasn't when I've gone for a system update again today. Just wanted to bring it up so that someone with better ebuild fu than me could have a look.

Thanks.

Reproducible: Always

Steps to Reproduce:
1. emerge --sync
2. emerge --update --newuse --changed-use --deep --changed-deps --keep-going @world -a
3. see the warning
Actual Results:  
warning of package not being updated: dev-python/docutils

Expected Results:  
would expect that the only version of sphinx_rtd_theme would upgrade with docutils, or allow the minor version update.

> emerge --info
Portage 3.0.20 (python 3.9.5-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-10.3.0, glibc-2.33-r1, 5.10.27-gentoo-x86_64 x86_64)
=================================================================
System uname: Linux-5.10.27-gentoo-x86_64-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-glibc2.33
KiB Mem:    16346220 total,   3370048 free
KiB Swap:    6428500 total,   5421652 free
Timestamp of repository gentoo: Sat, 17 Jul 2021 15:30:01 +0000
Head commit of repository gentoo: 64075c2dd744f47bba6f90ab2a97e4a446aff000
Head commit of repository dotnet: 6e75dacad0e99680e84049b1c7f6b40887cc8e29

Head commit of repository jorgicio: f9f8a100251b5185c6feda6b6257ebb03f3258ed

Head commit of repository bobwya: 8b7a852ebf23a584dce704d02e458ebe868d4910

Timestamp of repository cg: Sat, 17 Jul 2021 08:07:12 +0000
Head commit of repository cg: 0d88a2cacea109e1abb9ca493875e12e75ce9cb0

Head commit of repository flatpak-overlay: 4bf9a7815ca9361f86459c8a8e9bc403e3721704

Timestamp of repository guru: Sat, 17 Jul 2021 08:07:23 +0000
Head commit of repository guru: cdeb611fc798f8cf43d0125f6c74e4e2c7c0d324

Timestamp of repository slyfox: Sat, 10 Jul 2021 21:52:35 +0000
Head commit of repository slyfox: 5c8dd3c1bb12ef8c7530517cbb0d2bd858cba8ee

Head commit of repository steam-overlay: c93a9167c9251ceceb6e7ee35cdf636cb59be6f4

sh bash 5.1_p8
ld GNU ld (Gentoo 2.35.2 p1) 2.35.2
ccache version 4.3 [enabled]
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          3.9.5_p2::gentoo
dev-lang/rust-bin:        1.52.1::gentoo
dev-util/ccache:          4.3::gentoo
dev-util/cmake:           3.18.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.35.2::gentoo
sys-devel/gcc:            10.3.0-r1::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

dotnet
    location: /var/db/repos/dotnet
    sync-type: git
    sync-uri: https://github.com/gentoo/dotnet.git
    masters: gentoo

jorgicio
    location: /var/db/repos/jorgicio
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/jorgicio.git
    masters: gentoo

bobwya
    location: /var/db/repos/bobwya
    sync-type: git
    sync-uri: https://github.com/bobwya/bobwya.git
    masters: gentoo
    priority: 50

cg
    location: /var/db/repos/cg
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/cg.git
    masters: gentoo
    priority: 50

flatpak-overlay
    location: /var/db/repos/flatpak
    sync-type: git
    sync-uri: https://github.com/fosero/flatpak-overlay
    masters: gentoo
    priority: 50

guru
    location: /var/db/repos/guru
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/guru.git
    masters: gentoo
    priority: 50

slyfox
    location: /var/db/repos/slyfox
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/slyfox.git
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/db/repos/steam-overlay
    sync-type: git
    sync-uri: git://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.8/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ rsync://ftp-stud.hs-esslingen.de/gentoo/"
LANG="en_US.utf8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus declarative dri dts dvd dvdr elogind emboss encode exif flac fortran gdbm gif gpm gtk gui iconv icu ipv6 jpeg kde kipi kwallet lcms libglvnd libnotify libtirpc mad mng mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt5 readline sdl seccomp semantic-desktop spell split-usr ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="radeonsi amdgpu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-07-17 16:17:38 UTC
Yeah, you're reading it right. This isn't a problem _per se_ for now, we need to wait for a new version of docutils to come out, but if they take a while, we'll need to patch it or similar.

It can be safely ignored for the time being.
Comment 2 Davyd McColl 2021-07-17 16:20:57 UTC
(In reply to Sam James from comment #1)
> Yeah, you're reading it right. This isn't a problem _per se_ for now, we
> need to wait for a new version of docutils to come out, but if they take a
> while, we'll need to patch it or similar.
> 
> It can be safely ignored for the time being.

Thanks for getting back on this (:
Comment 3 Davyd McColl 2021-07-26 06:16:56 UTC
I should have asked earlier, but where should I report this upstream to get the ball rolling there?
Comment 4 Louis Sautier (sbraz) gentoo-dev 2021-07-31 16:02:34 UTC
(In reply to Davyd McColl from comment #3)
> I should have asked earlier, but where should I report this upstream to get
> the ball rolling there?

Hi, it has already been reported here: https://github.com/readthedocs/sphinx_rtd_theme/issues/1115
Comment 5 Stas 2021-12-23 10:21:12 UTC
A few days ago I ran into a similar error, but for "dev-python / documenttils-0.18" the error looks like this:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/docutils:0

  (dev-python/docutils-0.18:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8" conflicts with
    <dev-python/docutils-0.18[python_targets_python3_9(-)] required by (dev-python/sphinx_rtd_theme-1.0.0:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
    ^                    ^^^^                             
    <dev-python/docutils-0.18[python_targets_python3_9(-)] required by (dev-python/sphinx-4.3.1:0/0::gentoo, installed) USE="-doc -latex -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
    ^                    ^^^^                             
Nothing to merge; quitting.

I tried different solutions to this problem, but only masking the "dev-python / documenttils-0.18" package helped!
Comment 6 Stas 2021-12-23 10:24:43 UTC
(In reply to Stas from comment #5)
> A few days ago I ran into a similar error, but for "dev-python /
> documenttils-0.18" the error looks like this:
> 
> WARNING: One or more updates/rebuilds have been skipped due to a dependency
> conflict:
> 
> dev-python/docutils:0
> 
>   (dev-python/docutils-0.18:0/0::gentoo, ebuild scheduled for merge) USE=""
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
> conflicts with
>     <dev-python/docutils-0.18[python_targets_python3_9(-)] required by
> (dev-python/sphinx_rtd_theme-1.0.0:0/0::gentoo, installed) USE="-test"
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
>     ^                    ^^^^                             
>     <dev-python/docutils-0.18[python_targets_python3_9(-)] required by
> (dev-python/sphinx-4.3.1:0/0::gentoo, installed) USE="-doc -latex -test"
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
>     ^                    ^^^^                             
> Nothing to merge; quitting.
> 
> I tried different solutions to this problem, but only masking the
> "dev-python / documenttils-0.18" package helped!

echo '=dev-python/docutils-0.18' > /etc/portage/package.mask/docutils
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-12-23 10:25:32 UTC
(In reply to Stas from comment #5)
> A few days ago I ran into a similar error, but for "dev-python /
> documenttils-0.18" the error looks like this:
> 
> WARNING: One or more updates/rebuilds have been skipped due to a dependency
> conflict:
> 
> dev-python/docutils:0
> 
>   (dev-python/docutils-0.18:0/0::gentoo, ebuild scheduled for merge) USE=""
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
> conflicts with
>     <dev-python/docutils-0.18[python_targets_python3_9(-)] required by
> (dev-python/sphinx_rtd_theme-1.0.0:0/0::gentoo, installed) USE="-test"
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
>     ^                    ^^^^                             
>     <dev-python/docutils-0.18[python_targets_python3_9(-)] required by
> (dev-python/sphinx-4.3.1:0/0::gentoo, installed) USE="-doc -latex -test"
> ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
>     ^                    ^^^^                             
> Nothing to merge; quitting.
> 
> I tried different solutions to this problem, but only masking the
> "dev-python / documenttils-0.18" package helped!

It's a warning/informative message. All masking will do is cause issues in future when that package is actually needed.
Comment 8 Stas 2021-12-23 10:35:08 UTC
(In reply to Sam James from comment #7)
> (В ответ Стасу из комментария №5 ) 
>  > Несколько дней назад я столкнулся с аналогичной ошибкой, но для
> "dev-python / 
>  > documenttils-0.18 "ошибка выглядит так: 
>  >  
>  > ВНИМАНИЕ: одно или несколько обновлений / перестроек были пропущены из-за
> зависимости 
>  > конфликт: 
>  >  
>  > dev-python / документация: 0 
>  >  
>  > (dev-python / documenttils-0.18: 0/0 :: gentoo, ebuild запланирован для
> слияния) USE = "" 
>  > ABI_X86 = "(64)" PYTHON_TARGETS = "python3_9 (-pypy3) (-python3_10)
> -python3_8" 
>  > конфликтует с 
>  > <dev-python / documenttils-0.18 [python_targets_python3_9 (-)] требуется 
>  > (dev-python / sphinx_rtd_theme-1.0.0: 0/0 :: gentoo, установлен) USE = "-
> test" 
>  > ABI_X86 = "(64)" PYTHON_TARGETS = "python3_9 (-pypy3) (-python3_10)
> -python3_8" 
>  > ^ ^^^^                              
>  > <dev-python / documenttils-0.18 [python_targets_python3_9 (-)] требуется 
>  > (dev-python / sphinx-4.3.1: 0/0 :: gentoo, установлен) USE = "- doc
> -latex -test" 
>  > ABI_X86 = "(64)" PYTHON_TARGETS = "python3_9 (-pypy3) (-python3_10)
> -python3_8" 
>  > ^ ^^^^                              
>  > Нечего сливать; бросить. 
>  >  
>  > Я пробовал разные решения этой проблемы, но только замаскировал 
>  > Пакет "dev-python / documenttils-0.18" помог! Это предупреждающее /
> информативное сообщение.  Все, что связано с маскированием, это вызовет
> проблемы в будущем, когда этот пакет действительно понадобится.

In the future I will think about what to do .... but for now, so.
Comment 9 Pietro 2021-12-25 17:10:09 UTC
I am also hitting this annoying warning message, and I totally agree that masking it might complicate things later on when the package is needed.

Merry Christmas :)

>>>
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/docutils:0

  (dev-python/docutils-0.18:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8" conflicts with
    <dev-python/docutils-0.18[python_targets_python3_9(-)] required by (dev-python/sphinx-4.3.1:0/0::gentoo, installed) USE="-doc -latex -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
    ^                    ^^^^                             
    <dev-python/docutils-0.18[python_targets_python3_9(-)] required by (dev-python/sphinx_rtd_theme-1.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) (-python3_10) -python3_8"
<<<
Comment 10 Pietro 2021-12-27 10:20:28 UTC
I must have done something to the local use flags because the warning is now gone...
Comment 11 Manfred Knick 2021-12-27 10:38:29 UTC
HINT:

In my case, I detected app-emulation/qemu having "doc" enabled by default:

. . . . . IUSE="... +doc"

Disabling this via a "-doc" entry in /etc/portage/package.use,
the one and only culprit pulling dev-python/docutils had been eradicated.

HTH


P.S.: Created Bug 830088
Comment 12 Norman Rieß 2021-12-27 11:31:15 UTC
(In reply to Manfred Knick from comment #11)

> Disabling this via a "-doc" entry in /etc/portage/package.use,
> the one and only culprit pulling dev-python/docutils had been eradicated.

Confirmed. Thanks!
Comment 13 Pietro 2021-12-27 12:36:58 UTC
(In reply to Manfred Knick from comment #11)
> HINT:
> 
> In my case, I detected app-emulation/qemu having "doc" enabled by default:
> 
> . . . . . IUSE="... +doc"
> 
> Disabling this via a "-doc" entry in /etc/portage/package.use,
> the one and only culprit pulling dev-python/docutils had been eradicated.
> 
> HTH
> 
> 
> P.S.: Created Bug 830088

(In reply to Pietro from comment #10)
> I must have done something to the local use flags because the warning is now
> gone...

By the looks of it I added -doc to the global USE. That must have done the trick.
Comment 14 Manfred Knick 2021-12-27 17:54:04 UTC
(In reply to Pietro from comment #13)
> ... I added -doc to the global USE.
> That must have done the trick.
Hmm - 
yes, sure, your sledgehammer will work instantaneously for that current goal,
but keep in mind that it might obfuscate later findings.
Personally, I prefer a scalpel wherever possible    ;-)
Kind regards!
Comment 15 Davyd McColl 2022-02-03 13:44:22 UTC
Has there been any movement on this? The (rather drastic, imo) action of disabling docs system-wide doesn't seem like a legitimate fix. Is there any reason sphinx_rtd_theme can't just be bumped up to depend on docutils 0.17.1?
Comment 16 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-03 13:50:04 UTC
(In reply to Davyd McColl from comment #15)
> Has there been any movement on this? The (rather drastic, imo) action of
> disabling docs system-wide doesn't seem like a legitimate fix. Is there any
> reason sphinx_rtd_theme can't just be bumped up to depend on docutils 0.17.1?

As per the links above, it literally doesn't work with newer docutils. The dependency is correct. We just have to wait for newer sphinx_rtd_* to be released whith works with newer docutils.

There's no need to disable docs system wide. Just ignore the _warning_ (it's not an error).