Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 80207 - xorg-x11-6.7.0-r3 will not compile on ppc64
Summary: xorg-x11-6.7.0-r3 will not compile on ppc64
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC64 Linux
: High major (vote)
Assignee: ppc64 architecture team
URL:
Whiteboard:
Keywords:
: 80212 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-31 06:38 UTC by Tim Ellis
Modified: 2005-02-19 07:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Ellis 2005-01-31 06:38:56 UTC
When I emerge xorg it breaks on my G5. I made sure the box was fully updated before emerging. This is the only "stable" ebuild for ppc64 and it doesn't work! Doh!

Reproducible: Always
Steps to Reproduce:
1. Type emerge xorg-x11
2. Wait ages...
3. It breaks!

Actual Results:  
In file included from /usr/include/asm/atomic.h:16,
                 from /usr/include/asm/processor.h:16,
                 from /usr/include/linux/prefetch.h:15,
                 from /usr/include/linux/list.h:5,
                 from /usr/include/linux/wait.h:12,
                 from /usr/include/linux/keyboard.h:4,
                 from lnx_KbdMap.c:108:
/usr/include/asm/memory.h:26:30: macro "eieio" passed 1 arguments, but takes just 0
In file included from /usr/include/asm/atomic.h:16,
                 from /usr/include/asm/processor.h:16,
                 from /usr/include/linux/prefetch.h:15,
                 from /usr/include/linux/list.h:5,
                 from /usr/include/linux/wait.h:12,
                 from /usr/include/linux/keyboard.h:4,
                 from lnx_KbdMap.c:108:
/usr/include/asm/memory.h:27: error: syntax error before '{' token
make[7]: *** [lnx_KbdMap.o] Error 1
make[7]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc/programs/Xserver/hw/
xfree86/os-support/linux'
make[6]: *** [linux] Error 2
make[6]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc/programs/Xserver/hw/
xfree86/os-support'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc/programs/Xserver/hw/
xfree86'
make[4]: *** [hw/xfree86] Error 2
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc/programs/Xserver'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.7.0-r3/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.7.0-r3 failed.
!!! Function src_compile, Line 581, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-31 07:59:49 UTC
*** Bug 80212 has been marked as a duplicate of this bug. ***
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-31 08:20:06 UTC
Can you try 6.8.0-r4 or greater please? They've got a fix that doesn't exist in -r3.
Comment 3 Tim Ellis 2005-01-31 08:35:27 UTC
I have, it works... this build needs marking ~ppc64 though at least :)
Comment 4 Markus Rothe (RETIRED) gentoo-dev 2005-01-31 11:26:30 UTC
damn.. this should have been fixed in bug #66223.

I'll check what I can do.
Comment 5 Markus Rothe (RETIRED) gentoo-dev 2005-02-14 05:15:07 UTC
here is my plan: leave 6.7.0-r3 as it is and mark 6.8.2 stable as soon as it is
tested enough.

Markus
Comment 6 Markus Rothe (RETIRED) gentoo-dev 2005-02-19 07:54:57 UTC
xorg-x11-6.8.2 is now stable on ppc64! this should work like a charm!
Comment 7 Markus Rothe (RETIRED) gentoo-dev 2005-02-19 07:55:06 UTC
closing