Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 801454 - sys-power/nut-2.7.4-r7 - nutclient.h: error: ISO C++17 does not allow dynamic exception specifications (maybe gcc-11 related)
Summary: sys-power/nut-2.7.4-r7 - nutclient.h: error: ISO C++17 does not allow dynamic...
Status: RESOLVED DUPLICATE of bug 786702
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-07-10 08:24 UTC by Toralf Förster
Modified: 2021-08-04 19:32 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.00 KB, text/plain)
2021-07-10 08:24 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,101.80 KB, text/plain)
2021-07-10 08:24 UTC, Toralf Förster
Details
environment (environment,113.17 KB, text/plain)
2021-07-10 08:24 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,13.98 KB, application/x-bzip)
2021-07-10 08:24 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,16.62 KB, application/x-bzip)
2021-07-10 08:24 UTC, Toralf Förster
Details
sys-power:nut-2.7.4-r7:20210710-034858.log (sys-power:nut-2.7.4-r7:20210710-034858.log,65.77 KB, text/plain)
2021-07-10 08:24 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,36.88 KB, application/x-bzip)
2021-07-10 08:24 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-07-10 08:24:00 UTC
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -I../include   -pipe -march=native -fno-diagnostics-color -O2  -fno-lto -Wall -Wsign-compare  -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -Wl,--defsym=__gentoo_check_ldflags__=0 -o upssched upssched.o ../common/libcommon.la ../common/libparseconf.la  -lpthread 
In file included from nutclient.cpp:20:
nutclient.h:135:86: error: ISO C++17 does not allow dynamic exception specifications
  135 | enticate(const std::string& user, const std::string& passwd)throw(NutException)=0;
      |                                                             ^~~~~

nutclient.h:141:30: error: ISO C++17 does not allow dynamic exception specifications

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_developer-j3_abi32+64-20210708-145748

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.53.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4
  HEAD of ::gentoo
commit 0dd37694f4291b067ffaae49e134011a658ea695
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sat Jul 10 02:37:03 2021 +0000

    2021-07-10 02:37:02 UTC

emerge -qpvO sys-power/nut
[ebuild  N    ] sys-power/nut-2.7.4-r7  USE="snmp (split-usr) ssl tcpd ups_drivers_al175 ups_drivers_apcsmart ups_drivers_apcsmart-old ups_drivers_apcupsd-ups ups_drivers_bcmxcp ups_drivers_bcmxcp_usb ups_drivers_belkin ups_drivers_belkinunv ups_drivers_bestfcom ups_drivers_bestfortress ups_drivers_bestuferrups ups_drivers_bestups ups_drivers_blazer_ser ups_drivers_blazer_usb ups_drivers_clone ups_drivers_clone-outlet ups_drivers_dummy-ups ups_drivers_etapro ups_drivers_everups ups_drivers_gamatronic ups_drivers_genericups ups_drivers_isbmex ups_drivers_ivtscd ups_drivers_liebert ups_drivers_liebert-esp2 ups_drivers_masterguard ups_drivers_metasys ups_drivers_mge-shut ups_drivers_mge-utalk ups_drivers_microdowell ups_drivers_nutdrv_qx ups_drivers_oldmge-shut ups_drivers_oneac ups_drivers_optiups ups_drivers_powercom ups_drivers_powerpanel ups_drivers_rhino ups_drivers_richcomm_usb ups_drivers_riello_ser ups_drivers_riello_usb ups_drivers_safenet ups_drivers_solis ups_drivers_tripplite ups_drivers_tripplite_usb ups_drivers_tripplitesu ups_drivers_upscode2 ups_drivers_usbhid-ups ups_drivers_victronups usb xml zeroconf -cgi -ipmi (-selinux) -ups_drivers_netxml-ups -ups_drivers_nut-ipmipsu -ups_drivers_snmp-ups"
Comment 1 Toralf Förster gentoo-dev 2021-07-10 08:24:02 UTC
Created attachment 723109 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-07-10 08:24:03 UTC
Created attachment 723112 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-07-10 08:24:05 UTC
Created attachment 723115 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-07-10 08:24:06 UTC
Created attachment 723118 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-07-10 08:24:07 UTC
Created attachment 723121 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-07-10 08:24:08 UTC
Created attachment 723124 [details]
sys-power:nut-2.7.4-r7:20210710-034858.log
Comment 7 Toralf Förster gentoo-dev 2021-07-10 08:24:10 UTC
Created attachment 723127 [details]
temp.tar.bz2
Comment 8 Jérôme Borme 2021-07-10 12:19:43 UTC
Compiles with gcc-11 when specifying C++14 standard instead of the now-default C++17

--- /var/db/gentoo/sys-power/nut/nut-2.7.4-r6.ebuild	2020-09-07 10:09:40.000000000 +0100
+++ /var/db/repos/localrepo/sys-power/nut/nut-2.7.4-r6999.ebuild	2021-07-10 13:16:07.408870230 +0100
@@ -113,7 +113,7 @@
 
 src_configure() {
 	local myconf
-	append-flags -fno-lto
+	append-flags -fno-lto -std=c++14
 	tc-export CC
 	tc-export CXX
 	tc-export AR
Comment 9 Jérôme Borme 2021-07-10 12:26:27 UTC
appendflags -std=c++14 makes it build with all non-masked version of gcc (tested gcc-8.4.0-r2, 9.3.0-r2, 10.3.0-r2, 11.1.0-r2)
Comment 10 Gary E. Miller 2021-07-20 02:43:00 UTC
See also: https://bugs.gentoo.org/show_bug.cgi?id=786702
Comment 11 Sam James archtester gentoo-dev Security 2021-08-04 19:32:32 UTC

*** This bug has been marked as a duplicate of bug 786702 ***
Comment 12 Sam James archtester gentoo-dev Security 2021-08-04 19:32:38 UTC
(In reply to Gary E. Miller from comment #10)
> See also: https://bugs.gentoo.org/show_bug.cgi?id=786702

Thanks!