Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 801310 - sys-kernel/gentoo-sources: BUG: kernel NULL pointer dereference, RIP rb_erase in cleanup_net in ipv6_frags_exit_net
Summary: sys-kernel/gentoo-sources: BUG: kernel NULL pointer dereference, RIP rb_erase...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-09 11:07 UTC by Nuno
Modified: 2021-08-18 15:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno 2021-07-09 11:07:47 UTC
Sorry if this is not the right place to report this.

I've been using kernel 5.12.13-gentoo-dist for couple weeks now with no issues.

However, yesterday, after some ~11 days of uptime (with a few suspends in between), I got the following crash:



kernel: BUG: kernel NULL pointer dereference, address: 0000000000000000
kernel: #PF: supervisor read access in kernel mode
kernel: #PF: error_code(0x0000) - not-present page
kernel: PGD 0 P4D 0 
kernel: Oops: 0000 [#1] SMP NOPTI
kernel: CPU: 2 PID: 18869 Comm: kworker/u16:80 Tainted: G        W         5.12.13-gentoo-dist #1
kernel: Hardware name: LENOVO 20S0000HPG/20S0000HPG, BIOS N2XET29W (1.19 ) 03/23/2021
kernel: Workqueue: netns cleanup_net
kernel: RIP: 0010:rb_erase+0x106/0x350
kernel: Code: 00 00 48 89 10 48 8b 02 a8 01 0f 84 35 02 00 00 48 83 e0 fc 75 01 c3 48 89 d1 48 89 c2 48 8b 42 08 48 39 c8 75 af 48 8b 42 10 <f6> 00 01 0f 84 1d 01 00 00 48 8b 70 10 48 85 f6 74 05 f6 06 01 74
kernel: RSP: 0018:ffffb42a45f2fd90 EFLAGS: 00010246
kernel: RAX: 0000000000000000 RBX: ffff954919ed4300 RCX: 0000000000000000
kernel: RDX: ffff954b90417b10 RSI: ffff954a75550150 RDI: ffff954b90417ad0
kernel: RBP: ffffffff8cf1e580 R08: ffff954919ed4350 R09: 0000000000000000
kernel: R10: ffff954b90417af0 R11: 0000000000000000 R12: ffff954b90417a80
kernel: R13: ffff954919ed5c40 R14: ffff9549283a9420 R15: ffff9549283a93d4
kernel: FS:  0000000000000000(0000) GS:ffff954c4f680000(0000) knlGS:0000000000000000
kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
kernel: CR2: 0000000000000000 CR3: 0000000419410006 CR4: 00000000003706e0
kernel: Call Trace:
kernel:  drop_sysctl_table+0xae/0x150
kernel:  unregister_sysctl_table.part.0+0x3b/0x90
kernel:  ipv6_frags_exit_net+0x1a/0x40
kernel:  ops_exit_list+0x33/0x60
kernel:  cleanup_net+0x1e0/0x310
kernel:  process_one_work+0x21d/0x3b0
kernel:  worker_thread+0x50/0x400
kernel:  ? process_one_work+0x3b0/0x3b0
kernel:  kthread+0x11b/0x140
kernel:  ? __kthread_bind_mask+0x60/0x60
kernel:  ret_from_fork+0x1f/0x30
kernel: Modules linked in: uas usb_storage tcp_diag inet_diag cdc_acm squashfs loop ccm ppp_deflate bsd_comp ppp_async ppp_generic slhc vhost_net vhost vhost_iotlb tap tun veth fuse uinput rfcomm zram nf_conntrack_netlink nfnetlink br_netfilter bridge stp llc overlay snd_soc_skl_hda_dsp snd_soc_hdac_hdmi cmac bnep snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic nf_log_ipv6 ip6t_REJECT nf_reject_ipv6 xt_hl ip6t_rt nf_log_ipv4 nf_log_common xt_LOG xt_recent xt_limit nf_conntrack_netbios_ns nf_conntrack_broadcast nf_nat_ftp nf_conntrack_f
Comment 1 Thomas Deutschmann gentoo-dev Security 2021-07-10 14:01:39 UTC
Looks like a bug in kernel, also seen on Fedora (https://abrt.fedoraproject.org/faf/reports/165213/).

Are you able to reproduce/trigger the bug?
Comment 2 Nuno 2021-07-10 15:14:53 UTC
Hi Thomas, thanks for looking into this.

Unfortunately I don't know what triggered the crash and it hasn't happened again yet.
Comment 3 Mike Pagano gentoo-dev 2021-08-18 15:44:15 UTC
(In reply to Nuno from comment #2)
> Hi Thomas, thanks for looking into this.
> 
> Unfortunately I don't know what triggered the crash and it hasn't happened
> again yet.

Thanks for the reply.  Please re-open this if this reappears