Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80026 - udev doesn't create device nodes for nvidia and sound
Summary: udev doesn't create device nodes for nvidia and sound
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Greg Kroah-Hartman (RETIRED)
: 116513 (view as bug list)
Depends on:
Reported: 2005-01-29 21:57 UTC by Timo Gurr (RETIRED)
Modified: 2005-12-23 13:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Timo Gurr (RETIRED) gentoo-dev 2005-01-29 21:57:51 UTC
I found a similiar bug report but my problem seems to be different since I never had this issue on any of my other systems running with x86.

I already re-emerged both, baselayout and udev without any result.

Reproducible: Always
Steps to Reproduce:
wormhole psy # cd /dev
wormhole dev # ls -la | grep sound
wormhole dev # ls -la | grep nvidia

Actual Results:  
wormhole dev # ls -la | grep sound
lrwxrwxrwx   1 root root        10 29. Jan 06:51 adsp -> sound/adsp
lrwxrwxrwx   1 root root        11 29. Jan 06:51 audio -> sound/audio
lrwxrwxrwx   1 root root         9 29. Jan 06:51 dsp -> sound/dsp
lrwxrwxrwx   1 root root        11 29. Jan 06:51 mixer -> sound/mixer
drwxr-xr-x   2 root root       120 29. Jan 06:51 sound
wormhole dev # ls -la | grep nvidia
crw-rw----   1 root video 195,   0 29. Jan 06:51 nvidia0
crw-rw----   1 root video 195, 255 29. Jan 06:51 nvidiactl

Also it seems that the udev deamon is not started on boot:
wormhole dev # ps ax | grep udev
 6588 pts/1    S+     0:00 grep udev
wormhole dev # ps ax | grep udevd
 6592 pts/1    R+     0:00 grep udevd

Setting the RC_DEVICE_TARBALL to "YES" also didn't solve my problems since the
device nodes disappear after reboot.

wormhole dev # emerge info
Portage 2.0.51-r15 (default-linux/amd64/2004.3, gcc-3.4.3,
glibc-, 2.6.10-gentoo-r6 x86_64)
System uname: 2.6.10-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Jan 23 2005, 03:07:09)]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.4, 1.5, 1.8.5-r2, 1.6.3, 1.7.9, 1.4_p6
sys-devel/libtool:   1.5.10-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -ftracer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -ftracer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
USE="amd64 X aalib acpi alsa berkdb bitmap-fonts cdr crypt dvd f77 fam flac
font-server fortran gif gpm gstreamer imlib ipv6 java jp2 jpeg kde lzw lzw-tiff
mad motif multilib mysql ncurses nls nptl nptlonly oggvorbis opengl oss pam perl
png python qt readline samba ssl tcpd tiff truetype truetype-fonts type1-fonts
usb userlocales xml2 xpm xrandr xv zliblinguas_de"
Comment 1 SpanKY gentoo-dev 2005-01-29 22:44:59 UTC
what version of udev ?
what version of nvidia-kernel ?
what ALSA / OSS driver are you using ?
what does it say during boot ? does it say 'Configuring system to use udev' or 'Starting devfsd' ?
what does `cat /proc/mounts` show ?

works fine for me with 2.6.10 / nvidia-kernel-1.0.6629 / alsa
Comment 2 Timo Gurr (RETIRED) gentoo-dev 2005-01-30 01:14:54 UTC
Version of udev: udev-050
Version of nvidia-kernel: nvidia-kernel-1.0.6629-r3
Version of ALSA / OSS driver: the one in the current gentoo-dev-sources-2.6.10-r6
On boot it displays: 
Mounting /dev for udev ...
Configuring system to use udev ...
Populating /dev with device nodes ...
`cat /proc/mounts` shows:
wormhole psy # cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / xfs rw,noatime 0 0
none /proc proc rw,nodiratime 0 0
none /sys sysfs rw 0 0
none /dev tmpfs rw 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
none /proc/bus/usb usbfs rw 0 0

If I create the nvidia device nodes manually they are still there after reboot but once I do a "udevstart" to get my sound devices, too they are all missing after the next reboot.

Comment 3 SpanKY gentoo-dev 2005-01-30 02:04:32 UTC
/sbin/udevstart is executed right after /dev is populated with device nodes:
            ebegin "Configuring system to use udev"
            if [[ ${RC_DEVICE_TARBALL} = "yes" ]] && [[ -s /lib/udev-state/devices.tar.bz2 ]]
                einfo "  Populating /dev with device nodes ..."
                try tar -jxpf /lib/udev-state/devices.tar.bz2 -C /dev
populate_udev() {
    # Make sure we do not have udevd from initramfs running
    killall -q udevd
    # Now populate /dev

if you re-emere udev/baselayout, does it fix things ?
Comment 4 Timo Gurr (RETIRED) gentoo-dev 2005-01-30 12:07:38 UTC
The lines in my /sbin/rc seem to be identical to the ones you posted.
I already re-emerged both udev and baselayout as stated above but did it once again to be sure. It didn't want to etc-update any config files and my problem isn't solved yet, too.
If I can provide further information about my system please let me know.
Comment 5 Greg Kroah-Hartman (RETIRED) gentoo-dev 2005-02-08 13:36:13 UTC
Does udev 051 release fix this for you?
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2005-02-08 15:12:34 UTC
I am afraid not, same behavior with udev 051 as with udev 050.
Perhaps it is some kind of issue with the 2004.3 stage3 install, as soon as the 2005.0 profile becomes stable I'll reinstall and report back.
Comment 7 Greg Kroah-Hartman (RETIRED) gentoo-dev 2005-02-11 11:50:56 UTC
ok, marking it test-request for now then.
Comment 8 Timo Gurr (RETIRED) gentoo-dev 2005-02-17 12:41:30 UTC
I did a bit of experiment and now it finally works if I add an extra line of "/sbin/udevstart" in /etc/init.d/alsasound like the following:

        for DRIVER in ${DRIVERS}
                if [ ! "${DRIVER}" = off ] &&
                   [ -z `cut -d' ' -f1 /proc/modules | egrep "^${DRIVER}\$"` ] $
                   [ -z `cut -d' ' -f1 /proc/modules | egrep "^${DRIVER//-/_}\$$
                        ebegin "  Loading: ${DRIVER}"
                        /sbin/modprobe ${DRIVER}
                        eend $?

        sleep 1

Just a dirty hack though, sorry.
But feel free to close the report if you want since it seems that I am the only one experiencing this kind of problem.
Comment 9 Timo Gurr (RETIRED) gentoo-dev 2005-08-07 19:05:54 UTC
I don't have this issue anymore and the modification posted above is also not  
necessary on my system anymore. 
Please feel free to close this one. 
Comment 10 Greg Kroah-Hartman (RETIRED) gentoo-dev 2005-08-08 11:24:26 UTC
Ok, marking as closed.
Comment 11 Stefan de Konink 2005-12-02 14:40:21 UTC
Nvidia problems are back, I found in bugzilla a solution for my 'suddenly' not
starting X11 with the nvidia binary module, though nv worked.

We are talking about:
sys-fs/udev-073 starts again after mknod the /dev/nvidia0 and /dev/nvidiactl
Comment 12 Greg Kroah-Hartman (RETIRED) gentoo-dev 2005-12-07 12:47:00 UTC
udev has nothing to do with the nvidia driver anymore.  Please file a new bug
with the nvidia package.
Comment 13 Greg Kroah-Hartman (RETIRED) gentoo-dev 2005-12-23 13:06:01 UTC
*** Bug 116513 has been marked as a duplicate of this bug. ***