Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 800203 - dev-libs/boost-1.76.0-r1 - ?
Summary: dev-libs/boost-1.76.0-r1 - ?
Status: RESOLVED DUPLICATE of bug 724314
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-03 19:15 UTC by Mateusz Piwek
Modified: 2021-07-06 13:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=dev-libs/boost-1.76.0-r1::gentoo' (emerge_info.txt,6.10 KB, text/plain)
2021-07-03 19:15 UTC, Mateusz Piwek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piwek 2021-07-03 19:15:36 UTC
Created attachment 721306 [details]
emerge --info '=dev-libs/boost-1.76.0-r1::gentoo'

dev-libs/boost-1.76.0-r1 fails to compile due to: 
*** stack smashing detected ***: terminated
In file included from libs/serialization/src/xml_wgrammar.cpp:146:
libs/serialization/src/basic_xml_grammar.ipp: In constructor ‘boost::archive::basic_xml_grammar<CharType>::basic_xml_grammar() [with CharType = wchar_t]’:
libs/serialization/src/basic_xml_grammar.ipp:364:9: internal compiler error: Aborted
  360 |         str_p(BOOST_ARCHIVE_XML_CLASS_NAME())
      |         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  361 |         >> Eq
      |         ~~~~~
  362 |         >> L'"'
      |         ~~~~~~~
  363 |         >> ClassName
      |         ~~~~~~~~~~~~
  364 |         >> L'"'
      |         ^~~~~~~
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
...failed updating 2 targets...
 * ERROR: dev-libs/boost-1.76.0-r1::gentoo failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  125:  Called src_compile
 *   environment, line 3344:  Called multilib-minimal_src_compile
 *   environment, line 2050:  Called multilib_foreach_abi 'multilib-minimal_abi_src_compile'
 *   environment, line 2320:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 1997:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 1995:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_compile'
 *   environment, line  539:  Called multilib-minimal_abi_src_compile
 *   environment, line 2044:  Called multilib_src_compile
 *   environment, line 2532:  Called die
 * The specific snippet of code:
 *       ejam --prefix="${EPREFIX}"/usr "${OPTIONS[@]}" || die;
 * 
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.76.0-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.76.0-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/boost-1.76.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/boost-1.76.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/boost-1.76.0-r1/work/boost_1_76_0-abi_x86_64.amd64'
 * S: '/var/tmp/portage/dev-libs/boost-1.76.0-r1/work/boost_1_76_0'
Comment 1 Mike Gilbert gentoo-dev 2021-07-04 00:31:18 UTC
Please attach the full build log.
Comment 2 Sam James archtester gentoo-dev Security 2021-07-04 00:48:46 UTC
1. what floppym said.

2. This, on the face of it, smells like bug 724314, given it's a first-gen Ryzen. 

If it's not, you'll be able to get somewhere using this guide: https://wiki.gentoo.org/wiki/Gcc-ICE-reporting-guide.

*** This bug has been marked as a duplicate of bug 724314 ***
Comment 3 Mateusz Piwek 2021-07-06 09:24:03 UTC
Portage 3.0.18 (python 3.8.9-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-10.2.0, glibc-2.33, 5.10.27-gentoor1 x86_64)
=================================================================
System uname: Linux-5.10.27-gentoor1-x86_64-AMD_Ryzen_7_1700_Eight-Core_Processor-with-glibc2.2.5
KiB Mem:    16414320 total,  12744344 free
KiB Swap:   33656828 total,  33656828 free
Timestamp of repository gentoo: Fri, 02 Jul 2021 00:45:01 +0000
Head commit of repository gentoo: 6062a099d7ab5547a6396d71275927a725df4de0
sh bash 5.1_p8
ld GNU ld (Gentoo 2.35.2 p1) 2.35.2
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          2.7.18_p9::gentoo, 3.7.10_p3::gentoo, 3.8.9_p2::gentoo, 3.9.5_p2::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/cmake:           3.18.5::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.35.2::gentoo
sys-devel/gcc:            10.2.0-r5::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver1 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=znver1 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -march=znver1 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=znver1 -pipe"
GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirror.bytemark.co.uk/gentoo/ http://mirrors.evowise.com/gentoo/"
LANG="en_US.utf8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 amr branding bzip2 cairo cdda cdr cli crypt css cups dbus declarative dri dts dvb dvd dvdr elogind emboss encode exif flac fortran gd gdbm geoip gif glut gtk gui h323 hvm iconv icu id3tag idn imagemagic jbig jpeg jpeg2k kde kipi kwallet ladspa lcms libglvnd libnotify libtirpc lzma mad matroska mng mp3 mp4 mpeg mplayer multilib musepack nas ncurses nls nptl ogg openal openexr opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qemu qml qt5 quicktime raw readline screen sdl seccomp semantic-desktop speex spell split-usr ssl startup-notification svg tcpd theora tiff truetype udev udisks unicode upower usb v4l vcd vorbis wavpack widgets wxwidgets x264 xattr xcb xend xml xpm xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="pl ru en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 4 Mateusz Piwek 2021-07-06 13:50:59 UTC
Following clues form 724314, I did compiled successfully dev-libs/boost with GCC with 'debug' USE flag enabled. So, issue has been resolved.