Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79759 - mistaken dependency logic in opengl-update-2.1_pre4.ebuild blocks packages
Summary: mistaken dependency logic in opengl-update-2.1_pre4.ebuild blocks packages
Status: RESOLVED DUPLICATE of bug 79606
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-01-27 11:33 UTC by Torsten Kurbad
Modified: 2005-07-17 13:06 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Kurbad 2005-01-27 11:33:03 UTC

In the mentioned ebuild the following lines in RDEPEND


are better changed to


(Not lower than is equivalent to greater than or equal - not quite a mathematical mystery... ;o)

Portage obviously doesn't support the cumbersome logic and reports that the respective packages are blocked by opengl-update.


Reproducible: Always
Steps to Reproduce:
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-27 19:48:15 UTC
That would create a circular dependency in the case of xorg-x11, which is a no-no. new xorg depends on >=opengl-update-1.99, so for opengl-update-2 to depend on new xorg would make it impossible to get either of them when starting with neither.

The "answer" to this is blocking lower versions, which allows the circle to work with a little annoyance -- uninstalling xorg before upgrading to the new one. Although this isn't perfect, it's better than the alternative of allowing a broken combination of new opengl-update and old xorg.

In the ati-drivers case, it's not a dependency, it's something that can't be simultaneously installed with new opengl-update. Thus changing it to >= would actually be wrong. So in this case, '!<' != '>='.

In summary, the first one is impossible because of a circular dependency and the second is incorrect.

CC'ing committer so he can see the discussion.
Comment 2 Christoph Budziszewski 2005-02-02 11:07:48 UTC
Here is a nicer workaround:
 emerge --nodeps xorg-x11  
and then
 emerge -uD world

works for me.
Comment 3 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-02 11:34:28 UTC
You should be able to update xorg-x11 to -r4 or .901 using opengl-update-2.0_pre*, but 2.1 relies on the X11 libs being installed in /usr/lib{,32,64} rather than /usr/X11R6/lib{,32,64}

Comment 4 Torsten Kurbad 2005-02-07 10:16:47 UTC
After updating to one half of the problem is gone, the other persists:

It should really be

since media-video/ati-drivers-8.8.25-r3 insists on

Thus, with
the whole thing becomes mutually exclusive and blocks portage!

Would be nice, if someone could have a look into that again!
Comment 5 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-07 11:56:24 UTC
Torsten: Yes, it should work fine if you do emerge -v ati-drivers && emerge -uvD world
Comment 6 Tor Klingberg 2005-03-13 12:10:23 UTC
Are the portage developers aware of this circluar dependancy problem? This really something portage should be able to take care of.
Comment 7 Jeremy Huddleston (RETIRED) gentoo-dev 2005-03-13 13:22:11 UTC
Yes, they are aware of the problem, but due to lack of developer resources and interest, it is not a high priority...
Comment 8 Mark Purtill 2005-03-19 14:08:38 UTC
Is there a bug for emerge not handling situation like this and bug 85519?  If not, should there be?
Comment 9 Jeremy Huddleston (RETIRED) gentoo-dev 2005-04-10 14:08:35 UTC
dupe of #79606
Comment 10 Jeremy Huddleston (RETIRED) gentoo-dev 2005-04-10 14:08:50 UTC

*** This bug has been marked as a duplicate of 79606 ***