I am trying to update the system to python3.9, during the emerge process I get the API error for sip vs PyQt5 when trying to update dev-python/python-poppler-qt5-0.75.0
I have installed latest stable PyQt5 and sip packages (and emerged twice):
# emerge -pv PyQt5 sip
These are the packages that would be merged, in order:
Calculating dependencies *
[ebuild R ~] dev-python/sip-5.5.0-r2:5::gentoo USE="-doc" PYTHON_TARGETS="python3_8 python3_9 -python3_10" 0 KiB
[ebuild R ] dev-python/PyQt5-5.15.2::gentoo USE="bluetooth dbus examples gui help network opengl printsupport sql ssl svg webchannel webkit widgets -debug -declarative -designer -gles2-only -location -multimedia -networkauth -positioning -sensors -serialport -testlib -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python3_8 python3_9" 0 KiB
Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB
but I can see the problem importing the PyQt5 python module:
Python 3.9.5 (default, Jun 15 2021, 19:14:08)
Type 'copyright', 'credits' or 'license' for more information
IPython 7.23.1 -- An enhanced Interactive Python. Type '?' for help.
In : from PyQt5 import QtCore
RuntimeError Traceback (most recent call last)
<ipython-input-1-38dd74477490> in <module>
----> 1 from PyQt5 import QtCore
RuntimeError: the sip module implements API v12.0 to v12.7 but the PyQt5.QtCore module requires API v12.8
> I have installed latest stable PyQt5 and sip packages
Not really. You have sip-5.5.0-r2 which is in ~arch. Though I don't think this is the problem.
What version of PyQt5-sip do you have?
(In reply to Davide Pesavento from comment #1)
> > I have installed latest stable PyQt5 and sip packages
> Not really. You have sip-5.5.0-r2 which is in ~arch. Though I don't think
> this is the problem.
> What version of PyQt5-sip do you have?
Oh yeah, you are right. dev-python/sip:5 is not stable :-P
I have installed dev-python/PyQt5-sip-4.19.25
Upgrading to PyQt5-sip-12.9.0 should fix your problem. Or downgrade dev-python/sip to the stable version and then re-emerge PyQt5.
I confirm that upgrading to dev-python/PyQt5-sip-12.9.0 solves the problem. Is then a matter of fixing the deps? Thanks
The bug has been closed via the following commit(s):
Author: Davide Pesavento <email@example.com>
AuthorDate: 2021-08-02 00:33:25 +0000
Commit: Davide Pesavento <firstname.lastname@example.org>
CommitDate: 2021-08-02 00:34:31 +0000
dev-python/PyQt5: add 5.15.5_pre2107091435, EAPI 8
Switched the build system to use sip-build + PyQt-builder
instead of the deprecated configure.py
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Davide Pesavento <email@example.com>
dev-python/PyQt5/Manifest | 1 +
dev-python/PyQt5/PyQt5-5.15.5_pre2107091435.ebuild | 190 +++++++++++++++++++++
profiles/package.mask | 1 +
3 files changed, 192 insertions(+)