Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 7969 - nss-mysql + tar has issues
Summary: nss-mysql + tar has issues
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux MySQL bugs team
Depends on:
Blocks: 79302
  Show dependency tree
Reported: 2002-09-15 17:24 UTC by Christian Skarby
Modified: 2005-01-25 06:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

nss-mysql.0.43.tar.bz2 (nss-mysql.0.43.tar.bz2,3.03 KB, application/bzip2)
2002-09-24 15:56 UTC, Christian Skarby

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Skarby 2002-09-15 17:24:54 UTC
Somehow gzip sometimes do not work from
manually doing the same command (line 24 of unpack) works flawlessly
and both regards all packages with distfiles/*tar.gz (tar included)

palpable is running gentoo-1.4_beta on gcc-3.2-r1
I've also had the same problem on another system running the default-1.0 profile

Somehow the problem disappeared on the other box, nevertheless I cannot recall
doing anything there that should explain the "recovery" to a healty state.

[palpable] root:/usr/portage.local# emerge evms
Calculating dependencies ...done!
>>> emerge sys-apps/evms-1.1.0 to /
>>> md5 ;-) evms-1.1.0.tar.gz
>>> Unpacking source...
>>> Unpacking evms-1.1.0.tar.gz
/usr/sbin/ line 24:  3821 Segmentation fault      tar xz
--no-same-owner -f ${DISTDIR}/${x}

!!! ERROR: The ebuild did not complete successfully.
!!! Function unpack, Line 24, Exitcode 139
!!! failure unpacking evms-1.1.0.tar.gz

Comment 1 Christian Skarby 2002-09-15 17:42:58 UTC
and .. well .. both (at least palpable) runs on portage-2.0.36
Comment 2 SpanKY gentoo-dev 2002-09-15 18:29:03 UTC
with what version of portage did this occur ?
Comment 3 Christian Skarby 2002-09-16 01:01:37 UTC
Seems like I have managed to find what indirectly is causing this;
I am using nss-mysql and when my nsswitch.conf reads

passwd: files mysql
shadow: files mysql
group:  files mysql

emerge seems to break

changeing to

passwd: files
shadow: files
group:  files

before using emerge makes everything work.

From this I get that:
1) either portage or nss-mysql has a serious bug
2) if it is a portage problem it might have something to do with sandbox, 
   or maybe something else; is there something doing checks for valid
3) Something worth to investigate: will using nscd aviod this behavior?

I'll put further investigation into the matter as soon as I've got time

Comment 4 Christian Skarby 2002-09-16 01:31:36 UTC
Running nscd does aswell cancel the problem.
Somehow something times out(?) when doing it the slow way (mysql), so nscd is a
good idea when running nss-mysql

Comment 5 Nicholas Jones (RETIRED) gentoo-dev 2002-09-23 11:35:47 UTC
I'm a little under the knownledge of what exactly this does. I get the
idea from the bug report.

Do you have a solution to this that you can incorportate into the
ebuild you submitted for nss-mysql?

I can't test this or fix it. Can you?
Comment 6 Christian Skarby 2002-09-24 15:56:40 UTC
Created attachment 4139 [details]
Comment 7 Christian Skarby 2002-09-24 16:09:04 UTC
I don't think it is wise to enable nscd for the user. She/he should do it him/herself, have added an 
advisory suggesting to enable nscd that shows up when emerging / doing the ebuild nss-
mysql.0.43.ebuild config.

nscd (name service cache daemon) is a part of glibc and caches 
information (probably all information going through nss - see /etc/nsswitch) 

Comment 8 Michael Swain 2003-01-11 10:57:55 UTC
I ran acress this problem as well, and even with .43 it happens, but it is a
problem with tar its self and not the decompessor (I verified this by modifying
the to break apart decomp and tar.) when I first ran an strace it
seemed to crash after tryign to load libnss_db (which I do not have.) but it
seems that the problem stems form somehow doing a gentent agains mysql while tar
is running. If anyone knows the commands I can run an strace against a simple
ebuild and provide them to hopefully solve this problem.
Comment 9 Sean Woods 2003-04-15 17:47:19 UTC
I have gotten the system to work properly after re-emerging binutils.

The problem is related to the version of GLIBC your initial bootkit was linked against. A change in GLIBC 3.2 broke the NSS library.
Comment 10 Marius Mauch (RETIRED) gentoo-dev 2003-10-09 14:31:18 UTC
So is this still a problem and has it to do with portage itself?
Comment 11 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-01-05 19:20:36 UTC
this is not a portage problem, it's a problem with nss-mysql. i've seen it with nss-ldap as well.
Comment 12 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-14 15:37:48 UTC
closing as per comment #9.
Comment 13 Mathy Vanvoorden 2004-08-25 07:41:55 UTC
I'm having the same issues, and re-emerging binutils (or glibc) didn't do the trick. I also tried to use nscd, didn't work either.
Comment 14 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-25 07:51:17 UTC
matje: recompile your nss modules.
Comment 15 Mathy Vanvoorden 2004-08-25 08:04:56 UTC
My apoligies, apparently nscd does work, it didn't run properly over here, now it does. For as far as I can tell, the bug is located in nss-mysql, I think it returns control too soon without returning the requested info. Nscd seems to catch this error.

I have found another solution: adding --numeric-owner to $tarvars in, this makes tar not ask the info it wants (about the username of the developer), which you don't need anyway. I find it strange that untarring it manually does work though, no errors then. I'll post another bug for the portage developers so they can change this as they seem fit.
Comment 16 Mathy Vanvoorden 2004-08-25 08:05:25 UTC
Recompiling the nss-modules didn't work