Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79657 - py-asterisk (New Package)
Summary: py-asterisk (New Package)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD, InVCS
Depends on:
Blocks:
 
Reported: 2005-01-26 18:01 UTC by Stefan Knoblich (RETIRED)
Modified: 2012-09-11 12:12 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
diff for the current ebuild version (20050127) (asterisk-1.0.5.ebuild.diff,6.54 KB, patch)
2005-01-27 15:51 UTC, Stefan Knoblich (RETIRED)
Details | Diff
required patch (20050127) (asterisk-1.0.2-astconfig-0.0.2.diff,5.69 KB, patch)
2005-01-27 15:52 UTC, Stefan Knoblich (RETIRED)
Details | Diff
app_ldap-0.8 ebuild (asterisk-app_ldap-0.8.ebuild,669 bytes, text/plain)
2005-01-27 15:54 UTC, Stefan Knoblich (RETIRED)
Details
asterisk-config patch for app_ldap (app_ldap-0.8-astcfg.diff,752 bytes, patch)
2005-01-27 15:55 UTC, Stefan Knoblich (RETIRED)
Details | Diff
chan_bluetooth ebuild (asterisk-chan_bluetooth-0.0.1_pre38.ebuild,691 bytes, text/plain)
2005-01-27 15:55 UTC, Stefan Knoblich (RETIRED)
Details
asterisk-config patch for chan_bluetooth (chan_bluetooth-0.0.0-astcfg.diff,1.48 KB, patch)
2005-01-27 15:56 UTC, Stefan Knoblich (RETIRED)
Details | Diff
ebuild for app_iconv-0.8 (asterisk-app_iconv-0.8.ebuild,720 bytes, text/plain)
2005-01-29 13:38 UTC, Stefan Knoblich (RETIRED)
Details
patch for app_iconv to use asterisk-config (app_iconv-0.8-astcfg.diff,714 bytes, patch)
2005-01-29 13:38 UTC, Stefan Knoblich (RETIRED)
Details | Diff
py-asterisk-0.1a3 ebuild (Python bindings for asterisk) (py-asterisk-0.1_alpha3.ebuild,581 bytes, text/plain)
2005-01-29 14:03 UTC, Stefan Knoblich (RETIRED)
Details
ebuild for chan_capi-0.3.5 (asterisk-chan_capi-0.3.5.ebuild,1004 bytes, text/plain)
2005-01-29 16:13 UTC, Stefan Knoblich (RETIRED)
Details
required patch for chan_capi ebuild (chan_capi-0.3.5-gentoo.diff,1.09 KB, patch)
2005-01-29 16:13 UTC, Stefan Knoblich (RETIRED)
Details | Diff
asterisk-chan-capi-0.3.5.ebuild (asterisk-chan-capi-0.3.5.ebuild,1.68 KB, text/plain)
2005-02-07 01:43 UTC, Chris Bainbridge (RETIRED)
Details
asterisk-chan-capi/ChangeLog (ChangeLog,255 bytes, text/plain)
2005-02-07 01:45 UTC, Chris Bainbridge (RETIRED)
Details
asterisk-chan-capi-0.3.5.ebuild (asterisk-chan-capi-0.3.5.ebuild,1.75 KB, text/plain)
2005-02-07 02:14 UTC, Chris Bainbridge (RETIRED)
Details
asterisk-chan-capi-0.3.5.ebuild (asterisk-chan-capi-0.3.5.ebuild,1.73 KB, text/plain)
2005-02-09 07:37 UTC, Chris Bainbridge (RETIRED)
Details
ebuild for py-asterisk-0.1_alpha2 (py-asterisk-0.1_alpha2.ebuild,731 bytes, text/plain)
2008-07-06 04:01 UTC, Jesus Rivero (RETIRED)
Details
ebuild for py-asterisk-0.1_alpha2 - corrected keywords (py-asterisk-0.1_alpha2.ebuild,731 bytes, text/plain)
2008-07-06 04:07 UTC, Jesus Rivero (RETIRED)
Details
ebuild for py-asterisk-0.1_alpha2 - corrected keywords. (py-asterisk-0.1_alpha2.ebuild,707 bytes, text/plain)
2008-07-06 04:10 UTC, Jesus Rivero (RETIRED)
Details
py-asterisk-0.1_alpha2.ebuild (py-asterisk-0.1_alpha2.ebuild,652 bytes, text/plain)
2008-07-12 21:53 UTC, Jesus Rivero (RETIRED)
Details
ebuild for py-asterisk-0.1_alpha2.ebuild (py-asterisk-0.1_alpha2.ebuild,645 bytes, text/plain)
2008-07-12 22:47 UTC, Jesus Rivero (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knoblich (RETIRED) gentoo-dev 2005-01-26 18:01:37 UTC
new version, new stuff:

* support for mysql + postgresql database backends for voicemail
* postgres support
* asterisk-config patch for external plugins (like app_ldap and chan_bluetooth)
* new version of chan_oh323 (-0.6.5, if i win the stkn vs. makefiles fight...)
* new (lots of brainfarts fixed) version of the zaptel devfs on linux-2.6 patch
  (confirmed user-base: 1)
* >maybe< the beginning (*sigh*) of running asterisk as non-root support
* and maybe other nice stuff if i get the time for that...

* new channel: #gentoo-voip @ irc.freenode.net
Comment 1 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:51:45 UTC
Created attachment 49698 [details, diff]
diff for the current ebuild version (20050127)
Comment 2 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:52:27 UTC
Created attachment 49699 [details, diff]
required patch (20050127)
Comment 3 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:54:33 UTC
Created attachment 49700 [details]
app_ldap-0.8 ebuild
Comment 4 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:55:16 UTC
Created attachment 49701 [details, diff]
asterisk-config patch for app_ldap
Comment 5 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:55:58 UTC
Created attachment 49702 [details]
chan_bluetooth ebuild
Comment 6 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-27 15:56:59 UTC
Created attachment 49703 [details, diff]
asterisk-config patch for chan_bluetooth
Comment 7 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-29 13:38:02 UTC
Created attachment 49879 [details]
ebuild for app_iconv-0.8
Comment 8 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-29 13:38:41 UTC
Created attachment 49880 [details, diff]
patch for app_iconv to use asterisk-config
Comment 9 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-29 14:03:13 UTC
Created attachment 49882 [details]
py-asterisk-0.1a3 ebuild (Python bindings for asterisk)

Doesn't depend on asterisk-config (should work with other versions)
Comment 10 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-29 16:13:17 UTC
Created attachment 49890 [details]
ebuild for chan_capi-0.3.5

should work w/ all >=asterisk-1.0.0
Comment 11 Stefan Knoblich (RETIRED) gentoo-dev 2005-01-29 16:13:46 UTC
Created attachment 49891 [details, diff]
required patch for chan_capi ebuild
Comment 12 Chris Bainbridge (RETIRED) gentoo-dev 2005-02-07 01:43:57 UTC
Created attachment 50604 [details]
asterisk-chan-capi-0.3.5.ebuild

Updated asterisk-chan-capi ebuild. This ebuild was originally imported from
svn://gentoo.datacore.ch/read-only and was written by amir@datacore.ch. I added
a CAPI kernel check and Stefans patch.
Comment 13 Chris Bainbridge (RETIRED) gentoo-dev 2005-02-07 01:45:08 UTC
Created attachment 50605 [details]
asterisk-chan-capi/ChangeLog

Original Changelog from amir@datacore.ch
Comment 14 Chris Bainbridge (RETIRED) gentoo-dev 2005-02-07 02:14:41 UTC
Created attachment 50608 [details]
asterisk-chan-capi-0.3.5.ebuild

The original stkn ebuild fails when building in a sandbox. Reinserted the sed
line from amir ebuild.
Comment 15 Stefan Knoblich (RETIRED) gentoo-dev 2005-02-09 03:18:07 UTC
> The original stkn ebuild fails when building in a sandbox. Reinserted the sed
> line from amir ebuild.

Where does it fail? (I doubt that was my ebuild)

And btw. i won't accept the new ebuild in it's current state:

1)	sed -i -e "s:^INSTALL_PREFIX=$:INSTALL_PREFIX=${D}:" Makefile

unnecessary, make INSTALL_PREFIX=${D} ... does the trick

2)	insinto /usr/lib/asterisk/modules
	emake DESTDIR=${D} install || die "Make install failed"
	insinto /etc/asterisk
	emake DESTDIR=${D} config || die "Make config failed"

DESTDIR=${D} doesn't work, it's not used by the Makefile
(and one make line with both targets would be enough too)

insinto is wrong that's used with doins, for creating directories we have dodir
and that is not necessary either (see patch)
Comment 16 Chris Bainbridge (RETIRED) gentoo-dev 2005-02-09 07:37:54 UTC
Created attachment 50830 [details]
asterisk-chan-capi-0.3.5.ebuild

Yet another ebuild. Basically the same as stkn original with the capi kernel
check. Yup, DESTDIR etc. from the amir ebuild was unnecessary, thats why it
failed	with sandbox (not stkn ebuild).
Comment 17 Stefan Knoblich (RETIRED) gentoo-dev 2005-02-15 14:25:51 UTC
app_ldap-0.9.3
app_iconv-0.8
chan_bluetooth-0.0.1_pre2005021?

are in cvs now
Comment 18 Stefan Knoblich (RETIRED) gentoo-dev 2005-03-10 02:10:47 UTC
only thing left is py-asterisk
Comment 19 Jesus Rivero (RETIRED) gentoo-dev 2008-07-06 04:01:22 UTC
Created attachment 159674 [details]
ebuild for py-asterisk-0.1_alpha2

Best regards,
Comment 20 Jesus Rivero (RETIRED) gentoo-dev 2008-07-06 04:07:27 UTC
Created attachment 159675 [details]
ebuild for py-asterisk-0.1_alpha2 - corrected keywords
Comment 21 Jesus Rivero (RETIRED) gentoo-dev 2008-07-06 04:10:53 UTC
Created attachment 159676 [details]
ebuild for py-asterisk-0.1_alpha2 - corrected keywords.

Corrected Keywords.. sorry
Comment 22 Jesus Rivero (RETIRED) gentoo-dev 2008-07-12 21:53:29 UTC
Created attachment 160221 [details]
py-asterisk-0.1_alpha2.ebuild

Fixed
Comment 23 Jesus Rivero (RETIRED) gentoo-dev 2008-07-12 22:47:17 UTC
Created attachment 160223 [details]
ebuild for py-asterisk-0.1_alpha2.ebuild

Removed redundant inherit python
Comment 24 Łukasz Damentko (RETIRED) gentoo-dev 2008-08-11 00:32:47 UTC
Reassigning back to herd since Stefan has been retired as a Gentoo Developer (#27693).
Comment 25 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-04-29 17:38:00 UTC
Jesus, are you still interested by this package ?
Comment 26 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-05-17 21:37:07 UTC
No one to take this bug ?
If no one react, I will re-assign it to maintainer-wanted.
Comment 27 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-06-20 11:08:22 UTC
Assigning to maintainer-wanted
Comment 28 Arseny Solokha 2009-09-30 18:05:04 UTC
The latest release on project homepage is 0.1a3 which has been made 2004-10-06.

There's following message on the homepage:
"Are you a py-Asterisk user that would like to keep the project alive?
I am presently unable to work much on py-Asterisk much due to work and life pressures in general. However, I would very much like to see py-Asterisk continue to track the current state of Asterisk, and be useful to the community as a whole.

I have moved the project to Berlios in order to allow for easier participation from users and developers. Please contact the developer list if you would like access to this new project."

Latest useful thread in project -dev mailing list: https://lists.berlios.de/pipermail/py-asterisk-dev/2009-April/thread.html. The last question has no answer.

Last SVN commit: "Rev 173 - 2008-12-10 15:30:29 GMT * Create a new branch for César GarcÃa."

There's no visible changes for almost a year, and no maintainter to address to. Zombie?
Comment 29 Tony Vroon gentoo-dev 2012-09-11 12:12:23 UTC
As per research by Arseny Solokha, this appears to be well and truly dead upstream. As such, I can not and will not package this for the portage tree.