Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 793890 - net-im/telegram-desktop-2.7.4 stable request
Summary: net-im/telegram-desktop-2.7.4 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Esteve Varela Colominas
URL:
Whiteboard:
Keywords: CC-ARCHES, STABLEREQ
Depends on: 700902
Blocks:
  Show dependency tree
 
Reported: 2021-06-02 12:23 UTC by Esteve Varela Colominas
Modified: 2022-05-14 14:10 UTC (History)
6 users (show)

See Also:
Package list:
net-im/telegram-desktop-2.7.4-r1 amd64 media-libs/tg_owt-0_pre20210422 amd64 media-libs/libtgvoip-2.4.4_p20210302-r1 amd64 net-libs/usrsctp-0.9.5.0 amd64
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Esteve Varela Colominas 2021-06-02 12:23:41 UTC
Been using this for a month, no outstanding bug reports, seems to be working all-right, including voice/video calls.

Biggest dependency here is libvpx, I'm not sure if that would need a separate stable request.
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-02 12:30:51 UTC
I recommend avoiding manual CCing of arches just in case the sanity check doesn't pass.

We need to remember to CC maintainers of various packages to check they're okay with it if the version was not yet stable (as opposed to stabling it on a new arch, which is generally OK).
Comment 2 NATTkA bot gentoo-dev 2021-06-02 12:32:29 UTC Comment hidden (obsolete)
Comment 3 Esteve Varela Colominas 2021-06-02 13:47:35 UTC
Alright, adding rion4ik to CC to know if they're OK with this.
Comment 4 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-02 13:48:43 UTC
(In reply to Esteve Varela Colominas from comment #3)
> Alright, adding rion4ik to CC to know if they're OK with this.

Thanks!

Adding media-video@, chromium@ for libvpx 1.10.0.
Comment 5 Sergey Ilinykh 2021-06-02 13:56:13 UTC
usrsctp seems to work well. I'm Ok to stabilize.
Comment 6 Stephan Hartmann gentoo-dev 2021-06-02 14:21:53 UTC
(In reply to Sam James from comment #4)
> (In reply to Esteve Varela Colominas from comment #3)
> > Alright, adding rion4ik to CC to know if they're OK with this.
> 
> Thanks!
> 
> Adding media-video@, chromium@ for libvpx 1.10.0.

Chromium has no real business with libvpx anymore. We have to use bundled copy, because vaapi uses private libvpx API.
Comment 7 Georgy Yakovlev archtester gentoo-dev 2021-06-03 05:05:00 UTC
in 1c91884873968997be4b0c954169d04dc839f1db a patch was added to avoid voice recording crashes. I've update to -r1 if you don't mind.
Comment 8 Esteve Varela Colominas 2021-06-03 12:17:20 UTC
Oh, I wasn't aware of that bug. Thanks for patching it, I'll add voice recording to the list of things to test in the future.
Comment 9 Joe Kappus 2021-06-04 04:05:27 UTC
Sorry to spoil the party, I filed Bug #794094. I think it is likely just a missing dependency, I just don't know what specifically and it's been reproducible for a few weeks here.
Comment 10 Esteve Varela Colominas 2021-06-05 12:44:07 UTC
Disregard that, keep partying.
Comment 11 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-10 18:56:32 UTC
OK, shall we roll?
Comment 12 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-11 05:37:02 UTC
x86 done
Comment 13 Georgy Yakovlev archtester gentoo-dev 2021-06-11 09:00:27 UTC
Nattka went nuts?) etoomanyarches in CC.
Do only amd64 arm64 and x86. ppc64 optional and not recommend.

It will not work on big-endian arches like ppc or sparc.
Comment 14 Georgy Yakovlev archtester gentoo-dev 2021-06-11 09:01:12 UTC
Ah nvm, it’s for deps. /me hides
Comment 15 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-12 01:18:27 UTC
amd64 done
Comment 16 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-06-12 15:42:58 UTC
arm64 done
Comment 17 Rolf Eike Beer archtester 2021-06-25 13:20:22 UTC
Maybe then explicitely specify where you expect libvpx to work.
Comment 18 NATTkA bot gentoo-dev 2021-08-05 16:44:29 UTC
Unable to check for sanity:

> no match for package: net-im/telegram-desktop-2.7.4-r1
Comment 19 Andrey Aleksandrovich 2021-12-02 18:10:33 UTC
Obsolete?
Comment 20 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-04-12 06:52:51 UTC
(In reply to Andrey Aleksandrovich from comment #19)
> Obsolete?

It's not obsolete. Various arches aren't complete for the non-telegram-desktop packages.
Comment 21 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-05-11 00:59:59 UTC
Dropped stable sparc for libvpx in bug 700902.

arm already had libvpx done in bug 833741.

So, we're done. Finally. :)
Comment 22 Esteve Varela Colominas 2022-05-14 14:10:09 UTC
Thanks!